summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-python/pydantic/pydantic-1.9.0.ebuild3
1 files changed, 3 insertions, 0 deletions
diff --git a/dev-python/pydantic/pydantic-1.9.0.ebuild b/dev-python/pydantic/pydantic-1.9.0.ebuild
index 30c3c8a83e4c..45242111e134 100644
--- a/dev-python/pydantic/pydantic-1.9.0.ebuild
+++ b/dev-python/pydantic/pydantic-1.9.0.ebuild
@@ -35,6 +35,9 @@ src_prepare() {
}
python_test() {
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ local -x PYTEST_PLUGINS=pytest_mock
+
local EPYTEST_DESELECT=(
# flaky test, known upstream
tests/test_hypothesis_plugin.py::test_can_construct_models_with_all_fields