summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net-misc/gallery-dl/Manifest1
-rw-r--r--net-misc/gallery-dl/gallery-dl-1.25.7.ebuild40
2 files changed, 41 insertions, 0 deletions
diff --git a/net-misc/gallery-dl/Manifest b/net-misc/gallery-dl/Manifest
index b48501276256..94fb6fbb0cd6 100644
--- a/net-misc/gallery-dl/Manifest
+++ b/net-misc/gallery-dl/Manifest
@@ -1,2 +1,3 @@
DIST gallery-dl-1.25.5.gh.tar.gz 563928 BLAKE2B d8308233fc4e59da466825f5063556bffb31f8f710a75dca23b710244c1702569ffc46f41d0721e6bdcfd1ce5471d30872f8f931388db82a7ce918564d84ae75 SHA512 ed2e18a9220eb68bd93009b12212c4052893277cb585ded8b5c513c764d3efec348c0340360b5ccac6f98527fb0a9ddb93167e942e3151419169a4ad7353157f
DIST gallery-dl-1.25.6.gh.tar.gz 567710 BLAKE2B 85f4fe19a09d1569e431e18c821db6d7f581760f2065138a36f2c8523c632aac0f6bd2fc18154f9a9524e158525b604b67240fe139a97f1407d2178e9f668d99 SHA512 2ae93401598ca46458c22bca7f2a53fe611519c24c88156c6566b45a5073336e92310b7c60939782b619ede59c8b2862a0ed9811dd7f9307f8a080e5fbfdf3bc
+DIST gallery-dl-1.25.7.gh.tar.gz 570326 BLAKE2B b499d9dad019b6a209cb4ce1c6ef64867d0ab6327ca2131631ad7abf52c7541187886c0d3674152cea24d7cafb1c508c7c22ffd14a94737759beda3bffb38d4e SHA512 0fb86b074c54db615cc8fd276160ef42a5a58e839a88fe0acb24d3f27d3002f90d28e7e0eb6ca3606e3c4c7c8f56b7d8a103898ba375dd63ffea27e4c422b4c1
diff --git a/net-misc/gallery-dl/gallery-dl-1.25.7.ebuild b/net-misc/gallery-dl/gallery-dl-1.25.7.ebuild
new file mode 100644
index 000000000000..b3da2a9c870f
--- /dev/null
+++ b/net-misc/gallery-dl/gallery-dl-1.25.7.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} )
+PYTHON_REQ_USE="sqlite,ssl,xml(+)"
+
+inherit distutils-r1 optfeature
+
+DESCRIPTION="Download image galleries and collections from several image hosting sites"
+HOMEPAGE="https://github.com/mikf/gallery-dl"
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/mikf/${PN}.git"
+else
+ SRC_URI="https://github.com/mikf/${PN}/archive/v${PV}.tar.gz -> ${P}.gh.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~riscv ~x86"
+fi
+
+LICENSE="GPL-2"
+SLOT="0"
+# Tests require network access.
+PROPERTIES="test_network"
+RESTRICT="test"
+
+RDEPEND=">=dev-python/requests-2.11.0[${PYTHON_USEDEP}]"
+
+distutils_enable_tests setup.py
+
+python_compile_all() {
+ emake PYTHON=${EPYTHON} data/completion/{,_}gallery-dl man
+}
+
+pkg_postinst() {
+ optfeature "Pixiv Ugoira to WebM conversion" media-video/ffmpeg
+ optfeature "video downloads" net-misc/yt-dlp
+}