summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-python/diskcache/Manifest1
-rw-r--r--dev-python/diskcache/diskcache-5.6.3.ebuild42
2 files changed, 43 insertions, 0 deletions
diff --git a/dev-python/diskcache/Manifest b/dev-python/diskcache/Manifest
index 75557e310131..0ae5c9748094 100644
--- a/dev-python/diskcache/Manifest
+++ b/dev-python/diskcache/Manifest
@@ -1 +1,2 @@
DIST diskcache-5.6.1.gh.tar.gz 655959 BLAKE2B 95ba66a8c701796eec1bedcbb514e9288789d52887401f0687374f43c3bd31a502c7e0e0a1fe4b9df05c41a5a1e4efcda8986840749c170295544787e6fd7112 SHA512 a0a6847121089ffe727ec30bd94716d6ab78e5abd4cc8a3230c6ef034b27776be76ca223c3060af3150d2fceadcda670cbf7851c0f47624264342429b29b4f5d
+DIST diskcache-5.6.3.gh.tar.gz 655441 BLAKE2B bc2495862fec7dfffd50e84a7d68e04f42ae8f29c2273466a81e1ec8e82af33a8af3a1f40ac06563c656e48ea24e936402f6269ac498f8521b096e6457aa8df8 SHA512 476d677d88212aa3f9a6e8d12c3e7076cc6a06973d703ed0b2c550b4b4e916b24fb7d8f33c7174854015886fab26e2707b134328d2bc3e144aef5510e7bc0f7c
diff --git a/dev-python/diskcache/diskcache-5.6.3.ebuild b/dev-python/diskcache/diskcache-5.6.3.ebuild
new file mode 100644
index 000000000000..f99c99d9182d
--- /dev/null
+++ b/dev-python/diskcache/diskcache-5.6.3.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+PYTHON_REQ_USE="sqlite"
+
+inherit distutils-r1
+
+HOMEPAGE="
+ https://grantjenks.com/docs/diskcache/
+ https://github.com/grantjenks/python-diskcache/
+ https://pypi.org/project/diskcache/
+"
+DESCRIPTION="Disk and file backed cache"
+SRC_URI="
+ https://github.com/grantjenks/python-diskcache/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+S=${WORKDIR}/python-diskcache-${PV}
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+BDEPEND="
+ test? (
+ >=dev-python/django-3.2[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_sphinx docs
+distutils_enable_tests pytest
+
+src_prepare() {
+ # remove dep on pytest-xdist and pytest-cov
+ sed -i -e '/-n auto/d' -e '/--cov/d' tox.ini || die
+
+ distutils-r1_src_prepare
+}