summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--games-fps/quake1-killer/quake1-killer-2.2z-r1.ebuild (renamed from games-fps/quake1-killer/quake1-killer-2.2z.ebuild)17
1 files changed, 6 insertions, 11 deletions
diff --git a/games-fps/quake1-killer/quake1-killer-2.2z.ebuild b/games-fps/quake1-killer/quake1-killer-2.2z-r1.ebuild
index 258296f7f514..f7b2c4a6652c 100644
--- a/games-fps/quake1-killer/quake1-killer-2.2z.ebuild
+++ b/games-fps/quake1-killer/quake1-killer-2.2z-r1.ebuild
@@ -1,31 +1,26 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
-inherit games
+EAPI=7
DESCRIPTION="The Killer Quake Patch"
HOMEPAGE="http://kqp.horoy.com/"
SRC_URI="http://www.gamers.org/pub/idgames2/quakec/compilations/kqp220z.zip
mirror://gentoo/kqp220z.zip"
+S="${WORKDIR}"
LICENSE="quake1-killer"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE=""
-RDEPEND=""
-DEPEND="app-arch/unzip"
-
-S=${WORKDIR}
+BDEPEND="app-arch/unzip"
src_unpack() {
- echo ">>> Unpacking kqp220z.zip to ${PWD}"
+ elog "Unpacking kqp220z.zip to ${PWD}"
unzip -qoL "${DISTDIR}"/kqp220z.zip || die "unpacking kqp220z.zip failed"
}
src_install() {
- insinto "${GAMES_DATADIR}/quake1/killer"
+ insinto /usr/share/quake1/killer
doins -r *
- prepgamesdirs
}