summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net-analyzer/ndoutils/ndoutils-2.0.0.ebuild11
1 files changed, 10 insertions, 1 deletions
diff --git a/net-analyzer/ndoutils/ndoutils-2.0.0.ebuild b/net-analyzer/ndoutils/ndoutils-2.0.0.ebuild
index a7285fe8e9fc..460c9b7a5cdb 100644
--- a/net-analyzer/ndoutils/ndoutils-2.0.0.ebuild
+++ b/net-analyzer/ndoutils/ndoutils-2.0.0.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
@@ -56,6 +56,15 @@ DOCS=(
src_install() {
default
+
+ local itarget
+ if has_version ">=net-analyzer/nagios-core-4.0" ; then
+ itarget="install-4x"
+ else
+ itarget="install-3x"
+ fi
+
+ emake -C src DESTDIR="${D}" "${itarget}"
emake DESTDIR="${D}" install-config
newinitd "${FILESDIR}"/ndo2db.init-nagios3 ndo2db