summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--games-board/xskat/xskat-4.0-r1.ebuild21
1 files changed, 14 insertions, 7 deletions
diff --git a/games-board/xskat/xskat-4.0-r1.ebuild b/games-board/xskat/xskat-4.0-r1.ebuild
index 20a59e4c87ba..99f4b01f2de0 100644
--- a/games-board/xskat/xskat-4.0-r1.ebuild
+++ b/games-board/xskat/xskat-4.0-r1.ebuild
@@ -1,8 +1,9 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
-inherit toolchain-funcs eutils
+EAPI=7
+
+inherit desktop toolchain-funcs
DESCRIPTION="Famous german card game"
HOMEPAGE="http://www.xskat.de/xskat.html"
@@ -11,11 +12,12 @@ SRC_URI="http://www.xskat.de/${P}.tar.gz"
LICENSE="freedist"
SLOT="0"
KEYWORDS="~amd64 ~ppc64 ~x86"
-IUSE=""
-RDEPEND="media-fonts/font-misc-misc
+RDEPEND="
+ media-fonts/font-misc-misc
x11-libs/libX11"
-DEPEND="${RDEPEND}
+DEPEND="${RDEPEND}"
+BDEPEND="
x11-base/xorg-proto
x11-misc/gccmakedep
>=x11-misc/imake-1.0.8-r1"
@@ -26,13 +28,18 @@ src_configure() {
}
src_compile() {
- emake CDEBUGFLAGS="${CFLAGS}" EXTRA_LDOPTIONS="${LDFLAGS}" CC="$(tc-getCC)"
+ local myemakeargs=(
+ CC="$(tc-getCC)"
+ CDEBUGFLAGS="${CFLAGS}"
+ EXTRA_LDOPTIONS="${LDFLAGS}"
+ )
+ emake "${myemakeargs[@]}"
}
src_install() {
dobin xskat
newman xskat.man xskat.6
- dodoc CHANGES README{,.IRC}
newicon icon.xbm ${PN}.xbm
make_desktop_entry ${PN} XSkat /usr/share/pixmaps/${PN}.xbm
+ einstalldocs
}