summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net-misc/yt-dlp/yt-dlp-2021.10.22-r2.ebuild9
1 files changed, 9 insertions, 0 deletions
diff --git a/net-misc/yt-dlp/yt-dlp-2021.10.22-r2.ebuild b/net-misc/yt-dlp/yt-dlp-2021.10.22-r2.ebuild
index c9b4d7614b7f..89adf8ec5b64 100644
--- a/net-misc/yt-dlp/yt-dlp-2021.10.22-r2.ebuild
+++ b/net-misc/yt-dlp/yt-dlp-2021.10.22-r2.ebuild
@@ -47,3 +47,12 @@ python_install_all() {
exec yt-dlp --compat-options youtube-dl "\${@}"
EOF
}
+
+pkg_postinst() {
+ if [[ ! ${REPLACING_VERSIONS} ]] ||
+ ver_test ${REPLACING_VERSIONS} -lt 2021.10.22-r2; then
+ elog 'A wrapper using "yt-dlp --compat-options youtube-dl" was installed'
+ elog 'as "youtube-dl". This is strictly for compatibility and it is'
+ elog 'recommended to use "yt-dlp" directly, it may be removed in the future.'
+ fi
+}