summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--x11-plugins/wmcliphist/wmcliphist-2.1-r3.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/x11-plugins/wmcliphist/wmcliphist-2.1-r3.ebuild b/x11-plugins/wmcliphist/wmcliphist-2.1-r3.ebuild
new file mode 100644
index 000000000000..1357a842a0ca
--- /dev/null
+++ b/x11-plugins/wmcliphist/wmcliphist-2.1-r3.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+DESCRIPTION="Dockable clipboard history application for Window Maker"
+HOMEPAGE="https://www.dockapps.net/wmcliphist"
+SRC_URI="https://dev.gentoo.org/~voyageur/distfiles/${P}.tar.gz"
+S="${WORKDIR}/dockapps"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+
+RDEPEND="x11-libs/gtk+:3[X]"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+src_prepare() {
+ default
+
+ sed -e '/^PREFIX/s:=.*:=/usr:' \
+ -i Makefile || die
+ tc-export CC
+}
+
+src_install() {
+ default
+
+ newdoc ${PN}rc ${PN}rc.sample
+}