summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-python/qtconsole/Manifest2
-rw-r--r--dev-python/qtconsole/qtconsole-5.1.1.ebuild45
-rw-r--r--dev-python/qtconsole/qtconsole-5.2.1.ebuild47
3 files changed, 0 insertions, 94 deletions
diff --git a/dev-python/qtconsole/Manifest b/dev-python/qtconsole/Manifest
index 0e16eb4ec5b5..e9ac0c65e6e4 100644
--- a/dev-python/qtconsole/Manifest
+++ b/dev-python/qtconsole/Manifest
@@ -1,4 +1,2 @@
-DIST qtconsole-5.1.1.tar.gz 428840 BLAKE2B eb5f6dacf576133c07bc45a9f0fcfdfd041f72012d9564e288a40ac060a6843f6438c80836bcf2f35ffa1f575383bdffe347a498930fe96e2d99a1f1fbe3a032 SHA512 dd9f725fc6e55dea3910650c4c5641336ed1ed56e6eeaad91e6567743bc02fbd0ca567295c3c8897bb800df305ec0bf9f2d8caa8ad0099cdfa2d20c7ca96fbdc
-DIST qtconsole-5.2.1.tar.gz 429573 BLAKE2B 57d42dee8710576785dd1e2e054469b5b2325fad1c30aab1b071f1aac80f3146edc057b03b025d72f0c8691d002a06dbe45bf51d51876ff730d39106d4e4aaa4 SHA512 86e310da66f36e38a584758b18482da927acd70f095600554d4bef3c0b0fcfab5df9d9990b94943a14932afbb8d5ec1db5810c40ef2a7e59172788291684d9aa
DIST qtconsole-5.2.2.tar.gz 429610 BLAKE2B 1a9f163dfa8a2d38829b2db5a5589b80605b82f144d95e51e3668f296b8e839fd3045c813505926a4c8690e438e79d82c0307c33416152d28899b2f0324aec1e SHA512 43727a08a0b828421bb051063055b3306a2111bedfd148aea6bccc04e103bbffb798c35440bfdb82ffa6bf17a2b0ce9e1ad2d0b3df9aaea294a23dcf582dfd57
DIST qtconsole-5.3.0.tar.gz 430258 BLAKE2B 883c95124d911b17a1cebedc357f207e042a9679a09eb63bace09f7f39eac4b1f3a24ccd372760e3142494208119dc4131939cd82e8cab364dacecca184c8545 SHA512 6fcfaa7ad842f3f45d4e2286ce816a0b4c71e3c3fb07b86589934efcc637e2cd6f5712fa8a10c375b8e86d1e1e6ce32de9f2be2fc0decd554b51c658e106b120
diff --git a/dev-python/qtconsole/qtconsole-5.1.1.ebuild b/dev-python/qtconsole/qtconsole-5.1.1.ebuild
deleted file mode 100644
index bfb91fcfbe63..000000000000
--- a/dev-python/qtconsole/qtconsole-5.1.1.ebuild
+++ /dev/null
@@ -1,45 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{8..10} )
-PYTHON_REQ_USE="threads(+)"
-inherit distutils-r1
-
-DESCRIPTION="Qt-based console for Jupyter with support for rich media output"
-HOMEPAGE="https://jupyter.org"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="amd64 ~arm arm64 x86"
-
-RDEPEND="
- dev-python/ipykernel[${PYTHON_USEDEP}]
- dev-python/ipython_genutils[${PYTHON_USEDEP}]
- dev-python/jupyter_core[${PYTHON_USEDEP}]
- >=dev-python/jupyter_client-4.1.1[${PYTHON_USEDEP}]
- dev-python/pygments[${PYTHON_USEDEP}]
- dev-python/traitlets[${PYTHON_USEDEP}]
- dev-python/QtPy[${PYTHON_USEDEP},gui,printsupport,svg]
-"
-BDEPEND="
- test? (
- dev-python/QtPy[${PYTHON_USEDEP},svg,testlib]
- )
-"
-# required by the tests that are removed:
-# dev-python/flaky[${PYTHON_USEDEP}]
-# dev-python/pytest-qt[${PYTHON_USEDEP}]
-
-PDEPEND="dev-python/ipython[${PYTHON_USEDEP}]"
-
-distutils_enable_sphinx docs/source
-distutils_enable_tests pytest
-
-python_test() {
- # TODO: these tests require virtx; however, running under virtx
- # causes pytest to segv on exit (even though tests pass)
- epytest --ignore qtconsole/tests/test_00_console_widget.py
-}
diff --git a/dev-python/qtconsole/qtconsole-5.2.1.ebuild b/dev-python/qtconsole/qtconsole-5.2.1.ebuild
deleted file mode 100644
index 82cf36fe9fd7..000000000000
--- a/dev-python/qtconsole/qtconsole-5.2.1.ebuild
+++ /dev/null
@@ -1,47 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{8..9} )
-PYTHON_REQ_USE="threads(+)"
-inherit distutils-r1
-
-DESCRIPTION="Qt-based console for Jupyter with support for rich media output"
-HOMEPAGE="https://jupyter.org"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~arm64 ~x86"
-
-RDEPEND="
- >=dev-python/ipykernel-4.1[${PYTHON_USEDEP}]
- dev-python/ipython_genutils[${PYTHON_USEDEP}]
- dev-python/jupyter_core[${PYTHON_USEDEP}]
- >=dev-python/jupyter_client-4.1.1[${PYTHON_USEDEP}]
- dev-python/pygments[${PYTHON_USEDEP}]
- >=dev-python/pyzmq-17.1[${PYTHON_USEDEP}]
- dev-python/traitlets[${PYTHON_USEDEP}]
- dev-python/QtPy[${PYTHON_USEDEP},gui,printsupport,svg]
-"
-# The test suite tests both against pyqt5 *and* pyside2
-BDEPEND="
- test? (
- dev-python/QtPy[pyqt5,pyside2,${PYTHON_USEDEP},svg,testlib]
- )
-"
-# required by the tests that are removed:
-# dev-python/flaky[${PYTHON_USEDEP}]
-# dev-python/pytest-qt[${PYTHON_USEDEP}]
-
-PDEPEND="dev-python/ipython[${PYTHON_USEDEP}]"
-
-distutils_enable_sphinx docs/source dev-python/sphinx_rtd_theme
-distutils_enable_tests pytest
-
-python_test() {
- # TODO: these tests require virtx; however, running under virtx
- # causes pytest to segv on exit (even though tests pass)
- epytest --ignore qtconsole/tests/test_00_console_widget.py
-}