summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-admin/coreboot-utils/coreboot-utils-4.18-r2.ebuild (renamed from app-admin/coreboot-utils/coreboot-utils-4.18-r1.ebuild)7
-rw-r--r--app-admin/coreboot-utils/files/coreboot-utils-4.18-musl.patch19
2 files changed, 11 insertions, 15 deletions
diff --git a/app-admin/coreboot-utils/coreboot-utils-4.18-r1.ebuild b/app-admin/coreboot-utils/coreboot-utils-4.18-r2.ebuild
index f50dd5d15b0a..0f0e5b47fd02 100644
--- a/app-admin/coreboot-utils/coreboot-utils-4.18-r1.ebuild
+++ b/app-admin/coreboot-utils/coreboot-utils-4.18-r2.ebuild
@@ -24,6 +24,7 @@ PATCHES=(
"${FILESDIR}"/${PN}-4.18-flags.patch
)
+# selection from README.md that seem useful outside coreboot
coreboot_utils=(
#cbfstool has textrels and is not really necessary outside coreboot
cbmem
@@ -48,8 +49,6 @@ src_prepare() {
}
src_compile() {
- # selection from README.md that seem useful outside coreboot
-
tc-export CC
export HOSTCFLAGS="${CFLAGS}"
for tool in ${coreboot_utils[*]} ; do
@@ -61,7 +60,9 @@ src_compile() {
src_install() {
exeinto /usr/sbin
for tool in ${coreboot_utils[*]} ; do
- [[ -e util/${tool}/${tool} ]] && doexe util/${tool}/${tool}
+ [[ -e util/${tool}/${tool} ]] && doexe util/${tool}/${tool}
[[ -e util/${tool}/${tool}.py ]] && doexe util/${tool}/${tool}.py
+ [[ -e util/${tool}/${tool}.8 ]] && doman util/${tool}/${tool}.8
+ [[ -d util/${tool}/man ]] && doman util/${tool}/man/*.[12345678]
done
}
diff --git a/app-admin/coreboot-utils/files/coreboot-utils-4.18-musl.patch b/app-admin/coreboot-utils/files/coreboot-utils-4.18-musl.patch
index 435977ac9c0b..a92936f008cd 100644
--- a/app-admin/coreboot-utils/files/coreboot-utils-4.18-musl.patch
+++ b/app-admin/coreboot-utils/files/coreboot-utils-4.18-musl.patch
@@ -34,22 +34,17 @@ diff --git a/util/superiotool/superiotool.c b/util/superiotool/superiotool.c
index ed18c13e62..fa2c6ce35d 100644
--- a/util/superiotool/superiotool.c
+++ b/util/superiotool/superiotool.c
-@@ -320,6 +320,7 @@ int main(int argc, char *argv[])
- }
- }
-
-+#if 0
- #if defined(__FreeBSD__)
+@@ -324,8 +324,8 @@
if ((io_fd = open("/dev/io", O_RDWR)) < 0) {
perror("/dev/io");
-@@ -330,6 +331,7 @@ int main(int argc, char *argv[])
+ #else
+- if (iopl(3) < 0) {
+- perror("iopl");
++ if (ioperm(0, 6000, 1) < 0) {
++ perror("ioperm");
+ #endif
printf("Superiotool must be run as root.\n");
exit(1);
- }
-+#endif
-
- print_version();
-
diff --git a/util/superiotool/superiotool.h b/util/superiotool/superiotool.h
index a621ae5274..d5f44fece4 100644
--- a/util/superiotool/superiotool.h