summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-haskell/pantry/Manifest1
-rw-r--r--dev-haskell/pantry/pantry-0.4.0.2.ebuild72
2 files changed, 73 insertions, 0 deletions
diff --git a/dev-haskell/pantry/Manifest b/dev-haskell/pantry/Manifest
index 84a03e48f0b6..30098f325a5f 100644
--- a/dev-haskell/pantry/Manifest
+++ b/dev-haskell/pantry/Manifest
@@ -1 +1,2 @@
DIST pantry-0.4.0.1.tar.gz 89571 BLAKE2B 4d378ab3a1e951ccb651cd246cfa7328ccbc4dcb8e382e0332122a1bd6334bf3617cb257d8e22865f9dd32f6c75936a0e4871936a25c75596a730df8fcc88d97 SHA512 0fbed425e3079bf1a06805efff092345c5f09bca430d2167d132cba4cd4a4c66567ce1aba921a9ac01d0db368f255395b2ad38d8b16ea5d81e263b100ad5a51d
+DIST pantry-0.4.0.2.tar.gz 89491 BLAKE2B df082f4bf08f345fd64d54950241cc27af8259f1ae40ed3b123a10aeda3596c70029b1de08f8d551542af6b9cbdd77184e5dc1bda031be79d371a1051589771a SHA512 17e564825b9b7fa3bf2b091d0d0ba261c5ba17105ae34193b1aeb45db823877240d8d138f9bfb9699e87c946a5c87ce83ba12144aae73919d94c7cf3e7df1d7c
diff --git a/dev-haskell/pantry/pantry-0.4.0.2.ebuild b/dev-haskell/pantry/pantry-0.4.0.2.ebuild
new file mode 100644
index 000000000000..553d2801748c
--- /dev/null
+++ b/dev-haskell/pantry/pantry-0.4.0.2.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+# ebuild generated by hackport 0.6.6.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="Content addressable Haskell package management"
+HOMEPAGE="https://github.com/commercialhaskell/pantry#readme"
+SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RESTRICT="test" # seems related to http-download, requiring network access
+
+RDEPEND="dev-haskell/aeson:=[profile?]
+ dev-haskell/ansi-terminal:=[profile?]
+ >=dev-haskell/cabal-3:=[profile?] <dev-haskell/cabal-3.3:=[profile?]
+ dev-haskell/casa-client:=[profile?]
+ dev-haskell/casa-types:=[profile?]
+ dev-haskell/conduit:=[profile?]
+ dev-haskell/conduit-extra:=[profile?]
+ dev-haskell/cryptonite:=[profile?]
+ dev-haskell/cryptonite-conduit:=[profile?]
+ dev-haskell/digest:=[profile?]
+ dev-haskell/filelock:=[profile?]
+ dev-haskell/generic-deriving:=[profile?]
+ dev-haskell/hackage-security:=[profile?]
+ >=dev-haskell/hpack-0.31.2:=[profile?]
+ dev-haskell/http-client:=[profile?]
+ dev-haskell/http-client-tls:=[profile?]
+ dev-haskell/http-conduit:=[profile?]
+ dev-haskell/http-download:=[profile?]
+ dev-haskell/http-types:=[profile?]
+ dev-haskell/memory:=[profile?]
+ dev-haskell/mtl:=[profile?]
+ dev-haskell/network-uri:=[profile?]
+ dev-haskell/path:=[profile?]
+ dev-haskell/path-io:=[profile?]
+ dev-haskell/persistent:=[profile?]
+ >=dev-haskell/persistent-sqlite-2.9.3:=[profile?]
+ dev-haskell/persistent-template:=[profile?]
+ dev-haskell/primitive:=[profile?]
+ dev-haskell/resourcet:=[profile?]
+ dev-haskell/rio:=[profile?]
+ dev-haskell/rio-orphans:=[profile?]
+ dev-haskell/rio-prettyprint:=[profile?]
+ dev-haskell/tar-conduit:=[profile?]
+ dev-haskell/text:=[profile?]
+ dev-haskell/text-metrics:=[profile?]
+ dev-haskell/unix-compat:=[profile?]
+ dev-haskell/unliftio:=[profile?]
+ dev-haskell/unordered-containers:=[profile?]
+ dev-haskell/vector:=[profile?]
+ dev-haskell/yaml:=[profile?]
+ dev-haskell/zip-archive:=[profile?]
+ >=dev-lang/ghc-8.2.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-2.0.0.2
+ test? ( dev-haskell/exceptions
+ dev-haskell/hedgehog
+ dev-haskell/hspec
+ dev-haskell/quickcheck
+ dev-haskell/raw-strings-qq )
+"