summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-python/oslo-sphinx/Manifest1
-rw-r--r--dev-python/oslo-sphinx/oslo-sphinx-4.18.0.ebuild48
2 files changed, 49 insertions, 0 deletions
diff --git a/dev-python/oslo-sphinx/Manifest b/dev-python/oslo-sphinx/Manifest
index 5242bfbd7c18..f0ef11b12acd 100644
--- a/dev-python/oslo-sphinx/Manifest
+++ b/dev-python/oslo-sphinx/Manifest
@@ -1 +1,2 @@
DIST oslosphinx-4.15.2.tar.gz 33362 BLAKE2B 4eacd7da4eecd25836920063c2c05f205f5c8d29cf6253257e9e56f35e1f9cbd39fb120fd69b075670bb6be334fcc50dbff6f52cb928e556f334720a51eed590 SHA512 cf8fce033f97c0334fc076568720fe3b7903e780d4b839c452f33d02378470263891d01e553e4f2463484895c689532f95f4aa81ac3dcb0d6137b463bcc7e08a
+DIST oslosphinx-4.18.0.tar.gz 32046 BLAKE2B b10b13f819cc2f4c3e769c195bc340a74545a4cab2a2e9894e56e4352f5f35c1cdd7f1d40d47c2b7449d30bc77dbadb1feae129f6ff31d54e6227349a0c31e57 SHA512 b736dbf68a3ad8c32ca6d8de72cb79e49ab4b84593c70d0165615de66a8c343ce7094656d3b0be3383453143308a4862f27529b1c9d72920c5418a3f62dbcc46
diff --git a/dev-python/oslo-sphinx/oslo-sphinx-4.18.0.ebuild b/dev-python/oslo-sphinx/oslo-sphinx-4.18.0.ebuild
new file mode 100644
index 000000000000..fdb87b6aed39
--- /dev/null
+++ b/dev-python/oslo-sphinx/oslo-sphinx-4.18.0.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_{4,5,6}} )
+
+inherit distutils-r1
+
+MY_PN="${PN//-/}"
+
+DESCRIPTION="OpenStack Sphinx Extensions and Theme"
+HOMEPAGE="http://www.openstack.org/"
+SRC_URI="mirror://pypi/${PN:0:1}/${MY_PN}/${MY_PN}-${PV}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE="doc"
+
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ >=dev-python/pbr-1.6[${PYTHON_USEDEP}]
+ doc? (
+ >=dev-python/sphinx-1.6.2[${PYTHON_USEDEP}]
+ )
+"
+RDEPEND="
+ >=dev-python/requests-2.14.2[${PYTHON_USEDEP}]
+ >=dev-python/six-1.10.0[${PYTHON_USEDEP}]
+"
+
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+python_prepare_all() {
+ sed -i '/^hacking/d' test-requirements.txt || die
+ distutils-r1_python_prepare_all
+}
+
+python_compile_all() {
+ use doc && esetup.py build_sphinx
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( doc/build/html/. )
+
+ distutils-r1_python_install_all
+}