summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-accessibility/emacspeak-ss/emacspeak-ss-1.9.1.ebuild12
-rw-r--r--app-accessibility/emacspeak-ss/files/gentoo-apollo-fix.patch10
2 files changed, 12 insertions, 10 deletions
diff --git a/app-accessibility/emacspeak-ss/emacspeak-ss-1.9.1.ebuild b/app-accessibility/emacspeak-ss/emacspeak-ss-1.9.1.ebuild
index b073c4626208..7eb873e8bb76 100644
--- a/app-accessibility/emacspeak-ss/emacspeak-ss-1.9.1.ebuild
+++ b/app-accessibility/emacspeak-ss/emacspeak-ss-1.9.1.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI=4
+EAPI=6
-inherit eutils
+inherit toolchain-funcs
DESCRIPTION="adds support for several speech synthesizers to emacspeak"
HOMEPAGE="http://leb.net/blinux/"
@@ -17,8 +17,12 @@ IUSE=""
DEPEND=""
RDEPEND=">=app-accessibility/emacspeak-18"
+PATCHES=(
+ "${FILESDIR}"/gentoo-apollo-fix.patch
+)
+
src_prepare() {
- epatch "${FILESDIR}"/gentoo-apollo-fix.patch
+ default
tc-export CC
}
diff --git a/app-accessibility/emacspeak-ss/files/gentoo-apollo-fix.patch b/app-accessibility/emacspeak-ss/files/gentoo-apollo-fix.patch
index 3d8aa016453a..55abe1238949 100644
--- a/app-accessibility/emacspeak-ss/files/gentoo-apollo-fix.patch
+++ b/app-accessibility/emacspeak-ss/files/gentoo-apollo-fix.patch
@@ -1,6 +1,5 @@
-diff -Naur emacspeak-ss-1.9.1.old/Makefile.in emacspeak-ss-1.9.1/Makefile.in
---- emacspeak-ss-1.9.1.old/Makefile.in 2000-05-07 18:51:21.000000000 -0500
-+++ emacspeak-ss-1.9.1/Makefile.in 2004-04-22 18:43:20.635283200 -0500
+--- a/Makefile.in
++++ b/Makefile.in
@@ -3,7 +3,7 @@
man1dir=@mandir@/man1
exec_prefix = @exec_prefix@
@@ -10,9 +9,8 @@ diff -Naur emacspeak-ss-1.9.1.old/Makefile.in emacspeak-ss-1.9.1/Makefile.in
INSTALL=@INSTALL@
VERSION=@VERSION@
-diff -Naur emacspeak-ss-1.9.1.old/apollo.in emacspeak-ss-1.9.1/apollo.in
---- emacspeak-ss-1.9.1.old/apollo.in 2000-05-07 18:27:31.000000000 -0500
-+++ emacspeak-ss-1.9.1/apollo.in 2004-04-22 18:35:09.255401085 -0500
+--- a/apollo.in
++++ b/apollo.in
@@ -101,7 +101,7 @@
# write the argument to the synthesizer, and return its response if any
proc tts_ping {query} {