summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--games-puzzle/tetrinet/tetrinet-0.11-r1.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/games-puzzle/tetrinet/tetrinet-0.11-r1.ebuild b/games-puzzle/tetrinet/tetrinet-0.11-r1.ebuild
new file mode 100644
index 000000000000..013dcef24a21
--- /dev/null
+++ b/games-puzzle/tetrinet/tetrinet-0.11-r1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit flag-o-matic toolchain-funcs
+
+DESCRIPTION="Console based tetrinet inc. standalone server"
+HOMEPAGE="http://tetrinet.or.cz/"
+SRC_URI="http://tetrinet.or.cz/download/${P}.tar.bz2"
+
+LICENSE="public-domain"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="ipv6"
+
+RDEPEND=">=sys-libs/ncurses-5:0="
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+"
+
+src_prepare() {
+ default
+ eapply \
+ "${FILESDIR}"/${P}-no-ipv6.patch \
+ "${FILESDIR}"/${P}-build.patch
+
+ use ipv6 && append-cflags -DHAVE_IPV6
+ tc-export PKG_CONFIG
+}
+
+src_install() {
+ dobin tetrinet tetrinet-server
+ dodoc README TODO tetrinet.txt
+}