summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--media-sound/qmmp/qmmp-9999.ebuild11
1 files changed, 7 insertions, 4 deletions
diff --git a/media-sound/qmmp/qmmp-9999.ebuild b/media-sound/qmmp/qmmp-9999.ebuild
index 8bd1b63268e6..2fe547a222c2 100644
--- a/media-sound/qmmp/qmmp-9999.ebuild
+++ b/media-sound/qmmp/qmmp-9999.ebuild
@@ -20,9 +20,10 @@ fi
LICENSE="GPL-2"
SLOT="0"
# KEYWORDS further up
-IUSE="aac +alsa analyzer archive bs2b cdda cover crossfade cue curl +dbus enca ffmpeg flac game
-gnome jack ladspa lyrics +mad midi mms modplug mplayer musepack notifier opus oss projectm
-pulseaudio qsui qtmedia scrobbler shout sid sndfile soxr stereo tray udisks +vorbis wavpack"
+IUSE="aac +alsa analyzer archive bs2b cdda cover crossfade cue curl +dbus enca
+ffmpeg flac game gnome jack ladspa lyrics +mad midi mms modplug mplayer musepack
+notifier opus oss pipewire projectm pulseaudio qsui qtmedia scrobbler shout sid
+sndfile soxr stereo tray udisks +vorbis wavpack"
REQUIRED_USE="
gnome? ( dbus )
@@ -68,6 +69,7 @@ RDEPEND="
mplayer? ( media-video/mplayer )
musepack? ( >=media-sound/musepack-tools-444 )
opus? ( media-libs/opusfile )
+ pipewire? ( media-video/pipewire )
projectm? (
dev-qt/qtgui:5[-gles2-only]
dev-qt/qtopengl:5
@@ -94,7 +96,7 @@ DEPEND="${RDEPEND}
DOCS=( AUTHORS ChangeLog README )
src_prepare() {
- if has_version dev-libs/libcdio-paranoia; then
+ if has_version dev-libs/libcdio-paranoia ; then
sed -i \
-e 's:cdio/cdda.h:cdio/paranoia/cdda.h:' \
src/plugins/Input/cdaudio/decoder_cdaudio.cpp || die
@@ -136,6 +138,7 @@ src_configure() {
-DUSE_NOTIFIER="$(usex notifier)"
-DUSE_OPUS="$(usex opus)"
-DUSE_OSS="$(usex oss)"
+ -DUSE_PIPEWIRE="$(usex pipewire)"
-DUSE_PROJECTM="$(usex projectm)"
-DUSE_PULSE="$(usex pulseaudio)"
-DUSE_QSUI="$(usex qsui)"