summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-python/pyudev/pyudev-0.21.0.ebuild6
1 files changed, 2 insertions, 4 deletions
diff --git a/dev-python/pyudev/pyudev-0.21.0.ebuild b/dev-python/pyudev/pyudev-0.21.0.ebuild
index 88016e8f0f94..684711ee05ca 100644
--- a/dev-python/pyudev/pyudev-0.21.0.ebuild
+++ b/dev-python/pyudev/pyudev-0.21.0.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=6
-PYTHON_COMPAT=( python{2_7,3_6,3_7} )
+PYTHON_COMPAT=( python{3_6,3_7} )
inherit distutils-r1
@@ -13,14 +13,12 @@ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
LICENSE="LGPL-2.1"
SLOT="0"
KEYWORDS="amd64 arm ~arm64 ~mips x86"
-IUSE="pygobject qt5 test"
+IUSE="qt5 test"
RESTRICT="!test? ( test )"
-REQUIRED_USE="pygobject? ( || ( $(python_gen_useflags 'python2*') ) )"
RDEPEND="
dev-python/six[${PYTHON_USEDEP}]
virtual/udev
- pygobject? ( dev-python/pygobject:2[$(python_gen_usedep 'python2*')] )
qt5? ( dev-python/PyQt5[${PYTHON_USEDEP}] )
"
DEPEND="${RDEPEND}