summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-vim/tcomment/Manifest1
-rw-r--r--app-vim/tcomment/tcomment-4.00.ebuild26
2 files changed, 27 insertions, 0 deletions
diff --git a/app-vim/tcomment/Manifest b/app-vim/tcomment/Manifest
index b3eba0f0b274..e46aa777e0a8 100644
--- a/app-vim/tcomment/Manifest
+++ b/app-vim/tcomment/Manifest
@@ -1 +1,2 @@
DIST tcomment-3.08.1.tar.gz 49918 BLAKE2B df63a01432101e018a39f7b54dec0b91b415263e2b6c0f3e63521e1abe2247a005a1fc900cd6d18cfd908f75ae4b5767a5f7dc21ae620985d3465676c456a389 SHA512 609d5eb1e7785fb1af829000ab27ab63ac2bb7550bcd0f91c7c35f0a8c4b879e5348745f57b11d1e24d37920056ca55da8863e15e40d6fe289617d5d898a4177
+DIST tcomment-4.00.tar.gz 58709 BLAKE2B 64285c64d65e7308e3cb34494f1b49584f54707ba9f4e86a40a72c1434670819c412b68e4a30f296ce531913b054d482f5743ee7e6fd81baa5c3ee1d46dc8d01 SHA512 b072ec4b136ef6ea14e91883a77b036a26b2e2c0f6cabdce70e4aea2cf37a2c4b7becc0770ddfc8b7260a52cda729a0e4b8ff4a067c81bcbbe0f0e896b9e66c4
diff --git a/app-vim/tcomment/tcomment-4.00.ebuild b/app-vim/tcomment/tcomment-4.00.ebuild
new file mode 100644
index 000000000000..be5dacfaeb75
--- /dev/null
+++ b/app-vim/tcomment/tcomment-4.00.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit vim-plugin
+
+MY_PN="tcomment_vim"
+
+DESCRIPTION="vim plugin: an extensible and universal comment toggler"
+HOMEPAGE="https://www.vim.org/scripts/script.php?script_id=1173
+ https://github.com/tomtom/tcomment_vim"
+SRC_URI="https://github.com/tomtom/${MY_PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+LICENSE="GPL-3"
+KEYWORDS="~amd64 ~x86"
+
+VIM_PLUGIN_HELPFILES="${PN}.txt"
+
+DOCS=( CHANGES.TXT README )
+
+src_prepare() {
+ default
+ rm -r etc spec addon* || die
+}