summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-db/sqlite/sqlite-3.45.1-r1.ebuild7
-rw-r--r--dev-db/sqlite/sqlite-9999.ebuild7
2 files changed, 12 insertions, 2 deletions
diff --git a/dev-db/sqlite/sqlite-3.45.1-r1.ebuild b/dev-db/sqlite/sqlite-3.45.1-r1.ebuild
index 8ff12ceb6f51..ad62f71390b1 100644
--- a/dev-db/sqlite/sqlite-3.45.1-r1.ebuild
+++ b/dev-db/sqlite/sqlite-3.45.1-r1.ebuild
@@ -322,8 +322,13 @@ multilib_src_configure() {
# Skip known-broken test for now
# https://sqlite.org/forum/forumpost/d97caf168f
# https://sqlite.org/forum/forumpost/50f136d91d
+ # Quoting Fedora's spec:
+ # "The atof test is failing on the i686 architecture, when binary configured with
+ # --enable-rtree option. Failing part is text->real conversion and
+ # text->real->text conversion in lower significant values after decimal point in a number.
+ # func4 tests fail for i686 on float<->int conversions."
if use test ; then
- rm test/atof1.test || die
+ rm test/atof1.test test/func4.test || die
fi
fi
diff --git a/dev-db/sqlite/sqlite-9999.ebuild b/dev-db/sqlite/sqlite-9999.ebuild
index e529a0d8187d..40b16d903620 100644
--- a/dev-db/sqlite/sqlite-9999.ebuild
+++ b/dev-db/sqlite/sqlite-9999.ebuild
@@ -318,8 +318,13 @@ multilib_src_configure() {
# Skip known-broken test for now
# https://sqlite.org/forum/forumpost/d97caf168f
# https://sqlite.org/forum/forumpost/50f136d91d
+ # Quoting Fedora's spec:
+ # "The atof test is failing on the i686 architecture, when binary configured with
+ # --enable-rtree option. Failing part is text->real conversion and
+ # text->real->text conversion in lower significant values after decimal point in a number.
+ # func4 tests fail for i686 on float<->int conversions."
if use test ; then
- rm test/atof1.test || die
+ rm test/atof1.test test/func4.test || die
fi
fi