summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-python/humanize/Manifest1
-rw-r--r--dev-python/humanize/humanize-3.9.0.ebuild24
2 files changed, 25 insertions, 0 deletions
diff --git a/dev-python/humanize/Manifest b/dev-python/humanize/Manifest
index 27aa14e1772e..01ca15ea8b42 100644
--- a/dev-python/humanize/Manifest
+++ b/dev-python/humanize/Manifest
@@ -2,3 +2,4 @@ DIST humanize-3.5.0.tar.gz 56651 BLAKE2B 05095fbdf7c55258bf3d01c73f47bf913e1fda3
DIST humanize-3.7.0.tar.gz 44002 BLAKE2B ec253c07a38c83d67038836998a7159afe7d1f3e1f0f5ea0f946f987e18bf4943d7dd48e2e156009627e1bda2140017bf99df072671008a6e1daad704b693292 SHA512 e501cdb4dcb603601624f5df9a04a256669f06ac594d8a3a0c83543d1d8503bfcf4d7198ff87827e2c60dd63897c23b722be7497179c49a9f9b05d07289de4be
DIST humanize-3.7.1.tar.gz 61846 BLAKE2B 6ed6e35dc15ef08a88cd15211212cbd4194363889ff0dbe4e53d76adb248da948d688e4eddf5a93548497b1e1e02145431e1c157fd26288fc27f2b9b7b2c80b7 SHA512 152ee6030de83be34bdb40908427ca4f1461191ce417faef273b070a1d347a43f4a44182cd0fa79b8935c07d97679205285bbd6fa43352d2d9cada53df5f112f
DIST humanize-3.8.0.tar.gz 64298 BLAKE2B ba367054f66351b7b48bed69ab4ba63251dbdd6bb56c21cbd8d7846401d4a2428f6e069a0219b5a24bfde173d6ed2ef3116f01551137b4c0c1eddd8c9d6fc87b SHA512 8301f461c60fd990e50a24aef714d78a3b42fb82d792ac01b088e05b6bf765dfa34e2257c1a75e3da279db3b8d837bd6434398f33578c946fa17dc1a45122f75
+DIST humanize-3.9.0.tar.gz 64229 BLAKE2B 09aeec6a92c8e2e104032d4c61f054785ff58ce2dda68c4f3acffb17c7fa4e262b28a24b7c06d33671ea18d2eb05c9bcc0a82d5491e60afa161ebc0041945bf2 SHA512 75aa8f9f6b07d4b65e5589c3f337a92ee17769ab8da6608147b0f1ec3965b95788dd90cf0d0cae1b7c9be689b44910029ee72e2eba39a60c9926b67726c74353
diff --git a/dev-python/humanize/humanize-3.9.0.ebuild b/dev-python/humanize/humanize-3.9.0.ebuild
new file mode 100644
index 000000000000..b6c00705226e
--- /dev/null
+++ b/dev-python/humanize/humanize-3.9.0.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( pypy3 python3_{8..10} )
+DISTUTILS_USE_SETUPTOOLS=rdepend
+
+inherit distutils-r1
+
+DESCRIPTION="Common humanization utilities"
+HOMEPAGE="https://github.com/jmoiron/humanize/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+BDEPEND="
+ dev-python/setuptools_scm[${PYTHON_USEDEP}]
+ test? ( dev-python/freezegun[${PYTHON_USEDEP}] )
+"
+
+distutils_enable_tests --install pytest