summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net-dns/dnscrypt-proxy/Manifest4
-rw-r--r--net-dns/dnscrypt-proxy/dnscrypt-proxy-2.0.21.ebuild98
-rw-r--r--net-dns/dnscrypt-proxy/dnscrypt-proxy-2.0.22.ebuild98
-rw-r--r--net-dns/dnscrypt-proxy/dnscrypt-proxy-2.0.23.ebuild98
-rw-r--r--net-dns/dnscrypt-proxy/dnscrypt-proxy-2.0.24.ebuild98
5 files changed, 0 insertions, 396 deletions
diff --git a/net-dns/dnscrypt-proxy/Manifest b/net-dns/dnscrypt-proxy/Manifest
index 875bdd467672..09efb1e76c8c 100644
--- a/net-dns/dnscrypt-proxy/Manifest
+++ b/net-dns/dnscrypt-proxy/Manifest
@@ -1,6 +1,2 @@
DIST dnscrypt-proxy-2.0.19.tar.gz 3339713 BLAKE2B e65b5ed8243aa6cf471700c6edba6e843fdf6482443335ec74201363657b23a7c6e432318e4de508120b6210cecd02666d97bb62a5f2968ce7d4813518eb3997 SHA512 4501a64717c0f2a9313e9328340e466c9ec325d09ef548f6af9a7855ff3497fb741269a17b397a36e2a120519820378e9f98a6a768a3678ea8144ee4690364f6
-DIST dnscrypt-proxy-2.0.21.tar.gz 2189155 BLAKE2B 3cab3ec4208e93733cefad49732c3fde644aac5401191d53a8c5962a1173456c09e12eaadeba6e086c078968b9467743cba7167ff0c84af2cf2f1d2209edd49f SHA512 e01869b963ef7454f9136d8ececc4e541dae489524e03cc2906fc3b661281bd6ebf5ef8b6dc29a6bcc1dabb638b9e74200b3ed48ebcd69cd3306e8bab5dd248a
-DIST dnscrypt-proxy-2.0.22.tar.gz 2192330 BLAKE2B 7688354d50a9c80368881be622ca8ef9cebd901a7023e071bb7eba603c876bf496f017a0abb5d9c6591fd4c31aad748c574a34ff47c5462c7417124282aaa37e SHA512 ea2641e79739e75e8a7e6bc24a788488537ffa823e18a3585f95ca1ae90bef9890c65eaf7feb80cc5ad09165cef9513d4025e96367ca87fc59333534f8856102
-DIST dnscrypt-proxy-2.0.23.tar.gz 2552615 BLAKE2B fe59304d431a006fa8cf09cee97fcb62a2ea04306fd5b632a22c66fd7c0894ca4cac27280dc3eb2470cc1a503da9e0bc4316fe43c6c77391f305618137361a20 SHA512 d4eeaf20a397c8aed08a7a91a720637bb49395488eb1f7ab4a52ca8832d3e0b98fb320b86ca30ad19e1e3504e226379e5d325891a68624532493fc4796959462
-DIST dnscrypt-proxy-2.0.24.tar.gz 2596668 BLAKE2B 6a736d2d1ef11c88191f21bf631d54f6687250841e0b9ed2893b940915fc8b7c5d70f4a6c9dfa06ade97bde4c943d9615725475c4d880033228f247658a879c8 SHA512 f345fe9d299dc7fa876de686e5d9c471041f00e8297dcff31787a246caaecd150a762222c7e417815181e678ab2b222623dbf6a111c529c40a4f7e17dc7467a2
DIST dnscrypt-proxy-2.0.25.tar.gz 2596674 BLAKE2B 10947c9e496c47a565e62fb4ca6ad95679da0d237885fe09da367b501bf0dd228cb3d4af41b3527dca64665364527ec2db06afab2c209792409078debd7d3fc8 SHA512 74a47b013e15cbdcf8691bf3618cce40149f9832f6fc4c2cbfb6af2a72b4ecb52b068a150999771a77fcf4fdb49c64dabd127c5101ae29fb86723bc30c946133
diff --git a/net-dns/dnscrypt-proxy/dnscrypt-proxy-2.0.21.ebuild b/net-dns/dnscrypt-proxy/dnscrypt-proxy-2.0.21.ebuild
deleted file mode 100644
index 419d40281c69..000000000000
--- a/net-dns/dnscrypt-proxy/dnscrypt-proxy-2.0.21.ebuild
+++ /dev/null
@@ -1,98 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-EGO_PN="github.com/jedisct1/${PN}"
-
-inherit fcaps golang-build systemd user
-
-if [[ ${PV} == 9999 ]]; then
- inherit git-r3
- EGIT_REPO_URI="https://${EGO_PN}.git"
-else
- SRC_URI="https://${EGO_PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="~amd64 ~arm ~x86"
-fi
-
-DESCRIPTION="A flexible DNS proxy, with support for encrypted DNS protocols"
-HOMEPAGE="https://github.com/jedisct1/dnscrypt-proxy"
-
-LICENSE="ISC"
-SLOT="0"
-IUSE="pie"
-
-DEPEND=">=dev-lang/go-1.12"
-
-FILECAPS=( cap_net_bind_service+ep usr/bin/dnscrypt-proxy )
-PATCHES=( "${FILESDIR}"/config-full-paths-r10.patch )
-
-pkg_setup() {
- enewgroup dnscrypt-proxy
- enewuser dnscrypt-proxy -1 -1 /var/empty dnscrypt-proxy
-}
-
-src_prepare() {
- default
- # Create directory structure suitable for building
- mkdir -p "src/${EGO_PN%/*}" || die
- # fixes $GOPATH/go.mod exists but should not
- rm go.mod || die
- mv "${PN}" "src/${EGO_PN}" || die
- mv "vendor" "src/" || die
-}
-
-src_configure() {
- EGO_BUILD_FLAGS="-buildmode=$(usex pie pie default)"
-}
-
-src_install() {
- dobin dnscrypt-proxy
-
- insinto /etc/dnscrypt-proxy
- newins "src/${EGO_PN}"/example-dnscrypt-proxy.toml dnscrypt-proxy.toml
- doins "src/${EGO_PN}"/example-{blacklist.txt,whitelist.txt}
- doins "src/${EGO_PN}"/example-{cloaking-rules.txt,forwarding-rules.txt}
-
- insinto /usr/share/dnscrypt-proxy
- doins -r "utils/generate-domains-blacklists/."
-
- newinitd "${FILESDIR}"/dnscrypt-proxy.initd dnscrypt-proxy
- newconfd "${FILESDIR}"/dnscrypt-proxy.confd dnscrypt-proxy
- systemd_newunit "${FILESDIR}"/dnscrypt-proxy.service dnscrypt-proxy.service
- systemd_newunit "${FILESDIR}"/dnscrypt-proxy.socket dnscrypt-proxy.socket
-
- einstalldocs
-}
-
-pkg_postinst() {
- fcaps_pkg_postinst
-
- if ! use filecaps; then
- ewarn "'filecaps' USE flag is disabled"
- ewarn "${PN} will fail to listen on port 53"
- ewarn "please do one the following:"
- ewarn "1) re-enable 'filecaps'"
- ewarn "2) change port to > 1024"
- ewarn "3) configure to run ${PN} as root (not recommended)"
- ewarn
- fi
-
- if systemd_is_booted || has_version sys-apps/systemd; then
- elog "Using systemd socket activation may cause issues with speed"
- elog "latency and reliability of ${PN} and is discouraged by upstream"
- elog "Existing installations advised to disable 'dnscrypt-proxy.socket'"
- elog "It is disabled by default for new installations"
- elog "check "$(systemd_get_systemunitdir)/${PN}.service" for details"
- elog
-
- fi
-
- elog "After starting the service you will need to update your"
- elog "/etc/resolv.conf and replace your current set of resolvers"
- elog "with:"
- elog
- elog "nameserver 127.0.0.1"
- elog
- elog "Also see https://github.com/jedisct1/${PN}/wiki"
-}
diff --git a/net-dns/dnscrypt-proxy/dnscrypt-proxy-2.0.22.ebuild b/net-dns/dnscrypt-proxy/dnscrypt-proxy-2.0.22.ebuild
deleted file mode 100644
index 419d40281c69..000000000000
--- a/net-dns/dnscrypt-proxy/dnscrypt-proxy-2.0.22.ebuild
+++ /dev/null
@@ -1,98 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-EGO_PN="github.com/jedisct1/${PN}"
-
-inherit fcaps golang-build systemd user
-
-if [[ ${PV} == 9999 ]]; then
- inherit git-r3
- EGIT_REPO_URI="https://${EGO_PN}.git"
-else
- SRC_URI="https://${EGO_PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="~amd64 ~arm ~x86"
-fi
-
-DESCRIPTION="A flexible DNS proxy, with support for encrypted DNS protocols"
-HOMEPAGE="https://github.com/jedisct1/dnscrypt-proxy"
-
-LICENSE="ISC"
-SLOT="0"
-IUSE="pie"
-
-DEPEND=">=dev-lang/go-1.12"
-
-FILECAPS=( cap_net_bind_service+ep usr/bin/dnscrypt-proxy )
-PATCHES=( "${FILESDIR}"/config-full-paths-r10.patch )
-
-pkg_setup() {
- enewgroup dnscrypt-proxy
- enewuser dnscrypt-proxy -1 -1 /var/empty dnscrypt-proxy
-}
-
-src_prepare() {
- default
- # Create directory structure suitable for building
- mkdir -p "src/${EGO_PN%/*}" || die
- # fixes $GOPATH/go.mod exists but should not
- rm go.mod || die
- mv "${PN}" "src/${EGO_PN}" || die
- mv "vendor" "src/" || die
-}
-
-src_configure() {
- EGO_BUILD_FLAGS="-buildmode=$(usex pie pie default)"
-}
-
-src_install() {
- dobin dnscrypt-proxy
-
- insinto /etc/dnscrypt-proxy
- newins "src/${EGO_PN}"/example-dnscrypt-proxy.toml dnscrypt-proxy.toml
- doins "src/${EGO_PN}"/example-{blacklist.txt,whitelist.txt}
- doins "src/${EGO_PN}"/example-{cloaking-rules.txt,forwarding-rules.txt}
-
- insinto /usr/share/dnscrypt-proxy
- doins -r "utils/generate-domains-blacklists/."
-
- newinitd "${FILESDIR}"/dnscrypt-proxy.initd dnscrypt-proxy
- newconfd "${FILESDIR}"/dnscrypt-proxy.confd dnscrypt-proxy
- systemd_newunit "${FILESDIR}"/dnscrypt-proxy.service dnscrypt-proxy.service
- systemd_newunit "${FILESDIR}"/dnscrypt-proxy.socket dnscrypt-proxy.socket
-
- einstalldocs
-}
-
-pkg_postinst() {
- fcaps_pkg_postinst
-
- if ! use filecaps; then
- ewarn "'filecaps' USE flag is disabled"
- ewarn "${PN} will fail to listen on port 53"
- ewarn "please do one the following:"
- ewarn "1) re-enable 'filecaps'"
- ewarn "2) change port to > 1024"
- ewarn "3) configure to run ${PN} as root (not recommended)"
- ewarn
- fi
-
- if systemd_is_booted || has_version sys-apps/systemd; then
- elog "Using systemd socket activation may cause issues with speed"
- elog "latency and reliability of ${PN} and is discouraged by upstream"
- elog "Existing installations advised to disable 'dnscrypt-proxy.socket'"
- elog "It is disabled by default for new installations"
- elog "check "$(systemd_get_systemunitdir)/${PN}.service" for details"
- elog
-
- fi
-
- elog "After starting the service you will need to update your"
- elog "/etc/resolv.conf and replace your current set of resolvers"
- elog "with:"
- elog
- elog "nameserver 127.0.0.1"
- elog
- elog "Also see https://github.com/jedisct1/${PN}/wiki"
-}
diff --git a/net-dns/dnscrypt-proxy/dnscrypt-proxy-2.0.23.ebuild b/net-dns/dnscrypt-proxy/dnscrypt-proxy-2.0.23.ebuild
deleted file mode 100644
index 419d40281c69..000000000000
--- a/net-dns/dnscrypt-proxy/dnscrypt-proxy-2.0.23.ebuild
+++ /dev/null
@@ -1,98 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-EGO_PN="github.com/jedisct1/${PN}"
-
-inherit fcaps golang-build systemd user
-
-if [[ ${PV} == 9999 ]]; then
- inherit git-r3
- EGIT_REPO_URI="https://${EGO_PN}.git"
-else
- SRC_URI="https://${EGO_PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="~amd64 ~arm ~x86"
-fi
-
-DESCRIPTION="A flexible DNS proxy, with support for encrypted DNS protocols"
-HOMEPAGE="https://github.com/jedisct1/dnscrypt-proxy"
-
-LICENSE="ISC"
-SLOT="0"
-IUSE="pie"
-
-DEPEND=">=dev-lang/go-1.12"
-
-FILECAPS=( cap_net_bind_service+ep usr/bin/dnscrypt-proxy )
-PATCHES=( "${FILESDIR}"/config-full-paths-r10.patch )
-
-pkg_setup() {
- enewgroup dnscrypt-proxy
- enewuser dnscrypt-proxy -1 -1 /var/empty dnscrypt-proxy
-}
-
-src_prepare() {
- default
- # Create directory structure suitable for building
- mkdir -p "src/${EGO_PN%/*}" || die
- # fixes $GOPATH/go.mod exists but should not
- rm go.mod || die
- mv "${PN}" "src/${EGO_PN}" || die
- mv "vendor" "src/" || die
-}
-
-src_configure() {
- EGO_BUILD_FLAGS="-buildmode=$(usex pie pie default)"
-}
-
-src_install() {
- dobin dnscrypt-proxy
-
- insinto /etc/dnscrypt-proxy
- newins "src/${EGO_PN}"/example-dnscrypt-proxy.toml dnscrypt-proxy.toml
- doins "src/${EGO_PN}"/example-{blacklist.txt,whitelist.txt}
- doins "src/${EGO_PN}"/example-{cloaking-rules.txt,forwarding-rules.txt}
-
- insinto /usr/share/dnscrypt-proxy
- doins -r "utils/generate-domains-blacklists/."
-
- newinitd "${FILESDIR}"/dnscrypt-proxy.initd dnscrypt-proxy
- newconfd "${FILESDIR}"/dnscrypt-proxy.confd dnscrypt-proxy
- systemd_newunit "${FILESDIR}"/dnscrypt-proxy.service dnscrypt-proxy.service
- systemd_newunit "${FILESDIR}"/dnscrypt-proxy.socket dnscrypt-proxy.socket
-
- einstalldocs
-}
-
-pkg_postinst() {
- fcaps_pkg_postinst
-
- if ! use filecaps; then
- ewarn "'filecaps' USE flag is disabled"
- ewarn "${PN} will fail to listen on port 53"
- ewarn "please do one the following:"
- ewarn "1) re-enable 'filecaps'"
- ewarn "2) change port to > 1024"
- ewarn "3) configure to run ${PN} as root (not recommended)"
- ewarn
- fi
-
- if systemd_is_booted || has_version sys-apps/systemd; then
- elog "Using systemd socket activation may cause issues with speed"
- elog "latency and reliability of ${PN} and is discouraged by upstream"
- elog "Existing installations advised to disable 'dnscrypt-proxy.socket'"
- elog "It is disabled by default for new installations"
- elog "check "$(systemd_get_systemunitdir)/${PN}.service" for details"
- elog
-
- fi
-
- elog "After starting the service you will need to update your"
- elog "/etc/resolv.conf and replace your current set of resolvers"
- elog "with:"
- elog
- elog "nameserver 127.0.0.1"
- elog
- elog "Also see https://github.com/jedisct1/${PN}/wiki"
-}
diff --git a/net-dns/dnscrypt-proxy/dnscrypt-proxy-2.0.24.ebuild b/net-dns/dnscrypt-proxy/dnscrypt-proxy-2.0.24.ebuild
deleted file mode 100644
index 419d40281c69..000000000000
--- a/net-dns/dnscrypt-proxy/dnscrypt-proxy-2.0.24.ebuild
+++ /dev/null
@@ -1,98 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-EGO_PN="github.com/jedisct1/${PN}"
-
-inherit fcaps golang-build systemd user
-
-if [[ ${PV} == 9999 ]]; then
- inherit git-r3
- EGIT_REPO_URI="https://${EGO_PN}.git"
-else
- SRC_URI="https://${EGO_PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="~amd64 ~arm ~x86"
-fi
-
-DESCRIPTION="A flexible DNS proxy, with support for encrypted DNS protocols"
-HOMEPAGE="https://github.com/jedisct1/dnscrypt-proxy"
-
-LICENSE="ISC"
-SLOT="0"
-IUSE="pie"
-
-DEPEND=">=dev-lang/go-1.12"
-
-FILECAPS=( cap_net_bind_service+ep usr/bin/dnscrypt-proxy )
-PATCHES=( "${FILESDIR}"/config-full-paths-r10.patch )
-
-pkg_setup() {
- enewgroup dnscrypt-proxy
- enewuser dnscrypt-proxy -1 -1 /var/empty dnscrypt-proxy
-}
-
-src_prepare() {
- default
- # Create directory structure suitable for building
- mkdir -p "src/${EGO_PN%/*}" || die
- # fixes $GOPATH/go.mod exists but should not
- rm go.mod || die
- mv "${PN}" "src/${EGO_PN}" || die
- mv "vendor" "src/" || die
-}
-
-src_configure() {
- EGO_BUILD_FLAGS="-buildmode=$(usex pie pie default)"
-}
-
-src_install() {
- dobin dnscrypt-proxy
-
- insinto /etc/dnscrypt-proxy
- newins "src/${EGO_PN}"/example-dnscrypt-proxy.toml dnscrypt-proxy.toml
- doins "src/${EGO_PN}"/example-{blacklist.txt,whitelist.txt}
- doins "src/${EGO_PN}"/example-{cloaking-rules.txt,forwarding-rules.txt}
-
- insinto /usr/share/dnscrypt-proxy
- doins -r "utils/generate-domains-blacklists/."
-
- newinitd "${FILESDIR}"/dnscrypt-proxy.initd dnscrypt-proxy
- newconfd "${FILESDIR}"/dnscrypt-proxy.confd dnscrypt-proxy
- systemd_newunit "${FILESDIR}"/dnscrypt-proxy.service dnscrypt-proxy.service
- systemd_newunit "${FILESDIR}"/dnscrypt-proxy.socket dnscrypt-proxy.socket
-
- einstalldocs
-}
-
-pkg_postinst() {
- fcaps_pkg_postinst
-
- if ! use filecaps; then
- ewarn "'filecaps' USE flag is disabled"
- ewarn "${PN} will fail to listen on port 53"
- ewarn "please do one the following:"
- ewarn "1) re-enable 'filecaps'"
- ewarn "2) change port to > 1024"
- ewarn "3) configure to run ${PN} as root (not recommended)"
- ewarn
- fi
-
- if systemd_is_booted || has_version sys-apps/systemd; then
- elog "Using systemd socket activation may cause issues with speed"
- elog "latency and reliability of ${PN} and is discouraged by upstream"
- elog "Existing installations advised to disable 'dnscrypt-proxy.socket'"
- elog "It is disabled by default for new installations"
- elog "check "$(systemd_get_systemunitdir)/${PN}.service" for details"
- elog
-
- fi
-
- elog "After starting the service you will need to update your"
- elog "/etc/resolv.conf and replace your current set of resolvers"
- elog "with:"
- elog
- elog "nameserver 127.0.0.1"
- elog
- elog "Also see https://github.com/jedisct1/${PN}/wiki"
-}