summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--sci-astronomy/cdsclient/cdsclient-3.8.4-r1.ebuild (renamed from sci-astronomy/cdsclient/cdsclient-3.8.4.ebuild)30
-rw-r--r--sci-astronomy/cdsclient/files/cdsclient-makefile.patch18
2 files changed, 26 insertions, 22 deletions
diff --git a/sci-astronomy/cdsclient/cdsclient-3.8.4.ebuild b/sci-astronomy/cdsclient/cdsclient-3.8.4-r1.ebuild
index 6ff53c45a659..3087cd4f8f5b 100644
--- a/sci-astronomy/cdsclient/cdsclient-3.8.4.ebuild
+++ b/sci-astronomy/cdsclient/cdsclient-3.8.4-r1.ebuild
@@ -1,41 +1,31 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
-
-inherit versionator
+EAPI=8
# upstream versioning wrong: 3.71 is really 3.7.1
-MYP="${PN}-$(delete_version_separator 2)"
+MYP="${PN}-$(ver_rs 2 '')"
DESCRIPTION="Collection of scripts to access the CDS databases"
HOMEPAGE="http://cdsweb.u-strasbg.fr/doc/cdsclient.html"
SRC_URI="ftp://cdsarc.u-strasbg.fr/pub/sw/${MYP}.tar.gz"
+S="${WORKDIR}/${MYP}"
LICENSE="all-rights-reserved"
SLOT="0"
KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
-IUSE=""
-
RESTRICT="mirror bindist"
-DEPEND=""
-RDEPEND="app-shells/tcsh"
-S="${WORKDIR}/${MYP}"
+RDEPEND="app-shells/tcsh"
-PATCHES=( "${FILESDIR}/${PN}-makefile.patch" )
-src_prepare() {
- default
- # remove non standard "mantex" page
- sed -e 's/aclient.tex//' -i configure || die
-}
+PATCHES=( "${FILESDIR}"/${PN}-makefile.patch )
src_install() {
local bindir="${EPREFIX}/usr/bin/${PN}"
emake DESTDIR="${D}" SHSDIR="${D}${bindir}" install
- cat <<-EOF > 99${PN}
- PATH=${bindir}
- ROOTPATH=${bindir}
+
+ newenvd - 99${PN} <<-EOF
+ PATH="${bindir}"
+ ROOTPATH="${bindir}"
EOF
- doenvd 99${PN}
}
diff --git a/sci-astronomy/cdsclient/files/cdsclient-makefile.patch b/sci-astronomy/cdsclient/files/cdsclient-makefile.patch
index 6d135a622056..d07928219b40 100644
--- a/sci-astronomy/cdsclient/files/cdsclient-makefile.patch
+++ b/sci-astronomy/cdsclient/files/cdsclient-makefile.patch
@@ -1,5 +1,19 @@
---- cdsclient-3.81/Makefile.in.orig 2016-02-26 17:33:14.217750589 +0000
-+++ cdsclient-3.81/Makefile.in 2016-02-26 17:38:22.463875411 +0000
+- remove non standard "mantex" page
+- respect user flags
+
+--- a/configure
++++ b/configure
+@@ -3938,7 +3938,7 @@
+
+
+ EXPORT_SOURCE_FILE="aclient.c wwwget.c skio.c skclient.c sk.h"
+-EXPORT_MAN_FILE="sk.3 aclient.1 wwwget.1 aclient.tex"
++EXPORT_MAN_FILE="sk.3 aclient.1 wwwget.1 "
+ EXPORT_MAN_TEX="man.tex"
+ CASE="dev"
+
+--- a/Makefile.in
++++ b/Makefile.in
@@ -31,17 +31,17 @@
#################################################################
#PREFIX = /usr/local