summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--sci-mathematics/gap/gap-4.12.2-r3.ebuild18
1 files changed, 10 insertions, 8 deletions
diff --git a/sci-mathematics/gap/gap-4.12.2-r3.ebuild b/sci-mathematics/gap/gap-4.12.2-r3.ebuild
index 2ccaded522a5..d44da14dfd8a 100644
--- a/sci-mathematics/gap/gap-4.12.2-r3.ebuild
+++ b/sci-mathematics/gap/gap-4.12.2-r3.ebuild
@@ -97,15 +97,17 @@ src_prepare() {
src_configure() {
# We unset $ABI because GAP uses it internally for something else.
# --without-gmp and --without-zlib both trigger an AC_MSG_ERROR
- econf \
- ABI="" \
- --with-gmp \
- --with-zlib \
- $(use_enable cpu_flags_x86_popcnt popcnt) \
- $(use_enable memcheck memory-checking) \
- $(use_enable valgrind) \
- $(use_with readline) \
+ local myeconfargs=(
+ ABI=""
+ --with-gmp
+ --with-zlib
+ $(use_enable cpu_flags_x86_popcnt popcnt)
+ $(use_enable memcheck memory-checking)
+ $(use_enable valgrind)
+ $(use_with readline)
$(use_enable debug)
+ )
+ econf "${myeconfargs[@]}"
}
src_compile() {