summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--media-sound/vbrfixc/files/vbrfixc-0.24-gcc43.patch28
-rw-r--r--media-sound/vbrfixc/vbrfixc-0.24-r1.ebuild (renamed from media-sound/vbrfixc/vbrfixc-0.24.ebuild)14
2 files changed, 29 insertions, 13 deletions
diff --git a/media-sound/vbrfixc/files/vbrfixc-0.24-gcc43.patch b/media-sound/vbrfixc/files/vbrfixc-0.24-gcc43.patch
index 89e20e3aade0..d2473e81d8f5 100644
--- a/media-sound/vbrfixc/files/vbrfixc-0.24-gcc43.patch
+++ b/media-sound/vbrfixc/files/vbrfixc-0.24-gcc43.patch
@@ -1,11 +1,31 @@
-diff -ur vbrfixc-0.24/vbrfixc/vbrfix.cpp vbrfixc-0.24.dmd/vbrfixc/vbrfix.cpp
---- vbrfixc-0.24/vbrfixc/vbrfix.cpp 2003-07-17 13:58:21.000000000 -0400
-+++ vbrfixc-0.24.dmd/vbrfixc/vbrfix.cpp 2008-06-11 11:26:42.000000000 -0400
-@@ -16,6 +16,7 @@
+--- a/vbrfixc/vbrfix.cpp
++++ b/vbrfixc/vbrfix.cpp
+@@ -16,6 +16,8 @@
***************************************************************************/
#include "vbrfix.h"
//#include "stdafx.h"//include in mfc version
+#include <cstring>
++#include <stdint.h>
int getXHpos(int ver,int chan);
VbrFix::VbrFix(){
frameptrs=NULL;flags=0;
+@@ -295,7 +297,7 @@
+ }
+ lyrics3Pos=mp3.getpos()-8-4;
+ //find its length
+- bool e=false;unsigned char c;uint correctv1=0,correctv2=0,p=0;char ev1[]="LYRICSEND";char ev2[]="LYRICS200";
++ bool e=false;unsigned char c;uint32_t correctv1=0,correctv2=0,p=0;char ev1[]="LYRICSEND";char ev2[]="LYRICS200";
+ while(!e && mp3.getpos()< mp3length){
+ mp3.fRead(&c,1);
+ if(c==255){logi("Error byte value of 255 in the lyrics3 tag!, asuming tag has ended");e=true;}
+--- a/vbrfixc/wputil.h
++++ b/vbrfixc/wputil.h
+@@ -199,7 +199,7 @@
+ ofstream out(output, ios::out|ios::binary|ios::trunc);
+ if(out.fail())return false;
+ // fast portable file copy
+- return out << in.rdbuf();
++ return bool(out << in.rdbuf());
+ }
+ static wps loadSetting(const char *file,wps setting,wps defaultValue){
+ ifstream in(file, ios::in);
diff --git a/media-sound/vbrfixc/vbrfixc-0.24.ebuild b/media-sound/vbrfixc/vbrfixc-0.24-r1.ebuild
index 696cce119952..6aea3451bdef 100644
--- a/media-sound/vbrfixc/vbrfixc-0.24.ebuild
+++ b/media-sound/vbrfixc/vbrfixc-0.24-r1.ebuild
@@ -1,22 +1,18 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=8
DESCRIPTION="Vbrfix fixes MP3s and re-constructs VBR headers"
-HOMEPAGE="http://home.gna.org/vbrfix/"
+HOMEPAGE="https://wiki.gentoo.org/wiki/No_homepage"
SRC_URI="ftp://mirror.bytemark.co.uk/gentoo/distfiles/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
-# bin endian ones need vbrfixc-0.24-bigendian.diff from gentoo-x86 cvs Attic
+# big-endian ones need vbrfixc-0.24-bigendian.diff from gentoo-x86 cvs Attic
KEYWORDS="amd64 x86"
-IUSE=""
-DEPEND=""
-RDEPEND=""
-
-PATCHES=( "${FILESDIR}/${P}-gcc43.patch" )
+PATCHES=( "${FILESDIR}"/${P}-gcc43.patch )
src_install() {
HTML_DOCS=( vbrfixc/docs/en/*.html )