summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-python/pyfakefs/Manifest1
-rw-r--r--dev-python/pyfakefs/pyfakefs-4.0.2.ebuild29
2 files changed, 30 insertions, 0 deletions
diff --git a/dev-python/pyfakefs/Manifest b/dev-python/pyfakefs/Manifest
index cc9e3635a422..8c6c0389eaf6 100644
--- a/dev-python/pyfakefs/Manifest
+++ b/dev-python/pyfakefs/Manifest
@@ -3,3 +3,4 @@ DIST pyfakefs-3.5.8.tar.gz 171519 BLAKE2B 18eb784cf62108c3363b3b5fa137ec4ce83058
DIST pyfakefs-3.7.1.tar.gz 179420 BLAKE2B 46f902527c2c69af1d7d5e296a25d5415b4fba68d4ed76d7bc138e4b2d53dbd4bf7dc6fd75a8e5277eccb9740c67d5fdf5b640fbc577f22690ee32db434c3676 SHA512 910cef89443546c9a5f600cbe06cbdc396ac82d15d852768c06c2f97e764b05ee9fe9bea7687404a9a962924bd33c45d9de2a04b448fe6350d8cc31c4e163dfc
DIST pyfakefs-3.7.2.tar.gz 180195 BLAKE2B f1e76b652fc67f630fb45798974dc22455e9e99509829fbcaa479f36887c90207d7b6f087e89c9e113bb44df8c4221dc4676129663740812a9426d84a1d47401 SHA512 33bdbf7e21f1135c0ee048943a4b7dffec96e018285e4ee2e6a1c6a7f9e595e27348c83af3803d80322e7fd12a59985a6bf6342aa6211ba95c74ffa20929fb5a
DIST pyfakefs-4.0.1.tar.gz 177542 BLAKE2B 05fe75da0f7525a51f01740c9c83e5cd1f9c565947439ea4c55a7c859b9952539b77a3c3754498d594aa83c77fbcf058131a0cacdba5218d6073de7775e58bf9 SHA512 cf87b8fd8e0c8948f2923e001a61790148b22898538ce190dbb6e13ba4ec5850e95a576d08c7aee94fd342becebf1e50c91bdecf6679a54300ae045b25509a73
+DIST pyfakefs-4.0.2.tar.gz 177627 BLAKE2B a52bd900466203af6170bb9ce92f1e5f73f246d576f12390f5b52224de34fa69a3a4c426319b701953f040e343bcf267e20ea2a33df62c4a46f6397f760330aa SHA512 ba14cbc278ece50142d441b7731b01ba316ba9f11e5d442476e12b8b678490aace9578eb3b2fa2e47d6805795ceaf85574d3c5fb992a098585597c7e96d7143a
diff --git a/dev-python/pyfakefs/pyfakefs-4.0.2.ebuild b/dev-python/pyfakefs/pyfakefs-4.0.2.ebuild
new file mode 100644
index 000000000000..6aaf2a4f55cc
--- /dev/null
+++ b/dev-python/pyfakefs/pyfakefs-4.0.2.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8} pypy3 )
+DISTUTILS_USE_SETUPTOOLS=rdepend
+DISTUTILS_IN_SOURCE_BUILD=1
+
+inherit distutils-r1
+
+DESCRIPTION="a fake file system that mocks the Python file system modules"
+HOMEPAGE="https://github.com/jmcgeheeiv/pyfakefs/ https://pypi.org/project/pyfakefs/"
+SRC_URI="https://github.com/jmcgeheeiv/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~hppa ~ppc ~sparc ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+COMMON_DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND="${COMMON_DEPEND}"
+DEPEND="${COMMON_DEPEND}
+ test? ( dev-python/pytest[${PYTHON_USEDEP}] )"
+
+python_test() {
+ "${EPYTHON}" -m pyfakefs.tests.all_tests -v || die "tests failed under ${EPYTHON}"
+}