summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--www-apps/prewikka/Manifest1
-rw-r--r--www-apps/prewikka/metadata.xml20
-rw-r--r--www-apps/prewikka/prewikka-3.0.0.ebuild31
3 files changed, 52 insertions, 0 deletions
diff --git a/www-apps/prewikka/Manifest b/www-apps/prewikka/Manifest
new file mode 100644
index 000000000000..f316bdc13d2f
--- /dev/null
+++ b/www-apps/prewikka/Manifest
@@ -0,0 +1 @@
+DIST prewikka-3.0.0.tar.gz 1333924 SHA256 fe32c83c6d159c9a724656ea5d15808cfbf7b6398886f736d0ed723fcdbdfe8f SHA512 17d23ac0d5fbd1709133d7403d55ebf8f7d983f0f40be800bbd43d85b862a58a932614f5b08d9a1ce787010073232e78188cffcf009d2b7d3b88ead622deb445 WHIRLPOOL 137ff0e33a21aba96cd2b080a643fe9d45d0705aabfca0ec833c9a88756fd72bdbcb6342edb0a6b81c432394259f53d3eda21a824231d3eaffd3d21bde852e8f
diff --git a/www-apps/prewikka/metadata.xml b/www-apps/prewikka/metadata.xml
new file mode 100644
index 000000000000..6f2383f98070
--- /dev/null
+++ b/www-apps/prewikka/metadata.xml
@@ -0,0 +1,20 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>thomas.andrejak@gmail.com</email>
+ <name>Thomas Andrejak</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <longdescription lang="en">
+ Prewikka is the graphical front-end analysis console for the
+ Prelude Universal SIM. Providing numerous features, Prewikka
+ facilitates the work of users and analysts. It provides alert
+ aggregation and sensor and hearbeat views, and has user management
+ and configurable filters. Prewikka also provides access to external
+ tools such as whois and traceroute.
+ </longdescription>
+</pkgmetadata>
diff --git a/www-apps/prewikka/prewikka-3.0.0.ebuild b/www-apps/prewikka/prewikka-3.0.0.ebuild
new file mode 100644
index 000000000000..76eba123eae9
--- /dev/null
+++ b/www-apps/prewikka/prewikka-3.0.0.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="Graphical front-end analysis console for the Prelude Framework"
+HOMEPAGE="https://www.prelude-siem.org"
+SRC_URI="https://www.prelude-siem.org/pkg/src/3.0.0/${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="adns"
+
+DEPEND="dev-python/setuptools
+ dev-python/lesscpy
+ sys-devel/gettext"
+
+RDEPEND="dev-python/cheetah[${PYTHON_USEDEP}]
+ dev-python/Babel[${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ dev-python/pytz[${PYTHON_USEDEP}]
+ adns? ( dev-python/twisted-names[${PYTHON_USEDEP}] )
+ media-fonts/font-xfree86-type1
+ dev-libs/libprelude[${PYTHON_USEDEP}]
+ dev-libs/libpreludedb[${PYTHON_USEDEP}]"