summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-admin/puppet-agent/Manifest2
-rw-r--r--app-admin/puppet-agent/puppet-agent-6.10.0.ebuild79
2 files changed, 81 insertions, 0 deletions
diff --git a/app-admin/puppet-agent/Manifest b/app-admin/puppet-agent/Manifest
index ee5edccb7eab..323a15414420 100644
--- a/app-admin/puppet-agent/Manifest
+++ b/app-admin/puppet-agent/Manifest
@@ -1,3 +1,5 @@
+DIST puppet-agent_6.10.0-1stretch_amd64.deb 19699044 BLAKE2B 06345d1178cd9fe15f7ae5a56676764517de6587f238a35212845b89a8ac17664cf88821dcfd7fc51de6809104e1e6e6ee22512b7b007ddcd866d898bbc1b461 SHA512 d3bfeb31d769efec58584e582e62b880d399905abf742f394d2a1fc022647ffca14f9ea208a27dbf57cd6ab530737524ca57f021a27dc1a96d105a5dbe1ceded
+DIST puppet-agent_6.10.0-1stretch_i386.deb 20013932 BLAKE2B f19775e2557cbb69ab1f539def040ef7109ee271a44aee1f6ce5dc685b86b78dc0c69fbaee7f29fd054079311169e47bd26f71e154fbe623fdc29489eab67ae5 SHA512 5d0d782c92d392c35a1283e9dd3d4230a657151424838ae3f5f87a6f76c822457e7ad26b7399a2f6e3152e91b23df88767dd18b936dab06939475285dac82e39
DIST puppet-agent_6.7.2-1stretch_amd64.deb 19184682 BLAKE2B 6078c1b21f0e737881d949cfaf052571b40df450e53724696e2738141da30e59da7abf03ce00285ab77fd4ac52291ab6e42da373420807499f37b75c872fa83e SHA512 1c464448b1478397af7b806f8bfcaee0378af9d4b6bfa5a73e8245064329b1b49136107c5fcbaea0ef6cd4e1daf840d1ba331e798b2cd255ead54969520315c9
DIST puppet-agent_6.7.2-1stretch_i386.deb 19452604 BLAKE2B 1915e7b7085db6cb87980a98a7cb85881331719e2af98b07f8461514a0296b3cf5181eb88f78893055a0fa09fc2ffce0e81e866db27abcecf9d8f745e329311c SHA512 8d89735601c9764e207eef77f5d42e836ee9d7c0c0f2856e0f293919cce52e7a42fc28fca42bd0e0bed760063aae527007ef7ce25503ce05fcfd495a44243ee3
DIST puppet-agent_6.8.0-1stretch_amd64.deb 19184708 BLAKE2B ac961857784eaaa55604285cf305dac437007628ea5baa3c3ae9a8a345fcb8cf2b20820bd80cc2c96afb77cb03c4d2779b17b1183c9bc9461b56860d2179f448 SHA512 707146f71b21df4b89244df7b786f481136cfe7b0cabf20aa0d4784aca547ba85c75d13309b77c853b9e034b8271f350b30bc5358010d90b7573e3fdb63c31b6
diff --git a/app-admin/puppet-agent/puppet-agent-6.10.0.ebuild b/app-admin/puppet-agent/puppet-agent-6.10.0.ebuild
new file mode 100644
index 000000000000..a72df734d6b1
--- /dev/null
+++ b/app-admin/puppet-agent/puppet-agent-6.10.0.ebuild
@@ -0,0 +1,79 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit eutils systemd unpacker user
+
+DESCRIPTION="general puppet client utils along with hiera and facter"
+HOMEPAGE="https://puppetlabs.com/"
+SRC_BASE="http://apt.puppetlabs.com/pool/stretch/puppet/${PN:0:1}/${PN}/${PN}_${PV}-1stretch"
+SRC_URI="
+ amd64? ( ${SRC_BASE}_amd64.deb )
+ x86? ( ${SRC_BASE}_i386.deb )"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="puppetdb selinux"
+RESTRICT="strip"
+
+CDEPEND="!app-admin/augeas
+ !app-admin/puppet
+ !dev-ruby/hiera
+ !dev-ruby/facter
+ !app-emulation/virt-what"
+
+DEPEND="
+ ${CDEPEND}"
+RDEPEND="${CDEPEND}
+ app-portage/eix
+ sys-apps/dmidecode
+ sys-libs/glibc
+ sys-libs/readline:0/7
+ sys-libs/ncurses:0[tinfo]
+ selinux? (
+ sys-libs/libselinux[ruby]
+ sec-policy/selinux-puppet
+ )
+ puppetdb? ( >=dev-ruby/puppetdb-termini-5.0.1 )"
+
+S=${WORKDIR}
+
+pkg_setup() {
+ enewgroup puppet
+ enewuser puppet -1 -1 /var/run/puppet puppet
+}
+
+src_install() {
+ # conf.d
+ doconfd etc/default/puppet
+ doconfd etc/default/pxp-agent
+ # logrotate.d
+ insinto /etc/logrotate.d
+ doins etc/logrotate.d/pxp-agent
+ # puppet itself
+ insinto /etc/puppetlabs
+ doins -r etc/puppetlabs/*
+ # logdir for systemd
+ dodir var/log/puppetlabs/puppet/
+ fperms 0750 var/log/puppetlabs/puppet/
+ # the rest
+ insinto /opt
+ dodir opt/puppetlabs/puppet/cache
+ doins -r opt/*
+ fperms 0750 /opt/puppetlabs/puppet/cache
+ # init
+ newinitd "${FILESDIR}/puppet.initd" puppet
+ systemd_dounit lib/systemd/system/puppet.service
+ systemd_dounit lib/systemd/system/pxp-agent.service
+ systemd_newtmpfilesd "${FILESDIR}/puppet-agent.conf.tmpfilesd" puppet-agent.conf
+ # symlinks
+ chmod 0755 -R "${D}/opt/puppetlabs/puppet/bin/"
+ chmod 0755 "${D}//opt/puppetlabs/puppet/lib/virt-what/virt-what-cpuid-helper"
+ dosym ../../opt/puppetlabs/bin/facter /usr/bin/facter
+ dosym ../../opt/puppetlabs/bin/hiera /usr/bin/hiera
+ dosym ../../opt/puppetlabs/bin/puppet /usr/bin/puppet
+ dosym ../../opt/puppetlabs/puppet/bin/virt-what /usr/bin/virt-what
+ dosym ../../opt/puppetlabs/puppet/bin/augparse /usr/bin/augparse
+ dosym ../../opt/puppetlabs/puppet/bin/augtool /usr/bin/augtool
+}