summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--sci-mathematics/gimps/Manifest1
-rw-r--r--sci-mathematics/gimps/gimps-29.4.8.ebuild68
2 files changed, 69 insertions, 0 deletions
diff --git a/sci-mathematics/gimps/Manifest b/sci-mathematics/gimps/Manifest
index 38024671cd62..a967e36314e4 100644
--- a/sci-mathematics/gimps/Manifest
+++ b/sci-mathematics/gimps/Manifest
@@ -4,3 +4,4 @@ DIST p95v294b5.linux32.tar.gz 5455113 BLAKE2B a615ff15a77eaeebd6a1324f59e6b780d8
DIST p95v294b5.linux64.tar.gz 6244650 BLAKE2B c81623f70c66ec9443c1f4858851525b9064bcfd948bb831f63774e6a09ee2e86eb2e295db4d849ac40e55f1d5166a470e248b5eac0a4b2a4322b7041f1032a9 SHA512 e315ea226649df2135895a1206e5845fd05587ad190b676228e5e1cfca04a11b698f1a7d5b8e7c96b0cd174ce3dbeb6000240b67a3f0f90572f3bf15166020e5
DIST p95v294b7.linux32.tar.gz 5455201 BLAKE2B 2d542c06fb490f6619884be3cd510fb77e130184d2b7d3bb44fd375fcd7c95e38ef4cf80ed01079c9f395d6e8a526930a07357f20e14277beba4e232f4e2ca27 SHA512 21ee6a8f0a4482bdb22d80093b24a8b9d7e091577628dc797ad01d3a0ab98e946814c70a6313e2624fffa6658454707f88d24608e107048fc6361d15aa5a7fbe
DIST p95v294b7.linux64.tar.gz 6244730 BLAKE2B ca5d0aad96e9bd5fb1bcb232435a26b7d8c2b9d869a6dc638d883fb892013df7a823abb0dae4545c2191b5f39b9cd29ee83400f452fbe63255f2dca899ad6bce SHA512 0579ea9ca1977884c8c50f8c8655b0fef1d5e2b456adca23d6d93542734727f265dc8f784c27fc9510c89afeec7386d4a9a9e9b5d691a97fed8189bef5577b3d
+DIST p95v294b8.linux64.tar.gz 6244091 BLAKE2B ec02f582296f8959765f97526646f2f4a679a2b61d3c8e8efc971bf765c7f3b5cd4a9e2667661bcc6b0a3a088d095671af9b1f371f0e671de495935d582bf8e7 SHA512 bec8ce2081e9e349317441bbaa724e5d21ddfa1e328ccb6a17af796d41b201d96b2835fc2afcd68e350b22213225812cafdfca7973a7cd2071c1460188b3245d
diff --git a/sci-mathematics/gimps/gimps-29.4.8.ebuild b/sci-mathematics/gimps/gimps-29.4.8.ebuild
new file mode 100644
index 000000000000..c6c82e67d5b4
--- /dev/null
+++ b/sci-mathematics/gimps/gimps-29.4.8.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit pax-utils systemd readme.gentoo-r1 versionator
+
+DESCRIPTION="The Great Internet Mersenne Prime Search"
+HOMEPAGE="http://mersenne.org/"
+
+# The author has finally caved in to the pressure of putting the build
+# number in the package name. Some dark magic necessary to get to the
+# package name
+
+MY_PV=$(replace_version_separator 2 'b' )
+
+SRC_URI="
+ amd64? ( ftp://mersenne.org/gimps/p95v${MY_PV/./}.linux64.tar.gz )"
+
+SLOT="0"
+LICENSE="GIMPS"
+KEYWORDS="-* ~amd64"
+
+# Since there are no statically linked binaries for this version of mprime,
+# and no static binaries for amd64 in general, we use the dynamically linked
+# ones and try to cover the .so deps with the packages listed in RDEPEND.
+# libgmp.so.10.3.2 is bundled within the .tar.gz, but we use the system one.
+
+DEPEND=""
+RDEPEND="net-misc/curl
+ >=dev-libs/gmp-6.1.2"
+
+S="${WORKDIR}"
+I="/opt/gimps"
+
+QA_PREBUILT="opt/gimps/mprime"
+
+DOCS=( license.txt readme.txt stress.txt whatsnew.txt undoc.txt )
+
+src_install() {
+ dodir ${I} /var/lib/gimps
+ pax-mark m mprime
+ cp mprime "${D}/${I}" || die
+ fperms a-w "${I}/mprime"
+ fowners root:0 "${I}"
+ fowners root:0 "${I}/mprime"
+
+ einstalldocs
+
+ readme.gentoo_create_doc
+
+ newinitd "${FILESDIR}/${PN}-28.9-init.d" gimps
+ newconfd "${FILESDIR}/${PN}-25.6-conf.d" gimps
+
+ systemd_dounit "${FILESDIR}/${PN}.service"
+ systemd_newtmpfilesd "${FILESDIR}/${PN}.tmpfiles" "${PN}.conf"
+}
+
+pkg_postinst() {
+ readme.gentoo_print_elog
+}
+
+pkg_postrm() {
+ echo
+ einfo "GIMPS data files were not removed."
+ einfo "Remove them manually from /var/lib/gimps/"
+ echo
+}