summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-text/atril/Manifest1
-rw-r--r--app-text/atril/atril-1.28.0.ebuild113
2 files changed, 114 insertions, 0 deletions
diff --git a/app-text/atril/Manifest b/app-text/atril/Manifest
index 045856407b74..a0d739668c61 100644
--- a/app-text/atril/Manifest
+++ b/app-text/atril/Manifest
@@ -1,3 +1,4 @@
DIST atril-1.26.0.tar.xz 1986160 BLAKE2B 40de33749113144c49341cf8249bd20de37c3d64f3daa865dfe2bcad117e1c2b5aae2aef3b4e0199fd2656b17af236e2a863ef97933decc5072e3419219154e4 SHA512 9c4e8b1c45959136c8fc4c5db47117e45e8afca8be2294418e6c1a0f8098c162ccaa4a60e5baea34db91d45d345a3953afe95281782986e7046b87a34c8f7dbd
DIST atril-1.26.1.tar.xz 2087068 BLAKE2B d655bffb4a8245bb3cc25fc91d08ba64ade22fb6da24f5fcb9c418c020c99df66c85a0b59f1d0c31a2f450650d9807adc248a7baeb74cb696bf3687270572f47 SHA512 276e80a81234f3228065f3a804fbd8a306ac948978f3dfd233f678dc4fb6f833ebd1123950996ae08869fac112ebb0d2785ab60fde6bfddd2d2c407a2c991ea3
DIST atril-1.26.2.tar.xz 2095464 BLAKE2B 9e0d0829c7ae692f695e3cc5a45927b503c87e57d6e6a5808626f71de01394201047fe4bdca804369d1184802eff38364ae43e36536e1258d6798e473e5e08ac SHA512 d0b3fe14443907e43a58083282d555b74189d63d94e9ec0c2053976ad529d236738c3af4a668e813307d1ba44551b0a8ad1bc78cd8f53ab61cb811eca136eec9
+DIST atril-1.28.0.tar.xz 2093588 BLAKE2B 6e5b2f63ce1a0bd1f419b0e9ccb29887086c180ccdeb473770bc20a6408ba37b3334eca0d808c304f20c26818138eeb5116a55d02e8e84b60eeedda03254896f SHA512 dd5f77b3ba2033a3591e0f58742d75eefdd0bfdcdec80a6aa6148a1cf37e4508776733013f946103bdf0412f35dee0b283cc254fa0033fc14966df323bb371a8
diff --git a/app-text/atril/atril-1.28.0.ebuild b/app-text/atril/atril-1.28.0.ebuild
new file mode 100644
index 000000000000..66e489ce9208
--- /dev/null
+++ b/app-text/atril/atril-1.28.0.ebuild
@@ -0,0 +1,113 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+MATE_LA_PUNT="yes"
+
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit mate python-any-r1 virtualx
+
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~riscv ~x86"
+
+DESCRIPTION="Atril document viewer for MATE"
+LICENSE="FDL-1.1+ GPL-2+ GPL-3+ LGPL-2+ LGPL-2.1+"
+SLOT="0"
+
+IUSE="caja dbus debug djvu dvi epub +introspection keyring nls +postscript synctex t1lib test tiff xps"
+
+REQUIRED_USE="t1lib? ( dvi )"
+
+COMMON_DEPEND="
+ app-accessibility/at-spi2-core:2
+ app-text/poppler[cairo]
+ dev-libs/glib:2
+ dev-libs/libxml2:2
+ sys-libs/zlib
+ x11-libs/gdk-pixbuf:2
+ x11-libs/gtk+:3[introspection?]
+ x11-libs/libICE
+ x11-libs/libSM:0
+ x11-libs/libX11
+ x11-libs/cairo
+ x11-libs/pango
+ caja? ( mate-base/caja[introspection?] )
+ djvu? ( app-text/djvu:0 )
+ dvi? (
+ virtual/tex-base
+ t1lib? ( media-libs/t1lib:5 )
+ )
+ epub? (
+ <dev-libs/mathjax-3
+ net-libs/webkit-gtk:4.1
+ )
+ keyring? ( app-crypt/libsecret )
+ introspection? ( dev-libs/gobject-introspection:= )
+ postscript? ( app-text/libspectre )
+ synctex? ( virtual/tex-base )
+ tiff? ( media-libs/tiff:= )
+ xps? ( app-text/libgxps )
+"
+
+RDEPEND="${COMMON_DEPEND}
+ virtual/libintl
+"
+
+BDEPEND="${COMMON_DEPEND}
+ app-text/docbook-xml-dtd:4.1.2
+ app-text/yelp-tools
+ dev-util/gdbus-codegen
+ dev-util/glib-utils
+ dev-util/gtk-doc
+ dev-build/gtk-doc-am
+ sys-devel/gettext
+ virtual/pkgconfig
+ test? ( $(python_gen_any_dep 'dev-util/dogtail[${PYTHON_USEDEP}]') )
+"
+
+#RESTRICT="!test? ( test )"
+# Tests use dogtail and require using accessibility services.
+# Until we figure out how to run successfully, don't run tests
+RESTRICT="test"
+
+python_check_deps() {
+ use test && python_has_version "dev-util/dogtail[${PYTHON_USEDEP}]"
+}
+
+pkg_setup() {
+ use test && python-any-r1_pkg_setup
+}
+
+src_configure() {
+ # Passing --disable-help would drop offline help, that would be inconsistent
+ # with helps of the most of GNOME apps that doesn't require network for that.
+ mate_src_configure \
+ --enable-comics \
+ --enable-pdf \
+ --enable-pixbuf \
+ --enable-previewer \
+ --enable-thumbnailer \
+ $(use_with keyring) \
+ $(use_enable caja) \
+ $(use_enable dbus) \
+ $(use_enable debug) \
+ $(use_enable djvu) \
+ $(use_enable dvi) \
+ $(use_enable epub) \
+ $(use_enable introspection) \
+ $(use_enable nls) \
+ $(use_enable postscript ps) \
+ $(use_enable synctex) \
+ $(use_enable t1lib) \
+ $(use_enable test tests) \
+ $(use_enable tiff) \
+ $(use_enable xps)
+}
+
+src_test() {
+ export GSETTINGS_BACKEND=keyfile
+ gsettings set org.gnome.desktop.interface toolkit-accessibility true || die
+ gsettings set org.mate.interface accessibility true || die
+ virtx emake check
+}