summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-i18n/kcm-fcitx/Manifest1
-rw-r--r--app-i18n/kcm-fcitx/kcm-fcitx-0.5.2.ebuild39
2 files changed, 40 insertions, 0 deletions
diff --git a/app-i18n/kcm-fcitx/Manifest b/app-i18n/kcm-fcitx/Manifest
index 54f743a503aa..14a52e6efa76 100644
--- a/app-i18n/kcm-fcitx/Manifest
+++ b/app-i18n/kcm-fcitx/Manifest
@@ -1,3 +1,4 @@
DIST kcm-fcitx-0.4.2.tar.xz 63796 SHA256 f681c1a4172b74a63c36094f860eff4ea778422e1062b00fd03509eda745ed66 SHA512 51ccc5b03f076e73cda7852b1bb1598e56114fe1a7733f3eb0a731c0249cbaa2ac7f4c27115929d236cc94a3f131fc790933cddff624387d050fecf3e170842e WHIRLPOOL 6c0f3e4d345c7570ee519878c141ba2f708c85e0dc8a171058af291e6a02b48cdd3965335b9eb766f9a149b31d5fccc0334f8bb7352eb978625367af064e6b17
DIST kcm-fcitx-0.4.3.tar.xz 56864 SHA256 b7e9ad4569c0940f9654d58de1f13281fcbcab56febbd346951edcfa0a86e208 SHA512 d311699a5d99f75d353899b7fba0a950491ee8b891724b855033449900ec4b3db9408bb1b80e60ceb0dbb0ce91072162062261a497f83a2a683214b71c3f4713 WHIRLPOOL 04aec049436a120362d02ba900a0d8639feb359b4cc6b99a871c7ffa8d9660270c321828b8660c718890a7f0ea308ea584711ed712762aab712fe8d7e72a205a
DIST kcm-fcitx-0.5.0.tar.xz 55964 SHA256 079b309aea4b354d081d45d3dde6d754b24717eb7653344055633453cb328b33 SHA512 219b962c4b6f1763b389dc20d22a671d960a884f5c3f0faddbd4919b61dd6d93e600cbf440b15bc42f63cb383ed5ca65e657fa835c520196c8bd9d64a160baa3 WHIRLPOOL df9db7b5198130409986c4805a7771b6df4bd44d532071499ec6eb522af7bfdd9d576fbdf3664720e47a02a57e35409c69fff962152423ac59bab71d8c1e0947
+DIST kcm-fcitx-0.5.2.tar.xz 55936 SHA256 348b7afd18670c0879e616d6e097c2d8b033d1a7f5abbc3b75876953bd67f504 SHA512 9418001ad92ada2e7c48c426b24b6babebb3e41510c9ff2aac01e25f84f79cd02a3e413267a31feb677beca51070a4ca55f5d64bd103ddd9ab7853f207370882 WHIRLPOOL 8ca8032ea4b50228ea33189d7afac160cc04882c2ac7403de8cb244b39feddfb89019b4ab4a6caf67b2a9d40c2a9b97cdee0832c5beec4c108b67bc35f0b5923
diff --git a/app-i18n/kcm-fcitx/kcm-fcitx-0.5.2.ebuild b/app-i18n/kcm-fcitx/kcm-fcitx-0.5.2.ebuild
new file mode 100644
index 000000000000..283188e82b5e
--- /dev/null
+++ b/app-i18n/kcm-fcitx/kcm-fcitx-0.5.2.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit kde5
+
+DESCRIPTION="KDE configuration module for Fcitx"
+HOMEPAGE="http://fcitx-im.org/"
+SRC_URI="http://download.fcitx-im.org/${PN}/${P}.tar.xz"
+
+LICENSE="GPL-3"
+SLOT="5"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=app-i18n/fcitx-4.2.8
+ app-i18n/fcitx-qt5
+ dev-qt/qtcore:5
+ dev-qt/qtdbus:5
+ dev-qt/qtgui:5
+ dev-qt/qtwidgets:5
+ $(add_frameworks_dep extra-cmake-modules)
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep kcmutils)
+ $(add_frameworks_dep ki18n)
+ $(add_frameworks_dep kio)
+ $(add_frameworks_dep kitemviews)
+ $(add_frameworks_dep knewstuff)
+ $(add_frameworks_dep kwidgetsaddons)
+ sys-devel/gettext
+ x11-libs/libxkbfile"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+src_prepare() {
+ # po directory is empty, making the build fail
+ comment_add_subdirectory po
+}