summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--sys-auth/pam_ssh/Manifest1
-rw-r--r--sys-auth/pam_ssh/files/pam_ssh-1.97-EOF.patch11
-rw-r--r--sys-auth/pam_ssh/files/pam_ssh-1.97-doublefree.patch20
-rw-r--r--sys-auth/pam_ssh/pam_ssh-1.97-r1.ebuild45
-rw-r--r--sys-auth/pam_ssh/pam_ssh-1.97-r2.ebuild51
-rw-r--r--sys-auth/pam_ssh/pam_ssh-1.97-r3.ebuild52
6 files changed, 0 insertions, 180 deletions
diff --git a/sys-auth/pam_ssh/Manifest b/sys-auth/pam_ssh/Manifest
index 293dace2b75e..4f6c1889d98b 100644
--- a/sys-auth/pam_ssh/Manifest
+++ b/sys-auth/pam_ssh/Manifest
@@ -1,3 +1,2 @@
-DIST pam_ssh-1.97.tar.bz2 200184 BLAKE2B 572d42850b7eab5ba5a810f63ef39d7654248d87d020961d91ed6d982b9a89c3b233410772171e0ad66dd00fa723bae6c5b599026ec425a809465f65b2aaed90 SHA512 78632ef5baf8c7ac6d28d16a4c7e452978ad09a969c562cfcc708b835dbba3da12317569a618768ef6f9d59db1d5d31f2a0c7b2ab1244ed9caa37eb89413494e
DIST pam_ssh-1.98.tar.bz2 292989 BLAKE2B 08744c6649aa58c7221e5ec07e0c6aefa8d045cf30df01b941962d29f3abdae902b0fbad37923e3ff05536e422a1062732a6998e4b58d978d369df3d866ec1aa SHA512 bf6da4ced0619549d56516c6b24e899664e0948da7a0cc04ff1b536d06cc8c26242c83eb36ed835668c824b777e270aa293162ac77e3c479311386e6e5da39ff
DIST pam_ssh-2.1.tar.xz 361000 BLAKE2B f22836af20b41ae7254f816c33793bb3a128b604ec36a20b207610deebf61f4d5dd070fd6f5093c6f7b6eb9e14f85cd81ddbbed7e97ee581124e5335722d036b SHA512 8252b15efffa5687f740963f7a3c3479b73f99eca26a17155f915a10b9a71362a2778449adf10f01c174cc8545961ce3ea64459338a7c995c242b209529fd640
diff --git a/sys-auth/pam_ssh/files/pam_ssh-1.97-EOF.patch b/sys-auth/pam_ssh/files/pam_ssh-1.97-EOF.patch
deleted file mode 100644
index 80214a1df70c..000000000000
--- a/sys-auth/pam_ssh/files/pam_ssh-1.97-EOF.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- pam_ssh-1.92.orig/pam_get_pass.c 2004-02-19 19:59:05.000000000 +0100
-+++ pam_ssh-1.92/pam_get_pass.c 2009-04-18 13:51:10.000000000 +0200
-@@ -63,6 +63,8 @@
- retval = conv->conv(1, msgs, &resp, conv->appdata_ptr);
- if (retval != PAM_SUCCESS)
- return retval;
-+ if (resp[0].resp == NULL)
-+ return PAM_AUTHTOK_RECOVERY_ERR;
- retval = pam_set_item(pamh, PAM_AUTHTOK, resp[0].resp);
- if (retval != PAM_SUCCESS)
- return retval;
diff --git a/sys-auth/pam_ssh/files/pam_ssh-1.97-doublefree.patch b/sys-auth/pam_ssh/files/pam_ssh-1.97-doublefree.patch
deleted file mode 100644
index 2f63ff8bdcb0..000000000000
--- a/sys-auth/pam_ssh/files/pam_ssh-1.97-doublefree.patch
+++ /dev/null
@@ -1,20 +0,0 @@
---- pam_ssh-1.97/pam_ssh.c.orig 2009-08-01 20:11:00.000000000 +0200
-+++ pam_ssh-1.97/pam_ssh.c 2009-08-01 20:11:16.000000000 +0200
-@@ -627,7 +627,7 @@
- * than the file creation time */
- if (retval = stat(per_agent, &stat_buf)) {
- pam_ssh_log(LOG_ERR, "stat() failed on %s", per_agent);
-- free(per_agent);
-+ pam_set_data(pamh, "ssh_agent_env_agent", NULL, NULL);
- fclose(env_read);
- return retval;
- }
-@@ -646,7 +646,7 @@
- if (start_agent) {
- if ((env_write = open(per_agent, O_CREAT | O_WRONLY, S_IRUSR | S_IWUSR)) < 0) {
- pam_ssh_log(LOG_ERR, "can't write to %s", per_agent);
-- free(per_agent);
-+ pam_set_data(pamh, "ssh_agent_env_agent", NULL, NULL);
- openpam_restore_cred(pamh);
- return PAM_SERVICE_ERR;
- }
diff --git a/sys-auth/pam_ssh/pam_ssh-1.97-r1.ebuild b/sys-auth/pam_ssh/pam_ssh-1.97-r1.ebuild
deleted file mode 100644
index 37f128a89230..000000000000
--- a/sys-auth/pam_ssh/pam_ssh-1.97-r1.ebuild
+++ /dev/null
@@ -1,45 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=2
-
-inherit pam autotools eutils
-
-DESCRIPTION="Uses ssh-agent to provide single sign-on"
-HOMEPAGE="http://pam-ssh.sourceforge.net/"
-SRC_URI="mirror://sourceforge/pam-ssh/${P}.tar.bz2"
-
-LICENSE="BSD-2 BSD ISC"
-SLOT="0"
-KEYWORDS="alpha amd64 arm hppa ia64 m68k ~mips ppc ppc64 s390 sh sparc x86 ~amd64-linux ~x86-linux"
-IUSE=""
-
-# Doesn't work on OpenPAM.
-DEPEND="sys-libs/pam
- sys-devel/libtool"
-
-RDEPEND="sys-libs/pam
- virtual/ssh"
-
-src_prepare() {
- epatch "${FILESDIR}/${P}-doublefree.patch"
- eautoreconf
-}
-
-src_configure() {
- econf \
- "--with-pam-dir=$(getpam_mod_dir)" \
- || die "econf failed"
-}
-
-src_install() {
- emake DESTDIR="${D}" install || die "install failed"
- dodoc AUTHORS ChangeLog NEWS README TODO || die
-
- find "${D}" -name '*.la' -delete || die "Unable to remove libtool archives."
-}
-
-pkg_postinst() {
- elog "You can enable pam_ssh for system authentication by enabling"
- elog "the ssh USE flag on sys-auth/pambase."
-}
diff --git a/sys-auth/pam_ssh/pam_ssh-1.97-r2.ebuild b/sys-auth/pam_ssh/pam_ssh-1.97-r2.ebuild
deleted file mode 100644
index 11e3cc24d817..000000000000
--- a/sys-auth/pam_ssh/pam_ssh-1.97-r2.ebuild
+++ /dev/null
@@ -1,51 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=2
-
-inherit pam autotools eutils flag-o-matic
-
-DESCRIPTION="Uses ssh-agent to provide single sign-on"
-HOMEPAGE="http://pam-ssh.sourceforge.net/"
-SRC_URI="mirror://sourceforge/pam-ssh/${P}.tar.bz2"
-
-LICENSE="BSD-2 BSD ISC"
-SLOT="0"
-KEYWORDS="alpha amd64 arm hppa ia64 m68k ~mips ppc ~ppc64 s390 sh sparc x86 ~amd64-linux ~x86-linux"
-IUSE=""
-
-# Doesn't work on OpenPAM; looks for OpenSSH at build time (bug
-# #282993) and won't work with other implementations either
-RDEPEND="sys-libs/pam
- net-misc/openssh"
-
-DEPEND="${RDEPEND}
- sys-devel/libtool"
-
-src_prepare() {
- epatch "${FILESDIR}/${P}-doublefree.patch"
- eautoreconf
-}
-
-src_configure() {
- # hide all the otherwise-exported symbols that may clash with
- # other software loading the PAM modules (see bug #274924 as an
- # example).
- append-ldflags -Wl,--version-script="${FILESDIR}"/pam_symbols.ver
-
- econf \
- "--with-pam-dir=$(getpam_mod_dir)" \
- || die "econf failed"
-}
-
-src_install() {
- emake DESTDIR="${D}" install || die "install failed"
- dodoc AUTHORS ChangeLog NEWS README TODO || die
-
- find "${D}" -name '*.la' -delete || die "Unable to remove libtool archives."
-}
-
-pkg_postinst() {
- elog "You can enable pam_ssh for system authentication by enabling"
- elog "the ssh USE flag on sys-auth/pambase."
-}
diff --git a/sys-auth/pam_ssh/pam_ssh-1.97-r3.ebuild b/sys-auth/pam_ssh/pam_ssh-1.97-r3.ebuild
deleted file mode 100644
index d4c29b80106a..000000000000
--- a/sys-auth/pam_ssh/pam_ssh-1.97-r3.ebuild
+++ /dev/null
@@ -1,52 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=2
-
-inherit pam autotools eutils flag-o-matic
-
-DESCRIPTION="Uses ssh-agent to provide single sign-on"
-HOMEPAGE="http://pam-ssh.sourceforge.net/"
-SRC_URI="mirror://sourceforge/pam-ssh/${P}.tar.bz2"
-
-LICENSE="BSD-2 BSD ISC"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-linux ~x86-linux"
-IUSE=""
-
-# Doesn't work on OpenPAM; looks for OpenSSH at build time (bug
-# #282993) and won't work with other implementations either
-RDEPEND="sys-libs/pam
- net-misc/openssh"
-
-DEPEND="${RDEPEND}
- sys-devel/libtool"
-
-src_prepare() {
- epatch "${FILESDIR}/${P}-doublefree.patch"
- epatch "${FILESDIR}/${P}-EOF.patch"
- eautoreconf
-}
-
-src_configure() {
- # hide all the otherwise-exported symbols that may clash with
- # other software loading the PAM modules (see bug #274924 as an
- # example).
- append-ldflags -Wl,--version-script="${FILESDIR}"/pam_symbols.ver
-
- econf \
- "--with-pam-dir=$(getpam_mod_dir)" \
- || die "econf failed"
-}
-
-src_install() {
- emake DESTDIR="${D}" install || die "install failed"
- dodoc AUTHORS ChangeLog NEWS README TODO || die
-
- find "${D}" -name '*.la' -delete || die "Unable to remove libtool archives."
-}
-
-pkg_postinst() {
- elog "You can enable pam_ssh for system authentication by enabling"
- elog "the ssh USE flag on sys-auth/pambase."
-}