summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-admin/rasdaemon/Manifest1
-rw-r--r--app-admin/rasdaemon/files/ras-mc-ctl.openrc10
-rw-r--r--app-admin/rasdaemon/files/rasdaemon.openrc18
-rw-r--r--app-admin/rasdaemon/rasdaemon-0.6.2.ebuild50
4 files changed, 79 insertions, 0 deletions
diff --git a/app-admin/rasdaemon/Manifest b/app-admin/rasdaemon/Manifest
index de7972383472..7d14f3d50523 100644
--- a/app-admin/rasdaemon/Manifest
+++ b/app-admin/rasdaemon/Manifest
@@ -1 +1,2 @@
DIST rasdaemon-0.6.1.tar.bz2 363201 BLAKE2B bdc7ec3c2e7e4b2fee02dddc55b5afd82df64717f45da15dbfd5fee87721b80ac425af5806ee7462cad29c6ab2953a2e649c4b1e455983d8821a1f633d76c85d SHA512 a221a7ea0e4555befbf8acb9d4ce22d5cc7861a0da458111a24905fa06be0e8f3b18d8de5334310a423657febc0532d2705236de89cb1788302bf487ede29f60
+DIST rasdaemon-0.6.2.tar.bz2 375140 BLAKE2B fd22185172777865120fbd13b7bfb5db9b9b0348fe8575ca6b5f16fd662c1e847729e239342b1c9ece70a4e79ad00352bb69d9f80cfbc8da2c961e68874dd03b SHA512 d8c1ee2cc801124837b3a0739f3016a206165306e300ce51e6aac2cef56bb65479f96cdb019ba3a5cffeba94e7b67ca22686d4ac94bfa8a8a1145db6ba51096b
diff --git a/app-admin/rasdaemon/files/ras-mc-ctl.openrc b/app-admin/rasdaemon/files/ras-mc-ctl.openrc
new file mode 100644
index 000000000000..d9790c482e21
--- /dev/null
+++ b/app-admin/rasdaemon/files/ras-mc-ctl.openrc
@@ -0,0 +1,10 @@
+#!/sbin/openrc-run
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+description="Starts ${SVCNAME} service for rasdaemon"
+
+command="/usr/bin/${SVCNAME}"
+command_args="--register-labels"
+pidfile=/run/${SVCNAME}.pid
+command_background=true
diff --git a/app-admin/rasdaemon/files/rasdaemon.openrc b/app-admin/rasdaemon/files/rasdaemon.openrc
new file mode 100644
index 000000000000..c16f18dbe3fe
--- /dev/null
+++ b/app-admin/rasdaemon/files/rasdaemon.openrc
@@ -0,0 +1,18 @@
+#!/sbin/openrc-run
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+description="Starts ${SVCNAME} service"
+
+command="/usr/bin/${SVCNAME}"
+command_args="--foreground --record"
+pidfile=/run/${SVCNAME}.pid
+command_background=true
+
+start_post() {
+ "${command}" --enable
+}
+
+stop_post() {
+ "${command}" --disable
+}
diff --git a/app-admin/rasdaemon/rasdaemon-0.6.2.ebuild b/app-admin/rasdaemon/rasdaemon-0.6.2.ebuild
new file mode 100644
index 000000000000..330e1815fc39
--- /dev/null
+++ b/app-admin/rasdaemon/rasdaemon-0.6.2.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit linux-info systemd
+
+DESCRIPTION="Reliability, Availability and Serviceability logging tool"
+HOMEPAGE="http://www.infradead.org/~mchehab/rasdaemon/"
+SRC_URI="http://www.infradead.org/~mchehab/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND="
+ ${DEPEND}
+ sys-devel/gettext
+ dev-db/sqlite
+ sys-apps/dmidecode
+ dev-perl/DBD-SQLite
+"
+
+pkg_setup() {
+ linux-info_pkg_setup
+ local CONFIG_CHECK="~FUNCTION_TRACER ~FUNCTION_GRAPH_TRACER ~STACK_TRACER ~DYNAMIC_FTRACE"
+ check_extra_config
+}
+
+src_configure() {
+ econf --enable-abrt-report \
+ --enable-aer \
+ --enable-arm \
+ --enable-extlog \
+ --enable-hisi-ns-decode \
+ --enable-mce \
+ --enable-non-standard \
+ --enable-sqlite3 \
+ --localstatedir=/var
+}
+
+src_install() {
+ default
+ systemd_dounit misc/*.service
+
+ newinitd "${FILESDIR}/rasdaemon.openrc" rasdaemon
+ newinitd "${FILESDIR}/ras-mc-ctl.openrc" ras-mc-ctl
+}