summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-haskell/cabal/Manifest6
-rw-r--r--dev-haskell/cabal/cabal-3.2.1.0-r1.ebuild54
-rw-r--r--dev-haskell/cabal/cabal-3.2.1.0-r2.ebuild66
-rw-r--r--dev-haskell/cabal/cabal-3.4.1.0-r1.ebuild69
-rw-r--r--dev-haskell/cabal/cabal-3.4.1.0.ebuild51
-rw-r--r--dev-haskell/cabal/metadata.xml1
6 files changed, 140 insertions, 107 deletions
diff --git a/dev-haskell/cabal/Manifest b/dev-haskell/cabal/Manifest
index 7d6fc904f338..e08a1af49c1b 100644
--- a/dev-haskell/cabal/Manifest
+++ b/dev-haskell/cabal/Manifest
@@ -1,2 +1,4 @@
-DIST Cabal-3.2.1.0.tar.gz 823331 BLAKE2B 060f4808010f9eefd943312144c75e021bf02083c2a0805128da6c9b93da94ba13fe37cef1fbe27e41fe8a10610e088b923783f4b7bb57150532d3a3ea4a91fc SHA512 279088a2ab9145efc03dbdd10941edcf6034137046ee3b659a8cf0ff075a03e3edff28fd01d432d39701c5a7e05a50b99cf8de95f05d3bd4e75edb3af0e3a598
-DIST Cabal-3.4.1.0.tar.gz 836938 BLAKE2B b185d2beb91a0317b392c6f32ea47a574b8037b23f5131334bca1282359218ab94aa406be737e0fbb15458e7dfa2cba2b22f7776d42c20aeed2b87598cda0e2d SHA512 93233007b70487c76b8ceb9e475ebff0cae4c86a4694820ee505ee83d9049147d60c32c9aea5c4802faf5273adaaae66db299c1ee722aed64c716ac7a3b3aa90
+DIST cabal-3.2.1.0-rev1.cabal 27482 BLAKE2B 7726071d1d59f6f2dcc382346d8e75d219a00bc3b8f936049b464a13224ad1cac0cc6e065a0ab0fdd1ee85d24d3d7e33abbebd603dbac4ff564f72c8aafcab3b SHA512 0d8bb2d72f825a6e3e88e5a0146a97a0ea2f7fa7c4950205ce652648abda2c74ea336654ef77b40f95865cde57126a8725c7538e0d492e74cadf7ebcd4d80d4d
+DIST cabal-3.2.1.0.tar.gz 823331 BLAKE2B 060f4808010f9eefd943312144c75e021bf02083c2a0805128da6c9b93da94ba13fe37cef1fbe27e41fe8a10610e088b923783f4b7bb57150532d3a3ea4a91fc SHA512 279088a2ab9145efc03dbdd10941edcf6034137046ee3b659a8cf0ff075a03e3edff28fd01d432d39701c5a7e05a50b99cf8de95f05d3bd4e75edb3af0e3a598
+DIST cabal-3.4.1.0-rev1.cabal 31402 BLAKE2B cfaeee44401e73fa6f80e06896ae21dcbc162a1932963ffdf44428db50a63970ef8323ae6bff0a0f11341a1d31c8b766770b6f6b892d896a27710f44dc655147 SHA512 786c52e25062b0d2934a455a623dc78f4581add2875723356ddb4ff51346e35bf9ad226bda2f25863a30e57e4e7c3ad2f2df7aed3fdbe2c888b4397841b830cc
+DIST cabal-3.4.1.0.tar.gz 836938 BLAKE2B b185d2beb91a0317b392c6f32ea47a574b8037b23f5131334bca1282359218ab94aa406be737e0fbb15458e7dfa2cba2b22f7776d42c20aeed2b87598cda0e2d SHA512 93233007b70487c76b8ceb9e475ebff0cae4c86a4694820ee505ee83d9049147d60c32c9aea5c4802faf5273adaaae66db299c1ee722aed64c716ac7a3b3aa90
diff --git a/dev-haskell/cabal/cabal-3.2.1.0-r1.ebuild b/dev-haskell/cabal/cabal-3.2.1.0-r1.ebuild
deleted file mode 100644
index dc5b3144aa80..000000000000
--- a/dev-haskell/cabal/cabal-3.2.1.0-r1.ebuild
+++ /dev/null
@@ -1,54 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-# ebuild generated by hackport 0.6.7.9999
-#hackport: flags: -bundled-binary-generic
-
-# Drop test-suite due to "circular" dependencies with quickcheck
-CABAL_FEATURES="lib profile haddock hoogle hscolour"
-CABAL_FEATURES+=" nocabaldep" # in case installed Cabal is broken
-inherit haskell-cabal
-
-MY_PN="Cabal"
-MY_P="${MY_PN}-${PV}"
-
-DESCRIPTION="A framework for packaging Haskell software"
-HOMEPAGE="https://www.haskell.org/cabal/"
-SRC_URI="https://hackage.haskell.org/package/${MY_P}/${MY_P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0/${PV}"
-KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux" # ~ppc ~ppc64 ~ppc-macos
-IUSE=""
-
-RESTRICT=test # circular deps: cabal -> quickcheck -> cabal
-
-# GHC lower bound set to 8.0 to remove semigroups and fail dependencies.
-RDEPEND=" >=dev-haskell/mtl-2.1:=[profile?] <dev-haskell/mtl-2.3:=[profile?]
- >=dev-haskell/parsec-3.1.13.0:=[profile?] <dev-haskell/parsec-3.2:=[profile?]
- >=dev-haskell/text-1.2.3.0:=[profile?] <dev-haskell/text-1.3:=[profile?]
- >=dev-lang/ghc-8.0:=
-"
-DEPEND="${RDEPEND}"
-
-S="${WORKDIR}/${MY_P}"
-
-src_prepare() {
- default
-
- # Cabal bootstraps with 'ghc --make' without package cleanup in environment.
- # That causes module collisions at build:
- # - pulseaudio: Distribution/Utils/Structured.hs:98:1: error: Ambiguous module name ‘Data.Time’: it was found in multiple packages: pulseaudio-0.0.2.1 time-1.9.3
- # - kinds: Distribution/Utils/Structured.hs:106:1: error: Ambiguous module name ‘Data.Kind’: it was found in multiple packages: base-4.14.1.0 kinds-0.0.1.5
- HCFLAGS="${HCFLAGS} -ignore-package=pulseaudio"
- HCFLAGS="${HCFLAGS} -ignore-package=kinds"
-}
-
-src_configure() {
- haskell-cabal_src_configure \
- --flag=-bundled-binary-generic
-}
-
-CABAL_CORE_LIB_GHC_PV="8.10.6"
diff --git a/dev-haskell/cabal/cabal-3.2.1.0-r2.ebuild b/dev-haskell/cabal/cabal-3.2.1.0-r2.ebuild
new file mode 100644
index 000000000000..f7ec4a9eae1f
--- /dev/null
+++ b/dev-haskell/cabal/cabal-3.2.1.0-r2.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+# ebuild generated by hackport 0.8.0.0.9999
+#hackport: flags: -parsec-struct-diff
+
+CABAL_HACKAGE_REVISION=1
+CABAL_PN="Cabal"
+
+# Drop test-suite due to "circular" dependencies with quickcheck
+CABAL_FEATURES="lib profile haddock hoogle hscolour" # test-suite
+CABAL_FEATURES+=" nocabaldep" # in case installed Cabal is broken
+inherit haskell-cabal
+
+DESCRIPTION="A framework for packaging Haskell software"
+HOMEPAGE="https://www.haskell.org/cabal/"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+# Keep in sync with relevant ghc versions (CABAL_CORE_LIB_GHC_PV)
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux" # ~ppc ~ppc64 ~ppc-macos ~x86-macos ~x86-solaris
+
+RESTRICT=test # circular deps: cabal -> quickcheck -> cabal
+
+RDEPEND="
+ >=dev-lang/ghc-8.4.3:=
+"
+DEPEND="${RDEPEND}
+"
+# test? (
+# >=dev-haskell/base-compat-0.11.0 <dev-haskell/base-compat-0.12
+# >=dev-haskell/base-orphans-0.6 <dev-haskell/base-orphans-0.9
+# >=dev-haskell/diff-0.4 <dev-haskell/diff-0.5
+# >=dev-haskell/integer-logarithms-1.0.2 <dev-haskell/integer-logarithms-1.1
+# >=dev-haskell/optparse-applicative-0.13.2.0 <dev-haskell/optparse-applicative-0.16
+# >=dev-haskell/quickcheck-2.14 <dev-haskell/quickcheck-2.15
+# >=dev-haskell/stm-2.4.5.0 <dev-haskell/stm-2.6
+# dev-haskell/tagged
+# >=dev-haskell/tar-0.5.0.3 <dev-haskell/tar-0.6
+# >=dev-haskell/tasty-1.2.3 <dev-haskell/tasty-1.4
+# >=dev-haskell/tasty-golden-2.3.1.1 <dev-haskell/tasty-golden-2.4
+# dev-haskell/tasty-hunit
+# dev-haskell/tasty-quickcheck
+# dev-haskell/temporary
+# >=dev-haskell/tree-diff-0.1 <dev-haskell/tree-diff-0.2
+# )
+
+src_prepare() {
+ haskell-cabal_src_prepare
+
+ # Cabal bootstraps with 'ghc --make' without package cleanup in environment.
+ # That causes module collisions at build:
+ # - pulseaudio: Distribution/Utils/Structured.hs:98:1: error: Ambiguous module name ‘Data.Time’: it was found in multiple packages: pulseaudio-0.0.2.1 time-1.9.3
+ # - kinds: Distribution/Utils/Structured.hs:106:1: error: Ambiguous module name ‘Data.Kind’: it was found in multiple packages: base-4.14.1.0 kinds-0.0.1.5
+ HCFLAGS="${HCFLAGS} -ignore-package=pulseaudio"
+ HCFLAGS="${HCFLAGS} -ignore-package=kinds"
+}
+
+src_configure() {
+ haskell-cabal_src_configure \
+ --flag=-parsec-struct-diff
+}
+
+CABAL_CORE_LIB_GHC_PV="8.10.6 8.10.7"
diff --git a/dev-haskell/cabal/cabal-3.4.1.0-r1.ebuild b/dev-haskell/cabal/cabal-3.4.1.0-r1.ebuild
new file mode 100644
index 000000000000..ce7ccae0f5c3
--- /dev/null
+++ b/dev-haskell/cabal/cabal-3.4.1.0-r1.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+# ebuild generated by hackport 0.8.0.0.9999
+#hackport: flags: -parsec-struct-diff
+
+CABAL_HACKAGE_REVISION=1
+CABAL_PN="Cabal"
+
+# drop tests due to circular deps
+CABAL_FEATURES="lib profile haddock hoogle hscolour" # test-suite
+CABAL_FEATURES+=" nocabaldep" # in case installed Cabal is broken
+inherit haskell-cabal
+
+DESCRIPTION="A framework for packaging Haskell software"
+HOMEPAGE="https://www.haskell.org/cabal/"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+# Keep in sync with relevant ghc versions (CABAL_CORE_LIB_GHC_PV)
+KEYWORDS="amd64 ~arm64 ~ppc64 ~riscv ~x86 ~amd64-linux ~x86-linux"
+
+RESTRICT=test # circular deps: cabal -> quickcheck -> cabal
+
+RDEPEND="
+ >=dev-lang/ghc-8.4.3:=
+"
+DEPEND="${RDEPEND}
+"
+# test? (
+# >=dev-haskell/async-2.2.2 <dev-haskell/async-2.3
+# >=dev-haskell/base-compat-0.11.0 <dev-haskell/base-compat-0.12
+# >=dev-haskell/base-orphans-0.6 <dev-haskell/base-orphans-0.9
+# >=dev-haskell/clock-0.8 <dev-haskell/clock-0.9
+# >=dev-haskell/diff-0.4 <dev-haskell/diff-0.5
+# >=dev-haskell/integer-logarithms-1.0.2 <dev-haskell/integer-logarithms-1.1
+# >=dev-haskell/optparse-applicative-0.13.2.0 <dev-haskell/optparse-applicative-0.17
+# >=dev-haskell/quickcheck-2.14 <dev-haskell/quickcheck-2.15
+# >=dev-haskell/rere-0.1 <dev-haskell/rere-0.3
+# >=dev-haskell/stm-2.4.5.0 <dev-haskell/stm-2.6
+# dev-haskell/tagged
+# >=dev-haskell/tar-0.5.0.3 <dev-haskell/tar-0.6
+# >=dev-haskell/tasty-1.2.3 <dev-haskell/tasty-1.4
+# >=dev-haskell/tasty-golden-2.3.1.1 <dev-haskell/tasty-golden-2.4
+# dev-haskell/tasty-hunit
+# dev-haskell/tasty-quickcheck
+# dev-haskell/temporary
+# >=dev-haskell/tree-diff-0.1 <dev-haskell/tree-diff-0.2
+# )
+
+src_prepare() {
+ haskell-cabal_src_prepare
+
+ # Cabal bootstraps with 'ghc --make' without package cleanup in environment.
+ # That causes module collisions at build:
+ # - pulseaudio: Distribution/Utils/Structured.hs:98:1: error: Ambiguous module name ‘Data.Time’: it was found in multiple packages: pulseaudio-0.0.2.1 time-1.9.3
+ # - kinds: Distribution/Utils/Structured.hs:106:1: error: Ambiguous module name ‘Data.Kind’: it was found in multiple packages: base-4.14.1.0 kinds-0.0.1.5
+ HCFLAGS="${HCFLAGS} -ignore-package=pulseaudio"
+ HCFLAGS="${HCFLAGS} -ignore-package=kinds"
+}
+
+src_configure() {
+ haskell-cabal_src_configure \
+ --flag=-parsec-struct-diff
+}
+
+CABAL_CORE_LIB_GHC_PV="9.0.2"
diff --git a/dev-haskell/cabal/cabal-3.4.1.0.ebuild b/dev-haskell/cabal/cabal-3.4.1.0.ebuild
deleted file mode 100644
index bfb33339ba06..000000000000
--- a/dev-haskell/cabal/cabal-3.4.1.0.ebuild
+++ /dev/null
@@ -1,51 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-# ebuild generated by hackport 0.7.9999
-#hackport: flags: -bundled-binary-generic
-
-CABAL_PN="Cabal"
-
-CABAL_FEATURES="lib profile haddock hoogle hscolour" # drop tests due to circular deps
-CABAL_FEATURES+=" nocabaldep" # in case installed Cabal is broken
-inherit haskell-cabal
-
-DESCRIPTION="A framework for packaging Haskell software"
-HOMEPAGE="https://www.haskell.org/cabal/"
-SRC_URI="https://hackage.haskell.org/package/${CABAL_PN}/${CABAL_PN}-${PV}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0/${PV}"
-#keep in sync with ghc-9.0.2
-KEYWORDS="amd64 ~arm64 ~ppc64 ~riscv ~x86 ~amd64-linux ~x86-linux"
-
-RESTRICT=test # circular deps: cabal -> quickcheck -> cabal
-
-RDEPEND=">=dev-haskell/mtl-2.1:=[profile?] <dev-haskell/mtl-2.3:=[profile?]
- >=dev-haskell/parsec-3.1.13.0:=[profile?] <dev-haskell/parsec-3.2:=[profile?]
- >=dev-haskell/text-1.2.3.0:=[profile?] <dev-haskell/text-1.3:=[profile?]
- >=dev-lang/ghc-8.4.3:=
-"
-DEPEND="${RDEPEND}"
-
-S="${WORKDIR}/${CABAL_PN}-${PV}"
-
-src_prepare() {
- default
-
- # Cabal bootstraps with 'ghc --make' without package cleanup in environment.
- # That causes module collisions at build:
- # - pulseaudio: Distribution/Utils/Structured.hs:98:1: error: Ambiguous module name ‘Data.Time’: it was found in multiple packages: pulseaudio-0.0.2.1 time-1.9.3
- # - kinds: Distribution/Utils/Structured.hs:106:1: error: Ambiguous module name ‘Data.Kind’: it was found in multiple packages: base-4.14.1.0 kinds-0.0.1.5
- HCFLAGS="${HCFLAGS} -ignore-package=pulseaudio"
- HCFLAGS="${HCFLAGS} -ignore-package=kinds"
-}
-
-src_configure() {
- haskell-cabal_src_configure \
- --flag=-bundled-binary-generic
-}
-
-CABAL_CORE_LIB_GHC_PV="9.0.2"
diff --git a/dev-haskell/cabal/metadata.xml b/dev-haskell/cabal/metadata.xml
index ac62fa133898..ff65eca11461 100644
--- a/dev-haskell/cabal/metadata.xml
+++ b/dev-haskell/cabal/metadata.xml
@@ -6,6 +6,7 @@
<name>Gentoo Haskell</name>
</maintainer>
<upstream>
+ <remote-id type="hackage">Cabal</remote-id>
<remote-id type="github">haskell/cabal</remote-id>
</upstream>
</pkgmetadata>