summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--sys-auth/seatd/Manifest1
-rw-r--r--sys-auth/seatd/seatd-0.6.2.ebuild55
2 files changed, 56 insertions, 0 deletions
diff --git a/sys-auth/seatd/Manifest b/sys-auth/seatd/Manifest
index a45cc62360be..45d117f4e120 100644
--- a/sys-auth/seatd/Manifest
+++ b/sys-auth/seatd/Manifest
@@ -1,2 +1,3 @@
DIST seatd-0.5.0.tar.gz 34762 BLAKE2B 054bd64800b734f6092f856540217e5ea4872c5a363960bac6c5aa7dac5355bdbd982232efd2f8078ad326ec0e6257f3ee7643384c88a3bbe15255d65f02540c SHA512 a6b1f11313411fe99e8bdd64aa493fc19bde7b0b927f21e2c3ec8a7fadc6cf2f04fcefa73fa033d971d1dc482665d3dc927ec168026289fe88b2593a45adbc0f
DIST seatd-0.6.0.tar.gz 37418 BLAKE2B 0598191cd5988ec24506a5b70f2011b1ec1691f5e32108c4c44e79d5527527cae4da8bfbe934ca64efbb1a1dd8471b35589c33399cf85dc89b4cec92d2ef1192 SHA512 9b0b67a028cf9bba63a6c4630c66b21dd2cb87de0d290bfc51245727cda72964fbd0ffee709eded1e81c28f403db6bae8926a257fdd9267e154fbe8697d22a2b
+DIST seatd-0.6.2.tar.gz 37713 BLAKE2B 001c6269bcc83488099f9237a3412b61f89cf653fcb5b0d1ada3f5fbdb17ec604d881ce3d835ff1ea3bc683bb143bab75de88d67b55f508e6a9dd2e958347567 SHA512 47e3aec819f43e72913be1cac2c0db26287f1ef8ecc738845d3591b3e2b4fee3441ac50ea45ac75a5da774e5305a18a02b8375f76f71644c8c07e95bcad52762
diff --git a/sys-auth/seatd/seatd-0.6.2.ebuild b/sys-auth/seatd/seatd-0.6.2.ebuild
new file mode 100644
index 000000000000..8513ea785669
--- /dev/null
+++ b/sys-auth/seatd/seatd-0.6.2.ebuild
@@ -0,0 +1,55 @@
+# Copyright 2020-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit meson systemd
+
+DESCRIPTION="Minimal seat management daemon and universal library"
+HOMEPAGE="https://sr.ht/~kennylevinsen/seatd"
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://git.sr.ht/~kennylevinsen/seatd"
+else
+ KEYWORDS="~amd64 ~arm64 ~ppc64 ~riscv ~x86"
+ SRC_URI="https://git.sr.ht/~kennylevinsen/seatd/archive/${PV}.tar.gz -> ${P}.tar.gz"
+fi
+LICENSE="MIT"
+SLOT="0/1"
+IUSE="builtin elogind +server systemd"
+REQUIRED_USE="?? ( elogind systemd )"
+
+DEPEND="
+ elogind? ( sys-auth/elogind )
+ systemd? ( sys-apps/systemd )
+"
+RDEPEND="${DEPEND}"
+BDEPEND=">=app-text/scdoc-1.9.7"
+
+src_configure() {
+ local emesonargs=(
+ -Dman-pages=enabled
+ -Dwerror=false
+ $(meson_feature builtin libseat-builtin)
+ $(meson_feature server)
+ )
+
+ if use elogind ; then
+ emesonargs+=( -Dlibseat-logind=elogind )
+ elif use systemd; then
+ emesonargs+=( -Dlibseat-logind=systemd )
+ else
+ emesonargs+=( -Dlibseat-logind=disabled )
+ fi
+
+ meson_src_configure
+}
+
+src_install() {
+ meson_src_install
+
+ if use server; then
+ newinitd "${FILESDIR}/seatd.initd" seatd
+ systemd_dounit contrib/systemd/seatd.service
+ fi
+}