summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-python/pyelftools/Manifest1
-rw-r--r--dev-python/pyelftools/pyelftools-0.29.ebuild36
2 files changed, 0 insertions, 37 deletions
diff --git a/dev-python/pyelftools/Manifest b/dev-python/pyelftools/Manifest
index d0dada90443f..659112f94104 100644
--- a/dev-python/pyelftools/Manifest
+++ b/dev-python/pyelftools/Manifest
@@ -1,2 +1 @@
-DIST pyelftools-0.29.gh.tar.gz 14176561 BLAKE2B 441260492f8cd512445249700a79f1d823ef96f6213ab9183e17160b76efe51493c28d2ae8ecea79acf45e78987b4c24940441e9bc0a3deaeda0ee4fb72b58c3 SHA512 0eba3b029a734abe9f8df92cd58bc967f10bf9f61c3a419bdbc5e637200844dddd947bcb485e8ebbe2eeaa7f7e91efc6500316af51aace1db051a658cf61153e
DIST pyelftools-0.30.gh.tar.gz 14115024 BLAKE2B b7974bc1a51ff5ba6ced17aac44e3911ff8d892564a3bef07ae6a5fc261eb7d2eb02170678c4d0bafedaa9e393fa4ca6d2059c420436ea73aa4f6aa7b49a894e SHA512 5bd4c797f90307e351d541b8de8f76124c66e497b68b811f7012e1271c902beb6ab530a424b338777d12277d44f9b5f89f049e05d9fc2ec36a90b6fa16f1c1a4
diff --git a/dev-python/pyelftools/pyelftools-0.29.ebuild b/dev-python/pyelftools/pyelftools-0.29.ebuild
deleted file mode 100644
index dd53c6f4c172..000000000000
--- a/dev-python/pyelftools/pyelftools-0.29.ebuild
+++ /dev/null
@@ -1,36 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{10..12} )
-
-inherit distutils-r1
-
-DESCRIPTION="pure-Python library for analyzing ELF files and DWARF debugging information"
-HOMEPAGE="
- https://pypi.org/project/pyelftools/
- https://github.com/eliben/pyelftools/
-"
-# PyPI tarball lacks some test files
-SRC_URI="
- https://github.com/eliben/pyelftools/archive/v${PV}.tar.gz
- -> ${P}.gh.tar.gz
-"
-
-LICENSE="public-domain"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~loong ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~amd64-linux ~x86-linux"
-IUSE="examples"
-
-python_test() {
- # readelf_tests often fails due to host `readelf` changing output format
- "${EPYTHON}" test/run_all_unittests.py || die
- "${EPYTHON}" test/run_examples_test.py || die
-}
-
-python_install_all() {
- use examples && dodoc -r examples
- distutils-r1_python_install_all
-}