summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gui-libs/wlroots/Manifest1
-rw-r--r--gui-libs/wlroots/wlroots-0.17.3.ebuild102
2 files changed, 103 insertions, 0 deletions
diff --git a/gui-libs/wlroots/Manifest b/gui-libs/wlroots/Manifest
index f8f7464a0a5f..aff6698da55e 100644
--- a/gui-libs/wlroots/Manifest
+++ b/gui-libs/wlroots/Manifest
@@ -1,3 +1,4 @@
DIST wlroots-0.15.1.tar.gz 565816 BLAKE2B 09b704a55d8b4a5ab19bb0fcdd041635fbbbb8eed94ff6d189ef47f9f86e90178efa8441c7db78839b1145ed79ed016d520d6599e256cdcf49130cda38bc307d SHA512 6228160f2f350a406c612f1048d7075cf2f78206cc84bc16f889d5d0acd614f9e98845fffed03d7067cfdbd7558b77fcc5d8cedc3868d866e476523126a63677
DIST wlroots-0.16.2.gl.tar.gz 588432 BLAKE2B cad2a98b1413ed94270b53af62541d67de1c74d3350be32c2e67aaee1d36d4260738b517d6d41f2013f436276097509a5d2662c531be354f7b4edc1c0204eced SHA512 9d5fbee3b87738de75323a056b83446eb93b81ac3e8a4315918d5daad6ed2f50392d9641039f3f830ec1df94155473a2052689d3c029be7572d8ec9ecc62c0e9
DIST wlroots-0.17.2.tar.gz 606822 BLAKE2B bbf6e8d0014f6613b39cbb6a0a8e5be395a858a5db8e432307298f20eb37c6622dbc6e078e21d9b8396dd836da1f9787b433549641cc664962eb96a122846edc SHA512 44a3ec673431c02fc08a5c33daa06148b5e85a3a7ea45b28978cd6be230dd4c5082e8a34985e2976c9e64f98b7567e334c191c3d20141e8e27ddc4a4659843cc
+DIST wlroots-0.17.3.tar.gz 608292 BLAKE2B 7caab3c3a58595d3a745c0b20a5db2193c54931cdd7bc1b9de11c151af82503a03a6a3166a86f42486cc69c6ac18ca2a5596809a5c5e6d7b44c9845f509c1093 SHA512 b88747daba304db6dc302acdebb8764e719d84134118963c019d5f0d0d38552e0ffd2a50bf560b3b84549c5a0f2d11a6187ac8ddcd9faa28c5b42f86c585b555
diff --git a/gui-libs/wlroots/wlroots-0.17.3.ebuild b/gui-libs/wlroots/wlroots-0.17.3.ebuild
new file mode 100644
index 000000000000..c27c7a385512
--- /dev/null
+++ b/gui-libs/wlroots/wlroots-0.17.3.ebuild
@@ -0,0 +1,102 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit meson
+
+DESCRIPTION="Pluggable, composable, unopinionated modules for building a Wayland compositor"
+HOMEPAGE="https://gitlab.freedesktop.org/wlroots/wlroots"
+
+if [[ ${PV} == 9999 ]]; then
+ EGIT_REPO_URI="https://gitlab.freedesktop.org/${PN}/${PN}.git"
+ inherit git-r3
+ SLOT="0/9999"
+else
+ SRC_URI="https://gitlab.freedesktop.org/${PN}/${PN}/-/releases/${PV}/downloads/${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm64 ~loong ~ppc64 ~riscv ~x86"
+ SLOT="0/$(ver_cut 2)"
+fi
+
+LICENSE="MIT"
+IUSE="liftoff +libinput +drm +session tinywl vulkan x11-backend xcb-errors X"
+REQUIRED_USE="
+ drm? ( session )
+ libinput? ( session )
+ xcb-errors? ( || ( x11-backend X ) )
+"
+
+DEPEND="
+ >=dev-libs/wayland-1.22.0
+ media-libs/libglvnd
+ media-libs/mesa[egl(+),gles2]
+ >=x11-libs/libdrm-2.4.114
+ x11-libs/libxkbcommon
+ >=x11-libs/pixman-0.42.0
+ drm? (
+ media-libs/libdisplay-info
+ sys-apps/hwdata
+ liftoff? ( >=dev-libs/libliftoff-0.4 )
+ )
+ libinput? ( >=dev-libs/libinput-1.14.0:= )
+ session? (
+ sys-auth/seatd:=
+ virtual/libudev
+ )
+ vulkan? (
+ dev-util/glslang:=
+ dev-util/vulkan-headers
+ media-libs/vulkan-loader
+ )
+ xcb-errors? ( x11-libs/xcb-util-errors )
+ x11-backend? (
+ x11-libs/libxcb:=
+ x11-libs/xcb-util-renderutil
+ )
+ X? (
+ x11-libs/libxcb:=
+ x11-libs/xcb-util-wm
+ x11-base/xwayland
+ )
+"
+RDEPEND="
+ ${DEPEND}
+"
+BDEPEND="
+ >=dev-libs/wayland-protocols-1.32
+ dev-util/wayland-scanner
+ virtual/pkgconfig
+"
+
+src_configure() {
+ local backends=(
+ $(usev drm)
+ $(usev libinput)
+ $(usev x11-backend 'x11')
+ )
+ local meson_backends=$(IFS=','; echo "${backends[*]}")
+ local emesonargs=(
+ $(meson_feature xcb-errors)
+ $(meson_use tinywl examples)
+ -Drenderers=$(usex vulkan 'gles2,vulkan' gles2)
+ $(meson_feature X xwayland)
+ -Dbackends=${meson_backends}
+ $(meson_feature session)
+ )
+
+ meson_src_configure
+}
+
+src_install() {
+ meson_src_install
+ dodoc docs/*
+
+ if use tinywl; then
+ dobin "${BUILD_DIR}"/tinywl/tinywl
+ fi
+}
+
+pkg_postinst() {
+ elog "You must be in the input group to allow your compositor"
+ elog "to access input devices via libinput."
+}