summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--media-plugins/kodi-peripheral-steamcontroller/kodi-peripheral-steamcontroller-9999.ebuild37
-rw-r--r--media-plugins/kodi-peripheral-steamcontroller/metadata.xml12
2 files changed, 49 insertions, 0 deletions
diff --git a/media-plugins/kodi-peripheral-steamcontroller/kodi-peripheral-steamcontroller-9999.ebuild b/media-plugins/kodi-peripheral-steamcontroller/kodi-peripheral-steamcontroller-9999.ebuild
new file mode 100644
index 000000000000..d0320868c73d
--- /dev/null
+++ b/media-plugins/kodi-peripheral-steamcontroller/kodi-peripheral-steamcontroller-9999.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit cmake-utils kodi-addon
+
+DESCRIPTION="Steam controller driver for Kodi"
+HOMEPAGE="https://github.com/xbmc/peripheral.steamcontroller"
+SRC_URI=""
+
+case ${PV} in
+9999)
+ SRC_URI=""
+ EGIT_REPO_URI="https://github.com/kodi-game/peripheral.steamcontroller.git"
+ inherit git-r3
+ ;;
+*)
+ KEYWORDS="~amd64 ~x86"
+ SRC_URI="https://github.com/kodi-game/peripheral.steamcontroller/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ S="${WORKDIR}/peripheral.steamcontroller-${PV}"
+ ;;
+esac
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE=""
+
+DEPEND="
+ ~media-tv/kodi-9999
+ ~media-libs/kodi-platform-9999
+ =dev-libs/libplatform-2*
+ virtual/libusb:1
+ "
+RDEPEND="
+ ${DEPEND}
+ "
diff --git a/media-plugins/kodi-peripheral-steamcontroller/metadata.xml b/media-plugins/kodi-peripheral-steamcontroller/metadata.xml
new file mode 100644
index 000000000000..43c6920e0654
--- /dev/null
+++ b/media-plugins/kodi-peripheral-steamcontroller/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>candrews@gentoo.org</email>
+ <name>Craig Andrews</name>
+ </maintainer>
+ <longdescription>Steam controller driver for Kodi</longdescription>
+ <upstream>
+ <remote-id type="github">kodi-game/peripheral.steamcontroller</remote-id>
+ </upstream>
+</pkgmetadata>