summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-emulation/lxd/Manifest1
-rw-r--r--app-emulation/lxd/files/lxd-2.0.0_beta4-dont-go-get.patch20
-rw-r--r--app-emulation/lxd/files/lxd-2.0.0_beta4-nc-binary-name.patch11
-rw-r--r--app-emulation/lxd/files/lxd-2.0.0_beta4.confd27
-rw-r--r--app-emulation/lxd/files/lxd-2.0.0_beta4.initd50
-rw-r--r--app-emulation/lxd/lxd-2.0.0_beta4.ebuild161
6 files changed, 270 insertions, 0 deletions
diff --git a/app-emulation/lxd/Manifest b/app-emulation/lxd/Manifest
index ebd047c00473..c39da3c26a8c 100644
--- a/app-emulation/lxd/Manifest
+++ b/app-emulation/lxd/Manifest
@@ -1,3 +1,4 @@
DIST lxd-0.27.tar.bz2 2247266 SHA256 290d05a792f2f146b302d500eadd3168822ed99aecb4ea96762570580f29910a SHA512 37d5fef677a943dc7e84c73836aa1d4e5f0353c165aa33cefcd87dcd1fdae574760e74fb290404182badfee96e04ef929a81d6633d2c0f91c458ccd19996b9c3 WHIRLPOOL d1d0c0fad0e604f41482c133f4425461546599aded2e948d5c58f7698eba963746ac8c3c3085ffbd244b0169cedb26ad8ec5d85babea6aa9a7688ee6ce342589
DIST lxd-2.0.0_beta1.tar.bz2 2253384 SHA256 443d8004aea80a9295eeb28c81b930947163b5af5e7c5ec15e6123938268bd6c SHA512 21cc90e18173f832f7aa2f39762ba1c47ac54dbb947519302075d10f8c55cce766d436cb7f9ec96cb2fe538952b801398ce3b1320d878e8835d58e4fb3b81c86 WHIRLPOOL 85a11976fbf74f8b408c75aa7abf645d3e27eed3f82021fbcb7b2d8db95cc986fdf2cd6a38ef8749857027b380382e66678fb1f1656274159dbc2531c3860761
DIST lxd-2.0.0_beta3.tar.bz2 2283443 SHA256 a3bdf6c081ebed01fcd1ae92a6d3ebf2e7d6ffea606fe3cb83559366e7dc90aa SHA512 3f80c1236ac9a92a350b4221478dd69eb2693672d73859738b691b9462155d0a907de90deab9950980500ab0faa5ec815bc6191cedf2d34d3757757f585570ec WHIRLPOOL 6d425c26ef37bc65871cf08946f0a80e5b9a3e01da5edd07605e94a2b418e6d2163ee90210c4439350000c35a18efa97102dcbab90ccd1577d6164b5b2e271b4
+DIST lxd-2.0.0_beta4.tar.bz2 2291955 SHA256 6487750275e21ab3e862ea56807b9fcf28e9a646040e1f50f3967e9f76cf27e5 SHA512 ae67b9098946f037c1c938cc46f141fb8089ae33b980dd55cebc9cc3f14fbcd645e810e185fdc61dacbd6437569d079e4d9bd9763d12fefb65cfcecf13c10b28 WHIRLPOOL 6c781b47b80d044128647567b6de81352b174e2224e9ff91f2e1eacc5dfbb9141e53aa74e9bce479ebee1bb6c691282849897c34f815415623abcf3d666c7033
diff --git a/app-emulation/lxd/files/lxd-2.0.0_beta4-dont-go-get.patch b/app-emulation/lxd/files/lxd-2.0.0_beta4-dont-go-get.patch
new file mode 100644
index 000000000000..d2e622ec73b7
--- /dev/null
+++ b/app-emulation/lxd/files/lxd-2.0.0_beta4-dont-go-get.patch
@@ -0,0 +1,20 @@
+--- Makefile.orig 2016-02-19 00:16:40.720102639 +0000
++++ Makefile 2016-02-19 00:18:10.886096473 +0000
+@@ -12,17 +12,11 @@
+
+ .PHONY: default
+ default:
+- # Must run twice due to go get race
+- -go get -t -v -d ./...
+- -go get -t -v -d ./...
+ go install -v $(DEBUG) ./...
+ @echo "LXD built successfully"
+
+ .PHONY: client
+ client:
+- # Must run twice due to go get race
+- -go get -t -v -d ./...
+- -go get -t -v -d ./...
+ go install -v $(DEBUG) ./lxc
+ @echo "LXD client built successfully"
+
diff --git a/app-emulation/lxd/files/lxd-2.0.0_beta4-nc-binary-name.patch b/app-emulation/lxd/files/lxd-2.0.0_beta4-nc-binary-name.patch
new file mode 100644
index 000000000000..7373b66969b7
--- /dev/null
+++ b/app-emulation/lxd/files/lxd-2.0.0_beta4-nc-binary-name.patch
@@ -0,0 +1,11 @@
+--- lxd/rsync.go.orig 2015-11-11 20:54:37.402700202 -0600
++++ lxd/rsync.go 2015-11-11 20:55:06.704698199 -0600
+@@ -91,7 +91,7 @@
+ * command (i.e. the command to run on --server). However, we're
+ * hardcoding that at the other end, so we can just ignore it.
+ */
+- rsyncCmd := fmt.Sprintf("sh -c \"nc -U %s\"", f.Name())
++ rsyncCmd := fmt.Sprintf("sh -c \"nc.openbsd -U %s\"", f.Name())
+ cmd := exec.Command(
+ "rsync",
+ "-arvP",
diff --git a/app-emulation/lxd/files/lxd-2.0.0_beta4.confd b/app-emulation/lxd/files/lxd-2.0.0_beta4.confd
new file mode 100644
index 000000000000..3d553276a5e3
--- /dev/null
+++ b/app-emulation/lxd/files/lxd-2.0.0_beta4.confd
@@ -0,0 +1,27 @@
+# Group which owns the shared socket
+LXD_OPTIONS+=" --group lxd"
+
+
+
+# Enable cpu profiling into the specified file
+#LXD_OPTIONS+=" --cpuprofile /tmp/lxc_cpu_profile"
+
+# Enable memory profiling into the specified file
+#LXD_OPTIONS+=" --memprofile /tmp/lxc_mem_profile"
+
+
+
+# Enables debug mode
+#LXD_OPTIONS+=" --debug"
+
+# For debugging, print a complete stack trace every n seconds
+#LXD_OPTIONS+=" --print-goroutines-every 5"
+
+# Enables verbose mode
+#LXD_OPTIONS+=" -v"
+
+# Logfile to log to
+#LXD_OPTIONS+=" --logfile /var/log/lxd/lxd.log"
+
+# Enables syslog logging
+#LXD_OPTIONS+=" --syslog"
diff --git a/app-emulation/lxd/files/lxd-2.0.0_beta4.initd b/app-emulation/lxd/files/lxd-2.0.0_beta4.initd
new file mode 100644
index 000000000000..ec23258c19d1
--- /dev/null
+++ b/app-emulation/lxd/files/lxd-2.0.0_beta4.initd
@@ -0,0 +1,50 @@
+#!/sbin/runscript
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+DAEMON=/usr/sbin/lxd
+PIDFILE=/run/lxd.pid
+
+extra_commands="stopall"
+
+depend() {
+ need net
+ use lxcfs
+
+ # remove with 2.0 release
+ need cgmanager
+}
+
+start() {
+ ebegin "Starting lxd server"
+
+ start-stop-daemon --start \
+ --pidfile ${PIDFILE} \
+ --exec ${DAEMON} \
+ --background \
+ --make-pidfile \
+ -- \
+ ${LXD_OPTIONS}
+
+ eend $?
+}
+
+stop() {
+ if [[ $RC_GOINGDOWN = YES ]] || [[ $RC_REBOOT = YES ]]; then
+ stopall
+ else
+ ebegin "Stopping lxd service (but not containers)"
+ start-stop-daemon --stop --quiet -R TERM/45 -p ${PIDFILE}
+ eend $?
+ fi
+}
+
+stopall() {
+ ebegin "Stopping lxd service and containers"
+ if "${DAEMON}" shutdown; then
+ /etc/init.d/lxd zap
+ rm -f ${PIDFILE}
+ fi
+ eend $?
+}
diff --git a/app-emulation/lxd/lxd-2.0.0_beta4.ebuild b/app-emulation/lxd/lxd-2.0.0_beta4.ebuild
new file mode 100644
index 000000000000..ac54e47235b1
--- /dev/null
+++ b/app-emulation/lxd/lxd-2.0.0_beta4.ebuild
@@ -0,0 +1,161 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+DESCRIPTION="Fast, dense and secure container management"
+HOMEPAGE="https://linuxcontainers.org/lxd/introduction/"
+EGO_PN_PARENT="github.com/lxc"
+EGO_PN="${EGO_PN_PARENT}/lxd"
+SRC_URI="https://dev.gentoo.org/~stasibear/distfiles/${P}.tar.bz2"
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+
+PLOCALES="de fr ja"
+IUSE="+daemon nls test"
+
+# IUSE and PLOCALES must be defined before l10n inherited
+inherit bash-completion-r1 eutils golang-build l10n systemd user vcs-snapshot
+
+# The compiler is forced in golang-base:
+# DEPEND=">=dev-lang/go-1.4.2:="
+# ... so the dep is omitted here (and I disagree with := in this case)
+
+DEPEND="
+ dev-go/go-crypto
+ dev-libs/protobuf
+ dev-vcs/git
+ nls? ( sys-devel/gettext )
+ test? (
+ app-misc/jq
+ dev-db/sqlite
+ net-misc/curl
+ sys-devel/gettext
+ )
+"
+
+RDEPEND="
+ daemon? (
+ app-admin/cgmanager
+ app-arch/xz-utils
+ app-emulation/lxc[cgmanager,seccomp]
+ net-analyzer/openbsd-netcat
+ net-misc/rsync[xattr]
+ sys-apps/iproute2
+ virtual/acl
+ )
+"
+
+# KNOWN ISSUES:
+# - Translations may not work. I've been unsuccessful in forcing
+# localized output. Anyway, upstream (Canonical) doesn't install the
+# message files.
+
+# TODO:
+# - since 0.15 gccgo is a supported compiler ('make gccgo'). It would
+# be preferable for that support to go into the golang-build eclass not
+# this package directly.
+
+src_prepare() {
+ cd "${S}/src/${EGO_PN}" || die "Failed to change to deep src dir"
+
+ epatch "${FILESDIR}/${P}-dont-go-get.patch"
+
+ # Upstream requires the openbsd flavor of netcat (with -U), but
+ # Gentoo installs that with a renamed binary
+ epatch "${FILESDIR}/${P}-nc-binary-name.patch"
+
+ tmpgoroot="${T}/goroot"
+ mkdir -p "$tmpgoroot" || die "Failed to create temporary GOROOT"
+ cp -sR "$(get_golibdir_gopath)"/* "${tmpgoroot}" || die "Failed to copy files to temporary GOROOT"
+
+ # Warn on unhandled locale changes
+ l10n_find_plocales_changes po "" .po
+}
+
+src_compile() {
+ golang-build_src_compile
+
+ cd "${S}/src/${EGO_PN}" || die "Failed to change to deep src dir"
+
+ tmpgoroot="${T}/goroot"
+ if use daemon; then
+ # Build binaries
+ GOPATH="${S}:${tmpgoroot}" emake
+ else
+ # build client tool
+ GOPATH="${S}:${tmpgoroot}" emake client
+ fi
+
+ use nls && emake build-mo
+}
+
+src_test() {
+ if use daemon; then
+ # Go native tests should succeed
+ golang-build_src_test
+ fi
+}
+
+src_install() {
+ # Installs all src,pkg to /usr/lib/go-gentoo
+ golang-build_src_install
+
+ cd "${S}"
+ dobin bin/lxc
+ use daemon && dosbin bin/lxd
+
+ cd "src/${EGO_PN}"
+
+ if use nls; then
+ for lingua in ${PLOCALES}; do
+ if use linguas_${lingua}; then
+ domo po/${lingua}.mo
+ fi
+ done
+ fi
+
+ if use daemon; then
+ newinitd "${FILESDIR}"/${P}.initd lxd
+ newconfd "${FILESDIR}"/${P}.confd lxd
+
+ systemd_dounit "${FILESDIR}"/lxd.service
+ fi
+
+ newbashcomp config/bash/lxd-client lxc
+
+ dodoc AUTHORS CONTRIBUTING.md README.md
+
+ docinto specs
+ dodoc specs/*
+}
+
+pkg_postinst() {
+ einfo
+ einfo "Consult https://wiki.gentoo.org/wiki/LXD for more information,"
+ einfo "including a Quick Start."
+
+ # The messaging below only applies to daemon installs
+ use daemon || return 0
+
+ # The control socket will be owned by (and writeable by) this group.
+ enewgroup lxd
+
+ # Ubuntu also defines an lxd user but it appears unused (the daemon
+ # must run as root)
+
+ einfo
+ einfo "Though not strictly required, some features are enabled at run-time"
+ einfo "when the relevant helper programs are detected:"
+ einfo "- sys-apps/apparmor"
+ einfo "- sys-fs/btrfs-progs"
+ einfo "- sys-fs/lvm2"
+ einfo "- sys-fs/lxcfs"
+ einfo "- sys-fs/zfs"
+ einfo "- sys-process/criu"
+ einfo
+ einfo "Since these features can't be disabled at build-time they are"
+ einfo "not USE-conditional."
+}