summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-python/python-heatclient/Manifest1
-rw-r--r--dev-python/python-heatclient/python-heatclient-1.8.2.ebuild81
2 files changed, 82 insertions, 0 deletions
diff --git a/dev-python/python-heatclient/Manifest b/dev-python/python-heatclient/Manifest
index e6a520a4138c..214c376512a8 100644
--- a/dev-python/python-heatclient/Manifest
+++ b/dev-python/python-heatclient/Manifest
@@ -1 +1,2 @@
DIST python-heatclient-1.8.1.tar.gz 163976 SHA256 95558abcb78d747e5516b51f9aabe3bd54013a3c8b4ec06de5415ff2a042009b SHA512 7d9be61f048c2a23b853773009e060517eadff158cca8efc1fbd3a5f3a16d257950021e8afaafc15a536104248d53dfda49698a9d83a3b35955e9e23376655df WHIRLPOOL 6c65266b8495a1502637d08ee53fe5ae0ad8465440ad62ec27a596ff1b816a241328cb9eb9e349a21ec63ccd0ad3b70f4af0cba73128bc9f522e4dfcb01b7c05
+DIST python-heatclient-1.8.2.tar.gz 165073 SHA256 1543106a99010e2acbed9d4c8d4f0c459c968454f9022e7740e79e24a5d5ac14 SHA512 38c27dff97c8bf9826e57c02fdd5edb4c0410ccc041b7b1f2e95aa16b22d46cfd9a8b728bbd371e1dee0664aa1f8e14b4eafc6bbaab92a038abbb821e3c8dd34 WHIRLPOOL e4a962a58d0479807c686e793076f9b0d8158186285624b40205f7b00f841ca85bcdcc1a5a9388d2c3e9ef12c242eef425be144c1f675ffab721ee2a29fbfbed
diff --git a/dev-python/python-heatclient/python-heatclient-1.8.2.ebuild b/dev-python/python-heatclient/python-heatclient-1.8.2.ebuild
new file mode 100644
index 000000000000..ce88a3dd514f
--- /dev/null
+++ b/dev-python/python-heatclient/python-heatclient-1.8.2.ebuild
@@ -0,0 +1,81 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 python3_4 python3_5 )
+
+inherit distutils-r1
+
+DESCRIPTION="OpenStack Orchestration API Client Library"
+HOMEPAGE="http://www.openstack.org/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc test"
+
+CDEPEND=">=dev-python/pbr-1.8[${PYTHON_USEDEP}]"
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ ${CDEPEND}
+ test? (
+ >=dev-python/fixtures-3.0.0[${PYTHON_USEDEP}]
+ >=dev-python/requests-mock-1.1.0[${PYTHON_USEDEP}]
+ >=dev-python/mock-2.0.0[${PYTHON_USEDEP}]
+ >=dev-python/mox3-0.7.0[${PYTHON_USEDEP}]
+ !~dev-python/mox3-0.19.0[${PYTHON_USEDEP}]
+ >dev-python/oslotest-1.10.0[${PYTHON_USEDEP}]
+ >=dev-python/python-openstackclient-3.3.0[${PYTHON_USEDEP}]
+ >=dev-python/testrepository-0.0.18[${PYTHON_USEDEP}]
+ >=dev-python/testscenarios-0.4[${PYTHON_USEDEP}]
+ >=dev-python/testtools-1.4.0[${PYTHON_USEDEP}]
+ )
+ doc? (
+ >=dev-python/oslo-sphinx-4.7.0[${PYTHON_USEDEP}]
+ >=dev-python/sphinx-1.2.1[${PYTHON_USEDEP}]
+ <dev-python/sphinx-1.4[${PYTHON_USEDEP}]
+ )
+"
+
+RDEPEND="
+ ${CDEPEND}
+ >=dev-python/Babel-2.3.4[${PYTHON_USEDEP}]
+ >=dev-python/cliff-2.3.0[${PYTHON_USEDEP}]
+ >=dev-python/iso8601-0.1.11[${PYTHON_USEDEP}]
+ >=dev-python/osc-lib-1.2.0[${PYTHON_USEDEP}]
+ >=dev-python/prettytable-0.7.1[${PYTHON_USEDEP}]
+ <dev-python/prettytable-0.8[${PYTHON_USEDEP}]
+ >=dev-python/oslo-i18n-2.1.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-serialization-1.10.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-utils-3.18.0[${PYTHON_USEDEP}]
+ >=dev-python/keystoneauth-2.18.0[${PYTHON_USEDEP}]
+ >=dev-python/python-swiftclient-3.2.0[${PYTHON_USEDEP}]
+ >=dev-python/pyyaml-3.10.0[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.10.0[${PYTHON_USEDEP}]
+ !~dev-python/requests-2.12.2[${PYTHON_USEDEP}]
+ >=dev-python/six-1.9.0[${PYTHON_USEDEP}]
+"
+
+python_prepare_all() {
+ sed -i '/^hacking/d' test-requirements.txt || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_compile_all() {
+ use doc && esetup.py build_sphinx
+}
+
+python_test() {
+ rm -rf .testrepository || die "couldn't remove '.testrepository' under ${EPYTHON}"
+
+ testr init
+ testr run || die "testsuite failed under ${EPYTHON}"
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( doc/build/html/. )
+
+ distutils-r1_python_install_all
+}