summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-python/pikepdf/Manifest1
-rw-r--r--dev-python/pikepdf/pikepdf-2.15.1.ebuild52
2 files changed, 0 insertions, 53 deletions
diff --git a/dev-python/pikepdf/Manifest b/dev-python/pikepdf/Manifest
index 1d1471e094d1..ca1cf6c983cb 100644
--- a/dev-python/pikepdf/Manifest
+++ b/dev-python/pikepdf/Manifest
@@ -1,2 +1 @@
-DIST pikepdf-2.15.1.tar.gz 2311058 BLAKE2B 47c7600ed8c27970b2a45dd5cd557ec6f18782f826a6f31247885d34564935bae2d92f6702fdd635d38730bf6a01e9c4b41251a8a94b73c1828677590bdf84ca SHA512 d71931539f87c64319e45710f31d01ec1cddc5c6bbf15948161336344857a9497ce61140ce4631af3e7708fa13e6e909eaf4bfb146c68f7a8b2ce1f03e206cd7
DIST pikepdf-2.16.1.tar.gz 2312177 BLAKE2B a7695ecc71621c1e64ab919e76dabd3a94ff16d401861fe50f29f00832dda8be01f3e67c811756ef89573345b49ec6c880635309f859624b9df42cf6eff7b43b SHA512 d2c73a0a69c6cf0ed22dc2dc949187464abd4194a5d917e5681de033d6a8ce4c089efd49eb110c9fa11f9dead292aa6ab7ed71a01f7cbaadc51d1f37a773c936
diff --git a/dev-python/pikepdf/pikepdf-2.15.1.ebuild b/dev-python/pikepdf/pikepdf-2.15.1.ebuild
deleted file mode 100644
index b35dcf5d5062..000000000000
--- a/dev-python/pikepdf/pikepdf-2.15.1.ebuild
+++ /dev/null
@@ -1,52 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{8..10} )
-inherit distutils-r1
-
-MY_P=${P/_p/.post}
-DESCRIPTION="Python library to work with pdf files based on qpdf"
-HOMEPAGE="https://pypi.org/project/pikepdf/ https://github.com/pikepdf/pikepdf"
-SRC_URI="
- https://github.com/${PN}/${PN}/archive/v${PV/_p/.post}.tar.gz
- -> ${MY_P}.tar.gz"
-S=${WORKDIR}/${MY_P}
-
-LICENSE="MPL-2.0"
-SLOT="0"
-KEYWORDS="amd64 ~x86"
-
-DEPEND="app-text/qpdf:0="
-RDEPEND="${DEPEND}
- dev-python/pillow[${PYTHON_USEDEP}]
- dev-python/lxml[${PYTHON_USEDEP}]
- dev-python/pybind11[${PYTHON_USEDEP}]"
-BDEPEND="
- >=dev-python/pybind11-2.6.0[${PYTHON_USEDEP}]
- >=dev-python/setuptools_scm-4.1[${PYTHON_USEDEP}]
- dev-python/toml[${PYTHON_USEDEP}]
- dev-python/setuptools_scm_git_archive[${PYTHON_USEDEP}]
- test? (
- >=dev-python/attrs-20.2.0[${PYTHON_USEDEP}]
- >=dev-python/hypothesis-5[${PYTHON_USEDEP}]
- >=dev-python/pillow-5.0.0[${PYTHON_USEDEP},jpeg,lcms,tiff]
- >=dev-python/psutil-5[${PYTHON_USEDEP}]
- >=dev-python/pytest-6[${PYTHON_USEDEP}]
- >=dev-python/pytest-timeout-1.4.2[${PYTHON_USEDEP}]
- >=dev-python/python-dateutil-2.8.0[${PYTHON_USEDEP}]
- >=dev-python/python-xmp-toolkit-2.0.1[${PYTHON_USEDEP}]
- )"
-
-#distutils_enable_sphinx docs \
-# dev-python/ipython \
-# dev-python/matplotlib \
-# dev-python/sphinx_rtd_theme
-distutils_enable_tests pytest
-
-src_prepare() {
- sed -i -e '/wheel/d' setup.py || die
- sed -i -e '/-n auto/d' setup.cfg || die
- distutils-r1_src_prepare
-}