summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--games-arcade/jvgs/files/jvgs-0.5-flags.patch14
-rw-r--r--games-arcade/jvgs/jvgs-0.5.ebuild53
2 files changed, 0 insertions, 67 deletions
diff --git a/games-arcade/jvgs/files/jvgs-0.5-flags.patch b/games-arcade/jvgs/files/jvgs-0.5-flags.patch
deleted file mode 100644
index 04f88b88bc6d..000000000000
--- a/games-arcade/jvgs/files/jvgs-0.5-flags.patch
+++ /dev/null
@@ -1,14 +0,0 @@
-From: Julian Ospald <hasufell@gentoo.org>
-Date: Sun Aug 5 19:57:32 UTC 2012
-Subject: build system
-
-respect cxxflags
-
---- src/CMakeLists.txt
-+++ src/CMakeLists.txt
-@@ -1,4 +1,4 @@
--SET( CMAKE_CXX_FLAGS "-DTIXML_USE_STL -ggdb" )
-+SET( CMAKE_CXX_FLAGS "$ENV{CXXFLAGS} -DTIXML_USE_STL" )
-
- INCLUDE_DIRECTORIES(
- ${SDL_INCLUDE_DIR}
diff --git a/games-arcade/jvgs/jvgs-0.5.ebuild b/games-arcade/jvgs/jvgs-0.5.ebuild
deleted file mode 100644
index 7fc533e52a0f..000000000000
--- a/games-arcade/jvgs/jvgs-0.5.ebuild
+++ /dev/null
@@ -1,53 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-CMAKE_IN_SOURCE_BUILD=1
-inherit cmake-utils eutils games
-
-DESCRIPTION="An open-source platform game with a sketched and minimalistic look"
-HOMEPAGE="http://jvgs.sourceforge.net/"
-SRC_URI="mirror://sourceforge/jvgs/${P}-src.tar.gz"
-
-LICENSE="WTFPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE=""
-
-RDEPEND="virtual/opengl
- dev-lang/lua:0
- sys-libs/zlib
- media-libs/libsdl[video]
- media-libs/sdl-mixer[vorbis]
- media-libs/freetype:2"
-DEPEND="${RDEPEND}
- dev-lang/swig"
-
-S=${WORKDIR}/${P}-src
-PATCHES=( "${FILESDIR}"/${P}-flags.patch )
-
-src_configure() {
- cmake-utils_src_configure
-}
-
-src_compile() {
- cmake-utils_src_compile
-}
-
-src_install() {
- exeinto "$(games_get_libdir)"
- doexe src/${PN}
-
- insinto "${GAMES_DATADIR}"/${PN}
- doins -r main.lua resources
-
- games_make_wrapper ${PN} "/$(games_get_libdir)/${PN}" \
- "${GAMES_DATADIR}/${PN}"
-
- newicon resources/drawing.svg ${PN}.svg
- make_desktop_entry ${PN} ${PN}
-
- dodoc AUTHORS README.markdown
-
- prepgamesdirs
-}