summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-ruby/bson/Manifest1
-rw-r--r--dev-ruby/bson/bson-5.0.0.ebuild29
2 files changed, 30 insertions, 0 deletions
diff --git a/dev-ruby/bson/Manifest b/dev-ruby/bson/Manifest
index 671a76e802c0..336fe437c41a 100644
--- a/dev-ruby/bson/Manifest
+++ b/dev-ruby/bson/Manifest
@@ -1 +1,2 @@
DIST bson-4.15.0.gem 163328 BLAKE2B 21c28ee610a2e067c528e163ac4caec0e76d0ec1a73c8c89a2c455887da54aa0dfaa7ed840736013d87766c5cd4f23dc82b4c6474b0463a32b30575b28c5b898 SHA512 954dd419ab94dfde87d8902745885184505d74333fc71608f64544ca52f728782ea6fc3233718749c110c31ee14802ff240caa8ac4c170369d4adcf45557e79d
+DIST bson-5.0.0.gem 172544 BLAKE2B 574c1e42e3b625d0b24dc21eb731bd5b2f86ccc76cceb252635f6be3e504553ab7d267f0b128ae4cfe6da0135c4e0e588a78ae1955dcc5847a32ef64d4d81157 SHA512 31e3606328749937e523a0ec4f9a14da2fe8e03070b3602fd96a3b6742f060988d227029f85768c1ad22348b7af20efbe360b93956d7dc9efba429f9f8d36a47
diff --git a/dev-ruby/bson/bson-5.0.0.ebuild b/dev-ruby/bson/bson-5.0.0.ebuild
new file mode 100644
index 000000000000..bd1abf9c3ce5
--- /dev/null
+++ b/dev-ruby/bson/bson-5.0.0.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+USE_RUBY="ruby31 ruby32 ruby33"
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.md"
+RUBY_FAKEGEM_EXTENSIONS=(ext/bson/extconf.rb)
+
+inherit ruby-fakegem
+
+DESCRIPTION="A Ruby BSON implementation for MongoDB. (Includes binary C-based extension.)"
+HOMEPAGE="https://www.mongodb.com/"
+# We prefer rubygems if we can anyway, but note that rubygems has test sources we need,
+# but github *doesn't* (other way around to usual!)
+RUBY_S="bson-ruby-${PV}"
+
+LICENSE="APSL-2"
+SLOT="$(ver_cut 1)"
+KEYWORDS="~amd64"
+IUSE="test doc"
+
+ruby_add_rdepend "dev-ruby/base64 dev-ruby/bigdecimal"
+
+all_ruby_prepare() {
+ # Remove bundler support
+ sed -i -e '/bundler/I s:^:#:' Rakefile || die
+}