summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net-ftp/atftp/atftp-0.7.2-r1.ebuild67
1 files changed, 0 insertions, 67 deletions
diff --git a/net-ftp/atftp/atftp-0.7.2-r1.ebuild b/net-ftp/atftp/atftp-0.7.2-r1.ebuild
deleted file mode 100644
index ed32bfa406cf..000000000000
--- a/net-ftp/atftp/atftp-0.7.2-r1.ebuild
+++ /dev/null
@@ -1,67 +0,0 @@
-# Copyright 2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-inherit autotools flag-o-matic systemd
-
-DESCRIPTION="Advanced TFTP implementation client/server"
-HOMEPAGE="https://sourceforge.net/projects/atftp/"
-SRC_URI="mirror://sourceforge/atftp/${P}.tar.gz"
-
-LICENSE="GPL-2+"
-SLOT="0"
-KEYWORDS="amd64 arm ppc ppc64 ~s390 ~sparc x86"
-IUSE="selinux tcpd readline pcre"
-
-DEPEND="tcpd? ( sys-apps/tcp-wrappers )
- readline? ( sys-libs/readline:0= )
- pcre? ( dev-libs/libpcre )"
-RDEPEND="${DEPEND}
- !net-ftp/tftp-hpa
- !net-ftp/uftpd
- selinux? ( sec-policy/selinux-tftp )"
-BDEPEND=""
-
-PATCHES=(
- "${FILESDIR}/${P}-CFLAGS.patch"
-)
-
-src_prepare() {
- append-cppflags -D_REENTRANT -DRATE_CONTROL
- # fix #561720 by restoring pre-GCC5 inline semantics
- append-cflags -std=gnu89
-
- default
- eautoreconf
-}
-
-src_configure() {
- econf \
- $(use_enable tcpd libwrap) \
- $(use_enable readline libreadline) \
- $(use_enable pcre libpcre) \
- --enable-mtftp
-}
-
-src_test() {
- cd "${S}"/test || die
- # Try to run the tests
- ./test.sh || die
-}
-
-src_install() {
- default
-
- newinitd "${FILESDIR}"/atftp.init atftp
- newconfd "${FILESDIR}"/atftp.confd atftp
-
- systemd_dounit "${FILESDIR}"/atftp.service
- systemd_install_serviced "${FILESDIR}"/atftp.service.conf
-
- dodoc README* BUGS FAQ Changelog INSTALL TODO
- dodoc "${S}"/docs/*
-
- docinto test
- cd "${S}"/test || die
- dodoc load.sh mtftp.conf pcre_pattern.txt test.sh test_suite.txt
-}