summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-python/nose2/nose2-0.10.0.ebuild26
1 files changed, 6 insertions, 20 deletions
diff --git a/dev-python/nose2/nose2-0.10.0.ebuild b/dev-python/nose2/nose2-0.10.0.ebuild
index 78d73e088364..868ec6bfc4c7 100644
--- a/dev-python/nose2/nose2-0.10.0.ebuild
+++ b/dev-python/nose2/nose2-0.10.0.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-PYTHON_COMPAT=( python3_{7,8,9} )
+PYTHON_COMPAT=( python3_{8..10} )
inherit distutils-r1
DESCRIPTION="Next generation unittest with plugins"
@@ -13,29 +13,15 @@ SRC_URI="https://github.com/nose-devs/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
LICENSE="BSD"
SLOT="0"
KEYWORDS="amd64 x86"
-IUSE="doc"
-# Failures need investigating
-RESTRICT="test"
-BDEPEND="
- doc? ( >=dev-python/sphinx-1.0.5 )
-"
-DEPEND="
+RDEPEND="
>=dev-python/coverage-4.4.1[${PYTHON_USEDEP}]
- >=dev-python/six-1.1[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
"
-RDEPEND="${DEPEND}"
-python_compile_all() {
- use doc && emake -C docs html
-}
+distutils_enable_sphinx docs \
+ dev-python/sphinx_rtd_theme
python_test() {
- "${PYTHON}" -m nose2.__main__ || die "tests failed under ${EPYTHON}"
-}
-
-python_install_all() {
- use doc && local HTML_DOCS=( docs/_build/html/. )
-
- distutils-r1_python_install_all
+ "${EPYTHON}" -m nose2.__main__ -vv || die "tests failed under ${EPYTHON}"
}