summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-ml/uuseg/Manifest1
-rw-r--r--dev-ml/uuseg/metadata.xml23
-rw-r--r--dev-ml/uuseg/uuseg-15.0.0.ebuild38
3 files changed, 62 insertions, 0 deletions
diff --git a/dev-ml/uuseg/Manifest b/dev-ml/uuseg/Manifest
new file mode 100644
index 000000000000..93afecf9c511
--- /dev/null
+++ b/dev-ml/uuseg/Manifest
@@ -0,0 +1 @@
+DIST uuseg-15.0.0.tar.gz 25540 BLAKE2B 4ee1512bde79aab4777395d3ccfb8fe76c97ba7e93b722acd7c36acac432a44a9eade512ea45a0204a1d947a60e3d61773de05890d64d7afac4b1965d1493bb3 SHA512 c117868d52ca8f5de3104b0ea25ea011c19cefd53018c4d9bdf900185d04f74c097b7f129b75366a8da905a79dac3cbf8e6c66ff6c20fee1c2e42b9cdd6a9fa6
diff --git a/dev-ml/uuseg/metadata.xml b/dev-ml/uuseg/metadata.xml
new file mode 100644
index 000000000000..83ae1c163f95
--- /dev/null
+++ b/dev-ml/uuseg/metadata.xml
@@ -0,0 +1,23 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+
+<pkgmetadata>
+ <maintainer type="project">
+ <email>ml@gentoo.org</email>
+ <name>ML</name>
+ </maintainer>
+ <longdescription>
+ Uuseg is an OCaml library for segmenting Unicode text. It implements the
+ locale independent Unicode text segmentation algorithms to detect grapheme
+ cluster, word and sentence boundaries and the Unicode line breaking
+ algorithm to detect line break opportunities. The library is independent
+ from any IO mechanism or Unicode text data structure and it can process
+ text without a complete in-memory representation. Uuseg depends on Uucp and
+ optionally on Uutf for support on OCaml UTF-X encoded strings. It is
+ distributed under the ISC license.
+ </longdescription>
+ <upstream>
+ <bugs-to>https://github.com/dbuenzli/uuseg/issues/</bugs-to>
+ <remote-id type="github">dbuenzli/uuseg</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-ml/uuseg/uuseg-15.0.0.ebuild b/dev-ml/uuseg/uuseg-15.0.0.ebuild
new file mode 100644
index 000000000000..d3dd9d062ae2
--- /dev/null
+++ b/dev-ml/uuseg/uuseg-15.0.0.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit opam
+
+DESCRIPTION="Unicode text segmentation for OCaml"
+HOMEPAGE="https://erratique.ch/software/uuseg/
+ https://github.com/dbuenzli/uuseg/"
+SRC_URI="https://github.com/dbuenzli/uuseg/archive/v${PV}.tar.gz
+ -> ${P}.tar.gz"
+
+LICENSE="ISC"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE="+ocamlopt test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ dev-ml/cmdliner:=
+ dev-ml/uucp:=
+ dev-ml/uutf:=
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ dev-ml/ocamlbuild
+ dev-ml/findlib
+ dev-ml/topkg
+"
+
+src_compile() {
+ ocaml pkg/pkg.ml build --tests $(usex test true false) || die
+}
+
+src_test() {
+ ocaml pkg/pkg.ml test || die
+}