summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-python/aiohttp-socks/Manifest1
-rw-r--r--dev-python/aiohttp-socks/aiohttp-socks-0.7.1-r1.ebuild38
2 files changed, 39 insertions, 0 deletions
diff --git a/dev-python/aiohttp-socks/Manifest b/dev-python/aiohttp-socks/Manifest
index 0a77d258107e..8e2e9b6e5d62 100644
--- a/dev-python/aiohttp-socks/Manifest
+++ b/dev-python/aiohttp-socks/Manifest
@@ -1 +1,2 @@
+DIST aiohttp-socks-0.7.1.gh.tar.gz 19813 BLAKE2B e49ff94a63e3b22f082c892da6b65f71afd768ef98064f062facd382e0146e2fca563f2b7438f37e60a01d640199092c201e7ab2f77152829d8d8a64246ea152 SHA512 0f7a295e3d34d6cac78dcac5d64f76439730bf6bc6d287df9f2ed9b7ad3f1c04d61ebfd1cee75b80788f485b338094a4b02ecef2b3a2be172ffb8e1e65332b59
DIST aiohttp-socks-0.7.1.tar.gz 19813 BLAKE2B e49ff94a63e3b22f082c892da6b65f71afd768ef98064f062facd382e0146e2fca563f2b7438f37e60a01d640199092c201e7ab2f77152829d8d8a64246ea152 SHA512 0f7a295e3d34d6cac78dcac5d64f76439730bf6bc6d287df9f2ed9b7ad3f1c04d61ebfd1cee75b80788f485b338094a4b02ecef2b3a2be172ffb8e1e65332b59
diff --git a/dev-python/aiohttp-socks/aiohttp-socks-0.7.1-r1.ebuild b/dev-python/aiohttp-socks/aiohttp-socks-0.7.1-r1.ebuild
new file mode 100644
index 000000000000..851d6be8ce30
--- /dev/null
+++ b/dev-python/aiohttp-socks/aiohttp-socks-0.7.1-r1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="SOCKS proxy connector for aiohttp"
+HOMEPAGE="
+ https://pypi.org/project/aiohttp-socks/
+ https://github.com/romis2012/aiohttp-socks/
+"
+SRC_URI="
+ https://github.com/romis2012/aiohttp-socks/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+
+RDEPEND="
+ >=dev-python/aiohttp-2.3.2[${PYTHON_USEDEP}]
+ >=dev-python/attrs-19.2.0[${PYTHON_USEDEP}]
+ >=dev-python/python-socks-2.0.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/flask[${PYTHON_USEDEP}]
+ dev-python/pytest-asyncio[${PYTHON_USEDEP}]
+ dev-python/yarl[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest