summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-python/pyscard/Manifest1
-rw-r--r--dev-python/pyscard/pyscard-2.0.9.ebuild46
2 files changed, 47 insertions, 0 deletions
diff --git a/dev-python/pyscard/Manifest b/dev-python/pyscard/Manifest
index d77841f7ba4a..a12c278d2228 100644
--- a/dev-python/pyscard/Manifest
+++ b/dev-python/pyscard/Manifest
@@ -1 +1,2 @@
DIST pyscard-2.0.8.tar.gz 153266 BLAKE2B 524b060ffa869ac4d739cd26d795c559b7c2ab26aa7f687e7b9392508c0e768f9b8442a0d4ebfd0f2903eca922a7cf1cedbe54f78c77f39a4635739a914713d7 SHA512 245602aaab024a1d9f3e2ae46482d6e18253f7e9a3c419f40e746ad2578bbf58c1f56f9a7ec139c9ca5048e2d1a7505002d98b6d54d8906af4f4cfab225d5a09
+DIST pyscard-2.0.9.tar.gz 153513 BLAKE2B 00a7676cb0d987b7a6cd0c2cdf061e4e4405c78a0289d0c46abe95461b19d61a964792f69fe2a2f268653d332e8c21f17d03a8f3b05456df8475b0c51370830c SHA512 0503c29dfd288237eb17fae2a6387cdfce5e34a3aa6cdbdf58aef04ad91ab232d14d78b999fd1d4b7d7c8ad6282fa0d7983a65030f896f1e8098597f182b10cc
diff --git a/dev-python/pyscard/pyscard-2.0.9.ebuild b/dev-python/pyscard/pyscard-2.0.9.ebuild
new file mode 100644
index 000000000000..b141ab35e303
--- /dev/null
+++ b/dev-python/pyscard/pyscard-2.0.9.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_EXT=1
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 optfeature
+
+DESCRIPTION="Smart card support in python"
+HOMEPAGE="
+ https://pyscard.sourceforge.io/
+ https://github.com/LudovicRousseau/pyscard/
+ https://pypi.org/project/pyscard/
+"
+SRC_URI="
+ https://downloads.sourceforge.net/project/pyscard/pyscard/pyscard%20${PV}/${P}.tar.gz
+"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~x86"
+
+DEPEND="
+ sys-apps/pcsc-lite
+"
+RDEPEND="
+ ${DEPEND}
+"
+BDEPEND="
+ dev-lang/swig
+"
+
+distutils_enable_tests unittest
+
+pkg_postinst() {
+ optfeature "Gui support" dev-python/wxpython
+ optfeature "Support of remote readers with Pyro" dev-python/Pyro4
+}
+
+python_test() {
+ cd test || die
+ eunittest
+}