summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-python/GitPython/GitPython-3.1.15.ebuild58
-rw-r--r--dev-python/GitPython/Manifest2
2 files changed, 60 insertions, 0 deletions
diff --git a/dev-python/GitPython/GitPython-3.1.15.ebuild b/dev-python/GitPython/GitPython-3.1.15.ebuild
new file mode 100644
index 000000000000..254dbd3a49d5
--- /dev/null
+++ b/dev-python/GitPython/GitPython-3.1.15.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..9} )
+PYTHON_REQ_USE="threads(+)"
+
+inherit distutils-r1
+
+TEST_P=GitPython-${PV}
+GITDB_P=gitdb-4.0.5-r1
+SMMAP_P=smmap-3.0.4
+
+DESCRIPTION="Library used to interact with Git repositories"
+HOMEPAGE="https://github.com/gitpython-developers/GitPython https://pypi.org/project/GitPython/"
+SRC_URI="mirror://pypi/${PN::1}/${PN}/${P}.tar.gz
+ test? (
+ https://dev.gentoo.org/~mgorny/dist/${TEST_P}.gitbundle
+ https://dev.gentoo.org/~mgorny/dist/${GITDB_P}.gitbundle
+ https://dev.gentoo.org/~mgorny/dist/${SMMAP_P}.gitbundle
+ )"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="
+ dev-vcs/git
+ >=dev-python/gitdb-4.0.1[${PYTHON_USEDEP}]"
+BDEPEND="
+ test? (
+ >=dev-python/ddt-1.1.1[${PYTHON_USEDEP}]
+ )"
+
+distutils_enable_tests unittest
+
+src_test() {
+ git config --global user.email "travis@ci.com" || die
+ git config --global user.name "Travis Runner" || die
+
+ git clone "${DISTDIR}/${TEST_P}.gitbundle" "${T}"/test || die
+ git clone "${DISTDIR}/${GITDB_P}.gitbundle" \
+ "${T}"/test/git/ext/gitdb || die
+ git clone "${DISTDIR}/${SMMAP_P}.gitbundle" \
+ "${T}"/test/git/ext/gitdb/gitdb/ext/smmap || die
+
+ cd "${T}"/test || die
+ TRAVIS=1 ./init-tests-after-clone.sh || die
+ cat test/fixtures/.gitconfig >> ~/.gitconfig || die
+ rm -r test/performance || die
+ # tests requiring network access
+ sed -i -e 's:test_fetch_error:_&:' test/test_remote.py || die
+ sed -i -e 's:test_leaking_password_in_clone_logs:_&:' test/test_repo.py || die
+ rm test/test_installation.py || die
+
+ distutils-r1_src_test
+}
diff --git a/dev-python/GitPython/Manifest b/dev-python/GitPython/Manifest
index 981dccdfc978..8dd2e5966cb2 100644
--- a/dev-python/GitPython/Manifest
+++ b/dev-python/GitPython/Manifest
@@ -1,4 +1,6 @@
DIST GitPython-3.1.14.gitbundle 4446003 BLAKE2B db7844045aed7c40a3f341706e017e877bf3dedde61665754c1d4b14b98d0ddc863666ff1dceb313174a908f8fbacbda0586e53e874a1397e6eeb562cf1ddf1f SHA512 ecd570bdb85dfa64f42ce447bf381868d584eb56897954d893ba1f1ee193fa4e45f3847fe842a67276da0cf155a2501ed4c25d34d300a9776b0f068b659ba014
DIST GitPython-3.1.14.tar.gz 171534 BLAKE2B bcb2b7a497f6eabebe3187ad5104bede01c1a53aa52d15bdc7112198224c566cefc1ecae448dc47f6610e05cf871620a862ca6a3cca17bd8812720e64a9a1d86 SHA512 ee9015d82a53aba18dde8cede276d1d4410c7d9791c5b224c772114801c1e6dc4210c02399dc1248593a4e52d5f5e549cdbf927d6a7c7f9a5a9b0801f5d79675
+DIST GitPython-3.1.15.gitbundle 4811422 BLAKE2B 16399b302f7f3f36b315bcaa1535992a43b02fd888586d135824f8f4dc5ba611875d68e6d3102d71edc93848a91d3b244176d6b735ef30d65fdf64c28d325ef9 SHA512 13064036f20aaa58cf7784a3a61ed9c9e08414e9126332fc629e976889c87a2a70b1c9270774df676dcc08ded0ee3629112c60b88025536a9d13a04491b7b1e2
+DIST GitPython-3.1.15.tar.gz 175132 BLAKE2B 5a0cc8176257a5fec9afbf81351da191fc70ad5678d3ee89d36807cdf01a7f69216916723ac551bcc29fbc07a88a9a0357d12d41b4f43888917bd45dd766328e SHA512 bee1e12625995a0264694796ec6f346a5258ec13c24517939e65eaf9b679d82afb7848c02e6222389609bdf3a0dccbce4af1bd59a5d12f2851da47878a21b210
DIST gitdb-4.0.5-r1.gitbundle 1499071 BLAKE2B e429014def18d645b7117b27f592ead9c518076eeee2f6cc42c4a231f9a4f61c8275ccb1def5d042d44f34863528570163e9e154bb1536a0917b10f135e2462c SHA512 6fcf345af9f72afa39f4ba931bf474b2596678f1b790e3d4e1e3f7420baafbad04689bcdee9e99407f7c2b1c6f0d36fcf524b408ceb37b95dc4980e9423b1ad7
DIST smmap-3.0.4.gitbundle 276552 BLAKE2B 2d17b927b2c644d2f1984168ee99fe5a9a58392401ac0b2894a1d5e5f9c292f32311a7a5d7669bd93c642ff791f4801d61ef3236c1dafa1434e99a17fd8751f6 SHA512 6deb282c6ece3b556c59c458b5242ff362b903441db63c005a0ab1ac055b3f974f9b34f30e0a4a41ef9246696e08b191254f72db61a8f24d4eb2f0e48a08937b