summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net-misc/ucarp/files/ucarp-1.5.2-fno-common.patch8
-rw-r--r--net-misc/ucarp/ucarp-1.5.2-r6.ebuild (renamed from net-misc/ucarp/ucarp-1.5.2-r5.ebuild)21
2 files changed, 22 insertions, 7 deletions
diff --git a/net-misc/ucarp/files/ucarp-1.5.2-fno-common.patch b/net-misc/ucarp/files/ucarp-1.5.2-fno-common.patch
new file mode 100644
index 000000000000..6e746b26da66
--- /dev/null
+++ b/net-misc/ucarp/files/ucarp-1.5.2-fno-common.patch
@@ -0,0 +1,8 @@
+--- a/src/ip_carp.h
++++ b/src/ip_carp.h
+@@ -70,7 +70,7 @@ struct carp_header {
+ u_int16_t carp_cksum;
+ u_int32_t carp_counter[2];
+ unsigned char carp_md[20]; /* SHA1 HMAC */
+-} __packed;
++};
diff --git a/net-misc/ucarp/ucarp-1.5.2-r5.ebuild b/net-misc/ucarp/ucarp-1.5.2-r6.ebuild
index 00283bf58e82..a843fc050bfa 100644
--- a/net-misc/ucarp/ucarp-1.5.2-r5.ebuild
+++ b/net-misc/ucarp/ucarp-1.5.2-r6.ebuild
@@ -1,23 +1,28 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI="5"
+EAPI=7
DESCRIPTION="Portable userland implementation of Common Address Redundancy Protocol (CARP)"
-HOMEPAGE="http://www.ucarp.org"
+HOMEPAGE="https://ucarp.wordpress.com"
SRC_URI="ftp://ftp.ucarp.org/pub/ucarp/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~ppc ~x86"
-IUSE="nls"
+IUSE="debug nls"
RDEPEND="net-libs/libpcap"
-DEPEND="${RDEPEND}
- nls? ( sys-devel/gettext )"
+DEPEND="${RDEPEND}"
+BDEPEND="nls? ( sys-devel/gettext )"
+
+PATCHES=( "${FILESDIR}"/${P}-fno-common.patch )
src_configure() {
- econf $(use_enable nls)
+ econf \
+ --disable-static \
+ $(use_with debug) \
+ $(use_enable nls)
}
src_install() {
@@ -33,6 +38,8 @@ src_install() {
newinitd "${FILESDIR}"/ucarp.initd-r2 ucarp
newconfd "${FILESDIR}"/ucarp.confd ucarp
+
+ find "${ED}" -name '*.la' -delete || die
}
pkg_postinst() {