summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-python/pytest-jupyter/Manifest1
-rw-r--r--dev-python/pytest-jupyter/pytest-jupyter-0.7.0.ebuild34
2 files changed, 35 insertions, 0 deletions
diff --git a/dev-python/pytest-jupyter/Manifest b/dev-python/pytest-jupyter/Manifest
index 6baef7011d27..b02cd95089ac 100644
--- a/dev-python/pytest-jupyter/Manifest
+++ b/dev-python/pytest-jupyter/Manifest
@@ -1 +1,2 @@
DIST pytest_jupyter-0.6.2.tar.gz 15174 BLAKE2B b6c536383ab1b8e375e4250b4922ac6372f850ee4993643122896092109d3f711f91ccc7b159b7330de18f7876df818dc01d31c05e3c18d97488255e063db4d4 SHA512 396f7a7c978097e6dee37ead92bb3c8cef2a8100a7cc85b0b1eab19e20bdaed3332391c17568a6a279ab6ddeea1fbb2fa8dafe24ba4500982ba52cfcda2b1052
+DIST pytest_jupyter-0.7.0.tar.gz 15507 BLAKE2B b4b580668083e46830d06908f484f221e511a9dc5b32285de25e8e83268a1cb4a110ab5bc92c4652033bd658332c6aef8560313e041d39ceeec6d7339c67b24d SHA512 5bd44d1cc927281823ab92f5e1dbb4fa66e917fb9ba098c63001bb9edf60d4eb7842d4178c1dce1772e156d871def2319d511187185fbfd81ee9128c7c23ea2a
diff --git a/dev-python/pytest-jupyter/pytest-jupyter-0.7.0.ebuild b/dev-python/pytest-jupyter/pytest-jupyter-0.7.0.ebuild
new file mode 100644
index 000000000000..6ba7fd839d96
--- /dev/null
+++ b/dev-python/pytest-jupyter/pytest-jupyter-0.7.0.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Pytest plugin for testing Jupyter libraries and extensions"
+HOMEPAGE="
+ https://jupyter.org/
+ https://github.com/jupyter-server/pytest-jupyter/
+ https://pypi.org/project/pytest-jupyter/
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ >=dev-python/jupyter_client-7.4.0[${PYTHON_USEDEP}]
+ >=dev-python/ipykernel-6.14[${PYTHON_USEDEP}]
+ >=dev-python/jupyter-server-1.21[${PYTHON_USEDEP}]
+ >=dev-python/nbformat-5.3[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/pytest-timeout[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest