summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-python/jsonschema/Manifest1
-rw-r--r--dev-python/jsonschema/jsonschema-4.10.0.ebuild55
2 files changed, 56 insertions, 0 deletions
diff --git a/dev-python/jsonschema/Manifest b/dev-python/jsonschema/Manifest
index b88f8c636693..d2609176f013 100644
--- a/dev-python/jsonschema/Manifest
+++ b/dev-python/jsonschema/Manifest
@@ -1,3 +1,4 @@
+DIST jsonschema-4.10.0.tar.gz 286110 BLAKE2B b59e425df6a8d747424ff938de6cbd0eceaa16a1b16b795847f86662a5cbc7953f052f7aaac10109a4c75e69e227d29f3dbfdcd50197be0436f6e36ea02df29a SHA512 765ed96fe086feda9604d3079e78f62e35ab883e8826be57112bd8f7c4fedc385c4e2436b5224a171b3a7c0d18b22162ff0973448b339a8f13043532e52eb06d
DIST jsonschema-4.7.2.tar.gz 278495 BLAKE2B 55c25847e210e0bdd3bec672b4b6a4eb1a2e2ec5167c115c34a2d0b2de079a00eaff8d901386b475fc26660887090896e78e3a38c1805f5b767fa1eece740e3b SHA512 c624d7bf317ca20fd8cdd248ec7d7679fde907ab304f1a092fc7a172464f43e41904d3f88df57e1351043b978448f51166a09af3625f00a9ad4d7353033b80af
DIST jsonschema-4.8.0.tar.gz 279424 BLAKE2B 9e8936bde13841f9edf42ffe214ce8d1aaae8b9be4c3040871f228399a31b4292e8cfbf4bf4261822ca1b88622cb69cdf0d55bd2cc51bf191f6e364e9bfb94f8 SHA512 75a7593eb8b0163ba428f507ed4fd9fa6d51567f284776af96f4d79cb507a69666cc048034bfa3a401f960295779e935562dde4e97cf3f7b3b4571bc28b9dde7
DIST jsonschema-4.9.0.tar.gz 281100 BLAKE2B 5a1c387fc33735ffd39342f3e62600aea721a51be0995d10aa1726e8e4c3bf93694a7844410c0b245c699880d6642a6903525b3637883f5e662086b53deb0948 SHA512 73fc9958f37802c4558ea6893386810784d2b577c04423b7090fce4cd052e3af078f0b0c46b2b16f96bb49820047f1ec5d96cf6c6cb822fca1d988cf1d70209f
diff --git a/dev-python/jsonschema/jsonschema-4.10.0.ebuild b/dev-python/jsonschema/jsonschema-4.10.0.ebuild
new file mode 100644
index 000000000000..ab464e8b5c6a
--- /dev/null
+++ b/dev-python/jsonschema/jsonschema-4.10.0.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( pypy3 python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="An implementation of JSON-Schema validation for Python"
+HOMEPAGE="
+ https://pypi.org/project/jsonschema/
+ https://github.com/python-jsonschema/jsonschema/
+"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ >=dev-python/attrs-17.4.0[${PYTHON_USEDEP}]
+ >=dev-python/pyrsistent-0.18.0[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ >=dev-python/importlib_resources-1.4.0[${PYTHON_USEDEP}]
+ dev-python/pkgutil_resolve_name[${PYTHON_USEDEP}]
+ ' 3.8)
+"
+BDEPEND="
+ dev-python/hatch-vcs[${PYTHON_USEDEP}]
+"
+
+# formatter deps
+RDEPEND+="
+ dev-python/fqdn[${PYTHON_USEDEP}]
+ dev-python/idna[${PYTHON_USEDEP}]
+ dev-python/isoduration[${PYTHON_USEDEP}]
+ >=dev-python/jsonpointer-1.13[${PYTHON_USEDEP}]
+ dev-python/rfc3339-validator[${PYTHON_USEDEP}]
+ dev-python/rfc3986-validator[${PYTHON_USEDEP}]
+ dev-python/rfc3987[${PYTHON_USEDEP}]
+ dev-python/uri_template[${PYTHON_USEDEP}]
+ >=dev-python/webcolors-1.11[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ # requires pip, does not make much sense for the users
+ jsonschema/tests/test_cli.py::TestCLIIntegration::test_license
+ # wtf?
+ jsonschema/tests/test_deprecations.py::TestDeprecations::test_version
+ jsonschema/tests/test_jsonschema_test_suite.py::test_suite_bug
+)